summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2025-01-16 00:46:26 +0000
committerSam James <sam@gentoo.org>2025-01-16 00:46:26 +0000
commit5c8906469d67331984cecf21ba11d4234c243bc3 (patch)
tree79a5764805dd1b589988342d58558d4d33b5c68a /sys-fs
parentdev-python/btrfsutil: drop 6.9.2, 6.10.1, 6.11 (diff)
downloadgentoo-5c8906469d67331984cecf21ba11d4234c243bc3.tar.gz
gentoo-5c8906469d67331984cecf21ba11d4234c243bc3.tar.bz2
gentoo-5c8906469d67331984cecf21ba11d4234c243bc3.zip
sys-fs/ddrescue: add 1.29
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/ddrescue/Manifest1
-rw-r--r--sys-fs/ddrescue/ddrescue-1.29.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/sys-fs/ddrescue/Manifest b/sys-fs/ddrescue/Manifest
index 9333a2af998c..3d5fcee9d482 100644
--- a/sys-fs/ddrescue/Manifest
+++ b/sys-fs/ddrescue/Manifest
@@ -1 +1,2 @@
DIST ddrescue-1.28.tar.lz 93823 BLAKE2B 8c212f0d495e0df8e0398b97730c812ea9ccb77bd42e730198222e9918e3652fc52d932449b1e0dc9bdd453a123e2450c962e33e98d9845ce81b9a934a5bbdaa SHA512 ad3df2361b3b0228e2875792e0f6b301dc4d9cefd3f4fcdbce180a53c32924ee026bd27397b8efc94f40ee10f5f9d453fa72bd19203b6cb90208881e287e2c46
+DIST ddrescue-1.29.tar.lz 96728 BLAKE2B 88eab69f2296464859dc8720930f28f6bc32aa694649e15a99dcd9dfd63ed8ba845d7af347e8b1ee90e954f8317888ec0f2cd90ec98994a7d2b4d654a31adbfc SHA512 b15ca0394a19f0fba577a12c19ffb1d14b0e66a4356bf0e1cdc27ba4edcb208fbce5ca214ddccaa88aa8e116ce76932ba26a14046ccd9c835fefc20557c36cf1
diff --git a/sys-fs/ddrescue/ddrescue-1.29.ebuild b/sys-fs/ddrescue/ddrescue-1.29.ebuild
new file mode 100644
index 000000000000..dc63846261be
--- /dev/null
+++ b/sys-fs/ddrescue/ddrescue-1.29.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs flag-o-matic unpacker
+
+DESCRIPTION="Copy data from one file or block device to another with read-error recovery"
+HOMEPAGE="https://www.gnu.org/software/ddrescue/ddrescue.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.lz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux"
+IUSE="static"
+
+BDEPEND="$(unpacker_src_uri_depends)"
+
+src_configure() {
+ use static && append-ldflags -static
+
+ # not a normal configure script
+ econf \
+ --prefix="${EPREFIX}"/usr \
+ CXX="$(tc-getCXX)" \
+ CPPFLAGS="${CPPFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_test() {
+ ./testsuite/check.sh "${S}"/testsuite || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-man
+ einstalldocs
+}