summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-01-28 20:25:20 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-01-29 00:20:54 +0100
commit7014983e97352f371dc84da1856963a7a9afbadb (patch)
treea39e4bde8b35e73817664cbee73e4d6c3465acc0 /sys-libs/uid_wrapper
parentsys-libs/nss_wrapper: add 1.1.15 (diff)
downloadgentoo-7014983e97352f371dc84da1856963a7a9afbadb.tar.gz
gentoo-7014983e97352f371dc84da1856963a7a9afbadb.tar.bz2
gentoo-7014983e97352f371dc84da1856963a7a9afbadb.zip
sys-libs/uid_wrapper: add 1.3.0
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sys-libs/uid_wrapper')
-rw-r--r--sys-libs/uid_wrapper/Manifest1
-rw-r--r--sys-libs/uid_wrapper/uid_wrapper-1.3.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/sys-libs/uid_wrapper/Manifest b/sys-libs/uid_wrapper/Manifest
index 1aeaf176262c..6c8c1a04e9ca 100644
--- a/sys-libs/uid_wrapper/Manifest
+++ b/sys-libs/uid_wrapper/Manifest
@@ -1 +1,2 @@
DIST uid_wrapper-1.2.9.tar.gz 48150 BLAKE2B bfd52c5a5e6a6a4322cff9fbf9bb2ceee3f5eb004d1174cf1d548bf08eade02453c0b551e006ea30aaa0b147748c6592184a597f9c615da2ed5355fe96222a20 SHA512 561dd8d5b139020f47a908e6baca9197d46f6192c280c23f85fad80fcac3fffb2823200777b0f353f79949cfb45b7dcc21b9a585a4bc21b26632b0e0df11d825
+DIST uid_wrapper-1.3.0.tar.gz 51126 BLAKE2B 9460d50ce7cfa613316bda38678d4918aceb048a5f8bc3d48abd4024fd67b0e6194c543c7f7092041b91b4f72d8bab79858697ee541ccef0486c3aa4cfad2506 SHA512 a66515b701882cf8ac62c6aae719eb07a46b852ecfd5274c7a1f038b066db85fbc0cdf4fff2c79e7b1e45d08622cd90884498f668fe479989e47e79ecd932095
diff --git a/sys-libs/uid_wrapper/uid_wrapper-1.3.0.ebuild b/sys-libs/uid_wrapper/uid_wrapper-1.3.0.ebuild
new file mode 100644
index 000000000000..36e256bc8e52
--- /dev/null
+++ b/sys-libs/uid_wrapper/uid_wrapper-1.3.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="Wrapper to fake privilege separation"
+HOMEPAGE="https://cwrap.org/uid_wrapper.html"
+SRC_URI="https://www.samba.org/ftp/pub/cwrap/${P}.tar.gz
+ https://ftp.samba.org/pub/cwrap/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-util/cmocka )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUNIT_TESTING=$(usex test)
+ )
+
+ cmake-multilib_src_configure
+}