summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Schollmeyer <nex+b-g-o@nexadn.de>2024-09-22 15:33:04 +0200
committerFlorian Schmaus <flow@gentoo.org>2024-11-05 11:30:21 +0100
commit3e00a46f281453703cce0b6ec9e310a0cd0d39e1 (patch)
tree9a499c9286962a4139fa37651494dd218069d924 /sys-process
parentsys-process/btop: drop 1.2.13-r2, 1.3.0 (diff)
downloadgentoo-3e00a46f281453703cce0b6ec9e310a0cd0d39e1.tar.gz
gentoo-3e00a46f281453703cce0b6ec9e310a0cd0d39e1.tar.bz2
gentoo-3e00a46f281453703cce0b6ec9e310a0cd0d39e1.zip
sys-process/btop: add 1.4.0
This verbump removes most keywords as the new dependency app-text/lowdown is not keyworded for these. Rekeywording is planned. Signed-off-by: Adrian Schollmeyer <nex+b-g-o@nexadn.de> Closes: https://github.com/gentoo/gentoo/pull/39206 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/btop/Manifest1
-rw-r--r--sys-process/btop/btop-1.4.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/sys-process/btop/Manifest b/sys-process/btop/Manifest
index a9b5eaefcd19..ad3a83992dad 100644
--- a/sys-process/btop/Manifest
+++ b/sys-process/btop/Manifest
@@ -1 +1,2 @@
DIST btop-1.3.2.tar.gz 1144620 BLAKE2B dfe351fff0b9e0aa376ebc93d76e1542a1cd93eec695bc9056cd296a11d563d676a0f0a61e911d20cbbaef276feb5bf20cafbc5f063475393b82139e0d08386a SHA512 9bbe983aa1336566f78396b829d49c22fe709e4e3d959dabc7524b61defba2638f3b0c50658f755fd1f02dd70572c78cc3cfc8b01772e174d0f34a48e4e178b2
+DIST btop-1.4.0.gh.tar.gz 1239400 BLAKE2B 360b56fc0dab9bc017a4971ffe32cdbe2939b09949f0b4e1d12de5c7b91e6c540d1837c12184b298e35d26c972928d9dd2ef454dbac6464480f3f3e13123545d SHA512 7b7c63daf68192893ae4533c04ea70dcd6f253e188b1c842f2ebebac0b28e51431edef6ccfce5b25b3adbd5b2b637fc832bce7d5d64d664c2bf5c4672be75c8f
diff --git a/sys-process/btop/btop-1.4.0.ebuild b/sys-process/btop/btop-1.4.0.ebuild
new file mode 100644
index 000000000000..12ec79054479
--- /dev/null
+++ b/sys-process/btop/btop-1.4.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake optfeature toolchain-funcs xdg
+
+DESCRIPTION="A monitor of resources"
+HOMEPAGE="https://github.com/aristocratos/btop"
+SRC_URI="
+ https://github.com/aristocratos/btop/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+BDEPEND="
+ app-text/lowdown
+"
+
+DOCS=( "README.md" "CHANGELOG.md" )
+
+pkg_setup() {
+ if [[ "${MERGE_TYPE}" != "binary" ]]; then
+ if tc-is-clang ; then
+ if [[ "$(clang-major-version)" -lt 16 ]]; then
+ die "sys-process/btop requires >=sys-devel/clang-16.0.0 to build."
+ fi
+ elif ! tc-is-gcc ; then
+ die "$(tc-getCXX) is not a supported compiler. Please use sys-devel/gcc or >=sys-devel/clang-16.0.0 instead."
+ fi
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBTOP_GPU=true
+ -DBTOP_RSMI_STATIC=false
+ -DBTOP_STATIC=false
+ # These settings can be controlled in make.conf CFLAGS/CXXFLAGS
+ -DBTOP_FORTIFY=false
+ -DBTOP_LTO=false
+ -DBTOP_WERROR=false
+ -DBTOP_USE_MOLD=false
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "GPU monitoring support (Radeon GPUs)" dev-util/rocm-smi
+ optfeature "GPU monitoring support (NVIDIA GPUs)" x11-drivers/nvidia-drivers
+}