summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-11-25 17:04:44 +0100
committerMichał Górny <mgorny@gentoo.org>2016-11-25 17:17:58 +0100
commit8a9c5d375b606aaa7b36fb42ae9c0ce551167011 (patch)
tree9ce1720b2cb8b94f1865a2f71d362881cd4e4037 /virtual/python-ipaddress/python-ipaddress-1.0-r1.ebuild
parentdev-python/backports-abc: Enable python3.5 support (diff)
downloadgentoo-8a9c5d375b606aaa7b36fb42ae9c0ce551167011.tar.gz
gentoo-8a9c5d375b606aaa7b36fb42ae9c0ce551167011.tar.bz2
gentoo-8a9c5d375b606aaa7b36fb42ae9c0ce551167011.zip
virtual/python-ipaddress: ipaddress module is built-in in pypy3
Diffstat (limited to 'virtual/python-ipaddress/python-ipaddress-1.0-r1.ebuild')
-rw-r--r--virtual/python-ipaddress/python-ipaddress-1.0-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/virtual/python-ipaddress/python-ipaddress-1.0-r1.ebuild b/virtual/python-ipaddress/python-ipaddress-1.0-r1.ebuild
new file mode 100644
index 000000000000..1c3d69a5060e
--- /dev/null
+++ b/virtual/python-ipaddress/python-ipaddress-1.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy pypy3 )
+
+inherit python-r1
+
+DESCRIPTION="A virtual for Python ipaddress module"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/ipaddress[${PYTHON_USEDEP}]' \
+ python2_7 pypy)"