summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apache/mod_backtrace
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apache/mod_backtrace')
-rw-r--r--www-apache/mod_backtrace/Manifest1
-rw-r--r--www-apache/mod_backtrace/files/10_mod_backtrace.conf4
-rw-r--r--www-apache/mod_backtrace/metadata.xml11
-rw-r--r--www-apache/mod_backtrace/mod_backtrace-2.01.ebuild36
4 files changed, 52 insertions, 0 deletions
diff --git a/www-apache/mod_backtrace/Manifest b/www-apache/mod_backtrace/Manifest
new file mode 100644
index 000000000000..e1cf2652eead
--- /dev/null
+++ b/www-apache/mod_backtrace/Manifest
@@ -0,0 +1 @@
+DIST wku_bt-2.01.zip 933169 SHA256 3033a07b284a67e519e3b2d09a255b9cd8ce5902d3d9971d4cf182dec75c7d27 SHA512 c1bde8a26b395fc5fc66cd83c9282a8c519f34d27bef628ec502cec4245a7d446300178c9c94a5c5c0eb817bb8dd146587607760f9c9e780986d6ec53f03fb4c WHIRLPOOL dc2fa4debac883909f084562ffa0d9ab9e7f60a76bd02ee0054a0258444165f6fa63490bfefeaa03fe476ca9abc1ba93e2ad60858ba3ee4611b227b48e49bf1f
diff --git a/www-apache/mod_backtrace/files/10_mod_backtrace.conf b/www-apache/mod_backtrace/files/10_mod_backtrace.conf
new file mode 100644
index 000000000000..822efd2667fb
--- /dev/null
+++ b/www-apache/mod_backtrace/files/10_mod_backtrace.conf
@@ -0,0 +1,4 @@
+<IfDefine BACKTRACE>
+ LoadModule backtrace_module modules/mod_backtrace.so
+ EnableExceptionHook On
+</IfDefine>
diff --git a/www-apache/mod_backtrace/metadata.xml b/www-apache/mod_backtrace/metadata.xml
new file mode 100644
index 000000000000..e4ed96ad54c9
--- /dev/null
+++ b/www-apache/mod_backtrace/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+<use>
+ <flag name="unwind">
+ Use <pkg>sys-libs/libunwind</pkg> to provide better resolution of
+ function names.
+ </flag>
+</use>
+</pkgmetadata>
diff --git a/www-apache/mod_backtrace/mod_backtrace-2.01.ebuild b/www-apache/mod_backtrace/mod_backtrace-2.01.ebuild
new file mode 100644
index 000000000000..6c3bf16e8b59
--- /dev/null
+++ b/www-apache/mod_backtrace/mod_backtrace-2.01.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit apache-module depend.apache
+
+DESCRIPTION="Debug segmentation faults in Apache threads"
+HOMEPAGE="http://emptyhammock.com/projects/httpd/diag/"
+SRC_URI="http://emptyhammock.com/downloads/wku_bt-${PV}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="unwind"
+
+RDEPEND="=www-servers/apache-2*[debug]
+ unwind? ( sys-libs/libunwind )"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+APACHE2_MOD_CONF="10_${PN}"
+APACHE2_MOD_DEFINE="BACKTRACE"
+
+need_apache2
+
+S="${WORKDIR}/wku_bt-${PV}"
+
+src_compile() {
+ APXS2_ARGS="-c ${PN}.c diag.c -ldl"
+ if use unwind; then
+ APXS2_ARGS+=" -lunwind -DDIAG_HAVE_LIBUNWIND_BACKTRACE=1"
+ fi
+ apache-module_src_compile
+}