summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-05-18 07:18:13 +0300
committerViorel Munteanu <ceamac@gentoo.org>2023-05-18 07:18:13 +0300
commita22c2df1a867951b9ce232c061b2dce52f90d1b4 (patch)
tree5a17da76f50feb8586a9b7eba3fc5bad0e0a69a7 /www-apps
parentwww-apps/dokuwiki: add 20230404a (diff)
downloadgentoo-a22c2df1a867951b9ce232c061b2dce52f90d1b4.tar.gz
gentoo-a22c2df1a867951b9ce232c061b2dce52f90d1b4.tar.bz2
gentoo-a22c2df1a867951b9ce232c061b2dce52f90d1b4.zip
www-apps/dokuwiki: drop 20230404
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/dokuwiki/Manifest1
-rw-r--r--www-apps/dokuwiki/dokuwiki-20230404.ebuild86
2 files changed, 0 insertions, 87 deletions
diff --git a/www-apps/dokuwiki/Manifest b/www-apps/dokuwiki/Manifest
index 15f1d97987b4..8d185a2f2127 100644
--- a/www-apps/dokuwiki/Manifest
+++ b/www-apps/dokuwiki/Manifest
@@ -1,2 +1 @@
-DIST dokuwiki-2023-04-04.tgz 4032792 BLAKE2B 32bc42d6fd5d869bfc08ee8fc7214f42dfdb4812eea74d04d2566dc3c75f5a7069b62bbc0b8eaca389322d971ffc35c6d40e8257658e38f9cebf96ab2bd47bd6 SHA512 1539f9306916ce1f759a07168a02dab05ee044b3637ce96cf94d67b84027f5774cb2a9f493c8067ff70176d7b018c54cded1251e35022c8f9dfed74fd4fa501f
DIST dokuwiki-2023-04-04a.tgz 4043928 BLAKE2B a18372b04bd10760236ec4f976a87fed800601a541ebb6aaa07b302c8462286da3094aa102194a101c59ceacde99d0c865f938b8eb732cf09e8e7f0b5f40ea8e SHA512 748af27b2d226437f87461522254fca5e65c7572fdc20e75259944b388e3888a85f61120d1c22c671d3a302ac6791e463a0d3418f2fcf23bf046116107b11ab8
diff --git a/www-apps/dokuwiki/dokuwiki-20230404.ebuild b/www-apps/dokuwiki/dokuwiki-20230404.ebuild
deleted file mode 100644
index c6d2a56a3fa0..000000000000
--- a/www-apps/dokuwiki/dokuwiki-20230404.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit webapp
-
-# upstream uses dashes in the datestamp
-MY_BASE_PV="${PV:0:4}-${PV:4:2}-${PV:6:2}"
-
-if [[ ${PV} == *rc* ]]; then
- MY_PV="${MY_BASE_PV}${PV:8:4}"
- MY_P="${PN}-rc-${MY_BASE_PV}"
- S="${WORKDIR}/${MY_P}"
- SRC_URI="https://download.dokuwiki.org/src/${PN}/${PN}-rc.tgz -> ${PN}-${PV}.tgz"
-else
- MY_PV="${MY_BASE_PV}${PV:8:4}"
- SRC_URI="https://download.dokuwiki.org/src/${PN}/${PN}-${MY_PV}.tgz"
- S="${WORKDIR}/${PN}-${MY_PV}"
-fi
-
-DESCRIPTION="DokuWiki is a simple to use Wiki aimed at a small company's documentation needs"
-HOMEPAGE="https://wiki.dokuwiki.org"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~riscv ~sparc ~x86"
-IUSE="gd"
-
-DEPEND=""
-RDEPEND="
- >=dev-lang/php-7.4[xml]
- virtual/httpd-php:*
- gd? ( ||
- (
- dev-lang/php[gd]
- media-gfx/imagemagick
- )
- )
-"
-
-need_httpd_cgi
-
-src_prepare() {
- # create initial changes file
- touch data/changes.log
-
- default
-}
-
-src_install() {
- webapp_src_preinst
-
- dodoc README
- rm -f README COPYING
-
- docinto scripts
- dodoc bin/*
- rm -rf bin
-
- insinto "${MY_HTDOCSDIR}"
- doins -r .
-
- # Copy custom .htaccess that works with both apache 2.2 and 2.4
- for dir in "conf" "data" "inc" "inc/lang"; do
- insinto "${MY_HTDOCSDIR}/${dir}"
- newins "${FILESDIR}/htaccess" ".htaccess"
- done
-
- # Use custom .htaccess.dist that works with both apache 2.2 and 2.4
- insinto "${MY_HTDOCSDIR}/"
- newins "${FILESDIR}/htaccess-dist" ".htaccess.dist"
-
- for x in $(find data/ -not -name '.htaccess'); do
- webapp_serverowned "${MY_HTDOCSDIR}"/${x}
- done
-
- webapp_configfile "${MY_HTDOCSDIR}"/.htaccess.dist
- webapp_configfile "${MY_HTDOCSDIR}"/conf
-
- for x in $(find conf/ -not -name 'msg'); do
- webapp_configfile "${MY_HTDOCSDIR}"/${x}
- done
-
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
- webapp_src_install
-}