summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-12-21 09:04:23 +1000
committerMatt Jolly <kangie@gentoo.org>2024-12-21 09:07:10 +1000
commiteac519507566e45092ddcef566b8ca7e03630085 (patch)
tree72d06978ff0ed90b37a7cc83fa5f63671861ea9e /www-client
parentwww-client/opera: remove old (diff)
downloadgentoo-eac519507566e45092ddcef566b8ca7e03630085.tar.gz
gentoo-eac519507566e45092ddcef566b8ca7e03630085.tar.bz2
gentoo-eac519507566e45092ddcef566b8ca7e03630085.zip
www-client/opera-beta: automated bump (116.0.5366.13)
Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/opera-beta/Manifest1
-rw-r--r--www-client/opera-beta/opera-beta-116.0.5366.13.ebuild173
2 files changed, 174 insertions, 0 deletions
diff --git a/www-client/opera-beta/Manifest b/www-client/opera-beta/Manifest
index f5e6df0ca3f0..01433b19852b 100644
--- a/www-client/opera-beta/Manifest
+++ b/www-client/opera-beta/Manifest
@@ -1,3 +1,4 @@
DIST opera-beta_115.0.5322.58_amd64.deb 128403936 BLAKE2B 90d0abc5b44d5eb40fe32cc4e2102d0434513f00f5e8fd67b53716cee380f80e5fda5eec95be71c2253cd7f1d81cef60bdae19abe1d1758e6df2953255f73fa6 SHA512 729826a40c8b81fa178cce957f323efa9befda61a218cf4e4b6040193510eaf294f90d6807b2853a0366035b85aa330a004402baa7d7fffe6fa7b1b7afd251aa
+DIST opera-beta_116.0.5366.13_amd64.deb 124345880 BLAKE2B f374a0a5167c7d571334d6369d9addf97375cbd34e90d301b6ac6fdcb301c8554e63c8d4fcabfad9e59aeaeb6d3a4b03566d69d9649b526c977a3fd84c92844b SHA512 4ad232663b1f224ec2ec544297fe3b0a34feb819d8b1e1d441e13d4337a6de835a8d9eaa656b88ba68727936a297ea8b6636ea1d7c7000a78ac924057690027f
DIST opera-beta_116.0.5366.5_amd64.deb 125047088 BLAKE2B 178f890dbfa409dd22436d175d7166026b0e1d6f5851efac6fd3ca81e609c0a0766c533964649c9dcc2b28747c48e19282f05e8a46f5e94513119c5a4349217e SHA512 fe774dc93ca287ebd5c2fe1ceef550d3393d77c61d3675b025b8b0d85cb68c7c7b3190ea0f86f8dc49a98cfde1ce995ef1a31dd70c7895dd2cb484da2791493d
DIST opera-beta_116.0.5366.7_amd64.deb 125054764 BLAKE2B 08c80ce7acd935102c26bf10fd90681af1a3287f8dc9528b336b501eb34e1f37a91d43f37be31aa712c6f3595f717a25de865e81547507ee52e8f33aeff1af1f SHA512 2a12ec9eeceb87ade212b32338e7d2b91af642baafc2435b31248acadc064b014a2ddc4a01a0333162a854653b8b1dc9d1890af2d424c2922337f55f2835c340
diff --git a/www-client/opera-beta/opera-beta-116.0.5366.13.ebuild b/www-client/opera-beta/opera-beta-116.0.5366.13.ebuild
new file mode 100644
index 000000000000..1cab05aa0a7e
--- /dev/null
+++ b/www-client/opera-beta/opera-beta-116.0.5366.13.ebuild
@@ -0,0 +1,173 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CHROMIUM_LANGS="
+ bg bn ca cs da de el en-GB en-US es-419 es fil fi fr hi hr hu id
+ it ja ko lt lv ms nb nl pl pt-BR pt-PT ro ru sk sr sv sw ta te th tr uk vi
+ zh-CN zh-TW
+"
+
+# These are intended for ebuild maintainer use to force RPM if DEB is not available.
+: ${OPERA_FORCE_RPM=no}
+
+inherit chromium-2 pax-utils xdg
+
+if [[ ${OPERA_FORCE_RPM} == yes ]]; then
+ inherit rpm
+ OPERA_ARCHIVE_EXT="rpm"
+else
+ inherit unpacker
+ OPERA_ARCHIVE_EXT="deb"
+fi
+
+DESCRIPTION="A fast and secure web browser"
+HOMEPAGE="https://www.opera.com/"
+
+SRC_URI_BASE=(
+ "https://download1.operacdn.com/pub/${PN}"
+ "https://download2.operacdn.com/pub/${PN}"
+ "https://download3.operacdn.com/pub/${PN}"
+ "https://download4.operacdn.com/pub/${PN}"
+)
+
+if [[ ${PN} == opera ]]; then
+ MY_PN=${PN}-stable
+ SRC_URI_BASE=( "${SRC_URI_BASE[@]/%//desktop}" )
+else
+ MY_PN=${PN}
+fi
+
+# Commit ref from `strings libffmpeg.so | grep -F "FFmpeg version"` matches this Chromium version
+# used to select the correct ffmpeg-chromium version (corresponds to a major version of Chromium)
+# Does not need to be updated for every new version of Opera, only when it breaks
+CHROMIUM_VERSION="131"
+SRC_URI="${SRC_URI_BASE[@]/%//${PV}/linux/${MY_PN}_${PV}_amd64.${OPERA_ARCHIVE_EXT}}"
+S=${WORKDIR}
+
+LICENSE="OPERA-2018"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE="+ffmpeg-chromium +proprietary-codecs +suid qt5 qt6"
+RESTRICT="bindist mirror strip"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ gnome-base/gsettings-desktop-schemas
+ media-libs/alsa-lib
+ media-libs/mesa[gbm(+)]
+ net-misc/curl
+ net-print/cups
+ sys-apps/dbus
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libxcb
+ x11-libs/libxkbcommon
+ x11-libs/libxshmfence
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/pango
+ proprietary-codecs? (
+ !ffmpeg-chromium? ( >=media-video/ffmpeg-6.1-r1:0/58.60.60[chromium] )
+ ffmpeg-chromium? ( media-video/ffmpeg-chromium:${CHROMIUM_VERSION} )
+ )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5[X]
+ dev-qt/qtwidgets:5
+ )
+ qt6? ( dev-qt/qtbase:6[gui,widgets] )
+"
+
+QA_PREBUILT="*"
+OPERA_HOME="opt/opera${PN#opera}"
+
+pkg_pretend() {
+ # Protect against people using autounmask overzealously
+ use amd64 || die "opera only works on amd64"
+}
+
+pkg_setup() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_unpack() {
+ :
+}
+
+src_install() {
+ dodir /
+ cd "${ED}" || die
+ if [[ ${OPERA_FORCE_RPM} == yes ]]; then
+ rpm_src_unpack "${A[0]}"
+ else
+ unpacker
+ fi
+
+ # move to /opt, bug #573052
+ mkdir -p "${OPERA_HOME%${PN}}"
+ if [[ ${OPERA_FORCE_RPM} == yes ]]; then
+ mv "usr/lib64/${PN}" "${OPERA_HOME%${PN}}" || die
+ else
+ mv "usr/lib/x86_64-linux-gnu/${PN}" "${OPERA_HOME%${PN}}" || die
+ fi
+ rm -r "usr/lib" || die
+
+ # disable auto update
+ rm "${OPERA_HOME}/${PN%-*}_autoupdate"{,.licenses,.version} || die
+
+ if [[ ${OPERA_FORCE_RPM} == yes ]]; then
+ rm "${OPERA_HOME}/setup_repo.sh" || die
+ else
+ rm -r "usr/share/lintian" || die
+
+ # fix docs
+ mv usr/share/doc/${MY_PN} usr/share/doc/${PF} || die
+ gzip -d usr/share/doc/${PF}/changelog.gz || die
+ fi
+
+ # fix desktop file
+ sed -i \
+ -e 's|^TargetEnvironment|X-&|g' \
+ usr/share/applications/${PN}.desktop || die
+
+ # remove unused language packs
+ pushd "${OPERA_HOME}/localization" > /dev/null || die
+ chromium_remove_language_paks
+ popd > /dev/null || die
+
+ # setup opera symlink
+ rm "usr/bin/${PN}" || die
+ dosym "../../${OPERA_HOME}/${PN}" "/usr/bin/${PN}"
+
+ # install proprietary codecs
+ rm "${OPERA_HOME}/resources/ffmpeg_preload_config.json" || die
+ if use proprietary-codecs; then
+ dosym ../../usr/$(get_libdir)/chromium/libffmpeg.so$(usex ffmpeg-chromium .${CHROMIUM_VERSION} "") \
+ /${OPERA_HOME}/libffmpeg.so
+ fi
+
+ if ! use qt5; then
+ rm "${OPERA_HOME}/libqt5_shim.so" || die
+ fi
+ if ! use qt6; then
+ rm "${OPERA_HOME}/libqt6_shim.so" || die
+ fi
+
+ # pax mark opera, bug #562038
+ pax-mark m "${OPERA_HOME}/opera"
+ # enable suid sandbox if requested
+ use suid && fperms 4711 "/${OPERA_HOME}/opera_sandbox"
+}