summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-06-17 14:14:38 -0400
committerMatt Turner <mattst88@gentoo.org>2022-06-17 14:16:02 -0400
commit358c8172c1e5e26a85a0b6b51495bbff897a08c3 (patch)
tree17cc18d196a944bbde06942e7cafa16c7ec5d41a /x11-libs
parentmedia-libs/waffle: Revbump for xcb-proto multilib removal (diff)
downloadgentoo-358c8172c1e5e26a85a0b6b51495bbff897a08c3.tar.gz
gentoo-358c8172c1e5e26a85a0b6b51495bbff897a08c3.tar.bz2
gentoo-358c8172c1e5e26a85a0b6b51495bbff897a08c3.zip
x11-libs/xcb-util-cursor: Revbump for xcb-proto multilib removal
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.3-r4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.3-r4.ebuild b/x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.3-r4.ebuild
new file mode 100644
index 000000000000..60cd1a1dc7c5
--- /dev/null
+++ b/x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.3-r4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_MULTILIB=yes
+inherit xorg-3
+
+DESCRIPTION="X C-language Bindings sample implementations"
+HOMEPAGE="https://xcb.freedesktop.org/ https://gitlab.freedesktop.org/xorg/lib/libxcb-cursor"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x64-solaris"
+
+RDEPEND=">=x11-libs/libxcb-1.9.1:=[${MULTILIB_USEDEP}]
+ >=x11-libs/xcb-util-image-0.3.9-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/xcb-util-renderutil-0.3.9[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ >=x11-base/xcb-proto-1.8-r3:=
+ x11-base/xorg-proto"
+BDEPEND=">=dev-util/gperf-3.0.1"
+
+XORG_CONFIGURE_OPTIONS=(
+ --with-cursorpath='~/.cursors:~/.icons:/usr/local/share/cursors/xorg-x11:/usr/local/share/cursors:/usr/local/share/icons:/usr/local/share/pixmaps:/usr/share/cursors/xorg-x11:/usr/share/cursors:/usr/share/pixmaps/xorg-x11:/usr/share/icons:/usr/share/pixmaps'
+)