summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2023-01-18 00:33:21 +0100
committerSebastian Pipping <sping@gentoo.org>2023-01-18 00:33:21 +0100
commit0066a0410749f668d0ec4f90b15d2491f2290dd4 (patch)
tree43b504f97f638f46d011e9b36fe7cc3714ecd25b /x11-misc/arandr/arandr-0.1.11.ebuild
parentwww-client/httrack: 3.49.4 (diff)
downloadgentoo-0066a0410749f668d0ec4f90b15d2491f2290dd4.tar.gz
gentoo-0066a0410749f668d0ec4f90b15d2491f2290dd4.tar.bz2
gentoo-0066a0410749f668d0ec4f90b15d2491f2290dd4.zip
x11-misc/arandr: 0.1.11 with Python 3.11 fixes
Closes: https://bugs.gentoo.org/889986 Closes: https://bugs.gentoo.org/891227 Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Diffstat (limited to 'x11-misc/arandr/arandr-0.1.11.ebuild')
-rw-r--r--x11-misc/arandr/arandr-0.1.11.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/x11-misc/arandr/arandr-0.1.11.ebuild b/x11-misc/arandr/arandr-0.1.11.ebuild
new file mode 100644
index 000000000000..1070e68f54ef
--- /dev/null
+++ b/x11-misc/arandr/arandr-0.1.11.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="Another XRandR GUI"
+HOMEPAGE="https://christian.amsuess.com/tools/arandr/"
+SRC_URI="https://christian.amsuess.com/tools/arandr/files/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ dev-python/pygobject:3=[${PYTHON_USEDEP},cairo]
+ x11-libs/gtk+:3[introspection]
+ x11-apps/xrandr
+"
+BDEPEND="dev-python/docutils[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}/${PN}-0.1.10-manpages.patch" )