summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-12-20 12:20:11 +0100
committerPacho Ramos <pacho@gentoo.org>2024-12-20 12:21:43 +0100
commit4c01c231a9a64fbf7f65ec7ee258d6b00d130a6d (patch)
treeb01cfeff8fc1cdb58811162e78bbb1ad71435435 /x11-plugins
parentx11-misc/virtualgl: drop 3.0.2, 3.1-r1 (diff)
downloadgentoo-4c01c231a9a64fbf7f65ec7ee258d6b00d130a6d.tar.gz
gentoo-4c01c231a9a64fbf7f65ec7ee258d6b00d130a6d.tar.bz2
gentoo-4c01c231a9a64fbf7f65ec7ee258d6b00d130a6d.zip
x11-plugins/pidgin-indicator: add 1.0.2
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/pidgin-indicator/Manifest1
-rw-r--r--x11-plugins/pidgin-indicator/pidgin-indicator-1.0.2.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-indicator/Manifest b/x11-plugins/pidgin-indicator/Manifest
index 7f72b3049513..4357f73c8963 100644
--- a/x11-plugins/pidgin-indicator/Manifest
+++ b/x11-plugins/pidgin-indicator/Manifest
@@ -1 +1,2 @@
DIST pidgin-indicator-1.0.1.tar.bz2 311197 BLAKE2B 53c29c5c549f77caabbbbea69c447c2c092e063ee8d1a082507ec195ef7be45bf150e7831ff27c7759c79fc31ce289cd374fb7734f5171a9853e5fd37ac05bd3 SHA512 a39a285309242cfd121cff6aa6466cc2d6b4e37787cce87b9b7ed00a4147fee8ce2e9c6817212680c81b20b9c0bf7dac5d501861e6feffd8d0479a8293ad8201
+DIST pidgin-indicator-1.0.2.tar.bz2 309475 BLAKE2B b8ce1fe5248cde5ad1261ad1b5bb30c8bbc5681d2ddd0414b8b156aea509c0a8494692ba70cf5fdb584dfb44e5ca3264c72305a5e1f86dd2c48ab7f6707f09e8 SHA512 e8f13cdb975bd96c3edfbd75210a093bdef0216774860c85fbf8b7f4caa90a7da7ec32cd0143dd43c283e90f210d93b32fc54f8f718c18f1c49381a8f4e3a5ab
diff --git a/x11-plugins/pidgin-indicator/pidgin-indicator-1.0.2.ebuild b/x11-plugins/pidgin-indicator/pidgin-indicator-1.0.2.ebuild
new file mode 100644
index 000000000000..063da242face
--- /dev/null
+++ b/x11-plugins/pidgin-indicator/pidgin-indicator-1.0.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit xdg
+
+DESCRIPTION="AppIndicator/KStatusNotifierItem plugin for Pidgin"
+HOMEPAGE="https://github.com/philipl/pidgin-indicator"
+SRC_URI="https://github.com/philipl/pidgin-indicator/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+IUSE=""
+
+# No direct gtk3 until pidgin migrates:
+# https://github.com/philipl/pidgin-indicator/issues/32
+RDEPEND="
+ dev-libs/libayatana-appindicator
+ net-im/pidgin[gtk]
+"
+DEPEND="${RDEPEND}
+ dev-perl/XML-Parser
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}