summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-05-24 09:17:07 +0100
committerMarek Szuba <marecki@gentoo.org>2022-05-24 09:55:30 +0100
commit2ba93014df220068af34f18299363a17d530a278 (patch)
treee2bf542a6571ea2f43364f4eba4457f93196bce6 /x11-wm
parentapp-dicts/sword-ChiSB: update Chinese longdescription lang tag (diff)
downloadgentoo-2ba93014df220068af34f18299363a17d530a278.tar.gz
gentoo-2ba93014df220068af34f18299363a17d530a278.tar.bz2
gentoo-2ba93014df220068af34f18299363a17d530a278.zip
x11-wm/awesome: update live ebuild
1. EAPI 7 -> 8 2. Tests require x11-apps/xeyes 2. Add lua5.4 to LUA_COMPAT, it has been supported upstream since 2022-01-22. Note that according to ArchFeh older Lua versions do not handle current versions of config files any more, even though upstream CI continues to test (and passes against) them. If the former persists in the next release we will likely drop support for older Lua versions, in the meantime however follow upstream compatibility matrix. Suggested-by: ArchFeh <guyu2876@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/25548 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/awesome/awesome-9999.ebuild24
1 files changed, 14 insertions, 10 deletions
diff --git a/x11-wm/awesome/awesome-9999.ebuild b/x11-wm/awesome/awesome-9999.ebuild
index a85f6654445b..5e0c5ca5953e 100644
--- a/x11-wm/awesome/awesome-9999.ebuild
+++ b/x11-wm/awesome/awesome-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-LUA_COMPAT=( lua5-{1..3} luajit )
+LUA_COMPAT=( lua5-{1..4} luajit )
inherit cmake desktop lua-single pax-utils
@@ -24,7 +24,8 @@ IUSE="dbus doc gnome test"
REQUIRED_USE="${LUA_REQUIRED_USE}"
-RESTRICT="test" # https://bugs.gentoo.org/654084
+# Doesn't play nicely with the sandbox + requires an active D-BUS session
+RESTRICT="test"
RDEPEND="${LUA_DEPS}
dev-libs/glib:2
@@ -44,11 +45,6 @@ RDEPEND="${LUA_DEPS}
x11-libs/libxkbcommon[X]
x11-libs/libX11
dbus? ( sys-apps/dbus )"
-# ldoc is used by invoking its executable, hence no need for LUA_SINGLE_USEDEP.
-# On the other hand, it means that we should explicitly depend on a version
-# migrated to Lua eclasses so that during the upgrade from unslotted
-# to slotted dev-lang/lua, the package manager knows to emerge migrated
-# ldoc before migrated awesome.
DEPEND="${RDEPEND}
x11-base/xcb-proto
x11-base/xorg-proto
@@ -60,11 +56,19 @@ DEPEND="${RDEPEND}
')
)"
# graphicsmagick's 'convert -channel' has no Alpha support, bug #352282
+# ldoc is used by invoking its executable, hence no need for LUA_SINGLE_USEDEP.
+# On the other hand, it means that we should explicitly depend on a version
+# migrated to Lua eclasses so that during the upgrade from unslotted
+# to slotted dev-lang/lua, the package manager knows to emerge migrated
+# ldoc before migrated awesome.
BDEPEND="app-text/asciidoc
media-gfx/imagemagick[png]
virtual/pkgconfig
doc? ( >=dev-lua/ldoc-1.4.6-r100 )
- test? ( app-shells/zsh )"
+ test? (
+ app-shells/zsh
+ x11-apps/xeyes
+ )"
# Skip installation of README.md by einstalldocs, which leads to broken symlink
DOCS=()