summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-16 13:57:17 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-16 13:57:17 +0200
commit1cdbad41e6ff1fedf610687f16bb4ff01bcc522b (patch)
treee5d37129219f22e83bb9072b5c3a2fdceb3bdc74 /xfce-base/thunar
parentnet-libs/signond: qhelpgenerator is in dev-qt/qthelp (diff)
downloadgentoo-1cdbad41e6ff1fedf610687f16bb4ff01bcc522b.tar.gz
gentoo-1cdbad41e6ff1fedf610687f16bb4ff01bcc522b.tar.bz2
gentoo-1cdbad41e6ff1fedf610687f16bb4ff01bcc522b.zip
xfce-base/thunar: Bump to 4.17.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base/thunar')
-rw-r--r--xfce-base/thunar/Manifest1
-rw-r--r--xfce-base/thunar/thunar-4.17.10.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/xfce-base/thunar/Manifest b/xfce-base/thunar/Manifest
index 763f7da908dd..e78573af2867 100644
--- a/xfce-base/thunar/Manifest
+++ b/xfce-base/thunar/Manifest
@@ -1,2 +1,3 @@
DIST thunar-4.16.11.tar.bz2 2326592 BLAKE2B 0e077f2b4bba613849d3dabaebfa652fd99cc2d1035320016fd4e87597e1af1f6330c2758feead307c6182784de65a358058e2a482f2e287447cdd05d00c8404 SHA512 41b390ce269911e4f0b83c07bf910274cf13afcd293389b156457764a0c771dcb87c03976debe0c4ce06c6a5eeca32fd043cbc3e92d4c7ea8fb00da973b06404
+DIST thunar-4.17.10.tar.bz2 2796649 BLAKE2B 3d18bddc1c07bc7ed7aac7334a83d8cd6abc5c455f217db34edb36d6fe10ee3d0176e29472e799d0013635dec23578886abea0859b3691047e0e97d671651f2f SHA512 61e0d49016bce27a47f1fd6af12638fd8ab096976cc3a29c473a1b0ffcfca8bd9f624b02509846c3fae1425ca1748ea3ad1db0935e09e9af0653056c33570b63
DIST thunar-4.17.9.tar.bz2 2786205 BLAKE2B 2b497e8653fe83581fcec78959dafce3764c98564cfa36bfe26a7cdf2aa3f0b8bf7c41b5e002ca3999931c21856adec74ea2f5f3d863da89bd6e89025f5a83c1 SHA512 029d7e893cbe38d5c968dd9ac6141b52c513bcb7bb1c9a566082e51bd86f22993acf8ba65cba05d341558a06c57aa36e51dbf702044fd3ea0176a88fae158cc2
diff --git a/xfce-base/thunar/thunar-4.17.10.ebuild b/xfce-base/thunar/thunar-4.17.10.ebuild
new file mode 100644
index 000000000000..f46b2ce1f0ca
--- /dev/null
+++ b/xfce-base/thunar/thunar-4.17.10.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="File manager for the Xfce desktop environment"
+HOMEPAGE="
+ https://www.xfce.org/projects/
+ https://docs.xfce.org/xfce/thunar/start
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="exif introspection libnotify pcre +trash-panel-plugin udisks"
+
+DEPEND="
+ >=dev-libs/glib-2.66
+ >=x11-libs/gdk-pixbuf-2.14
+ >=x11-libs/gtk+-3.22:3
+ >=xfce-base/exo-4.17.0:=
+ >=xfce-base/libxfce4ui-4.17.6:=
+ >=xfce-base/libxfce4util-4.17.2:=
+ >=xfce-base/xfconf-4.12:=
+ exif? ( >=media-libs/libexif-0.6.19:= )
+ introspection? ( dev-libs/gobject-introspection:= )
+ libnotify? ( >=x11-libs/libnotify-0.7 )
+ pcre? ( >=dev-libs/libpcre-6:= )
+ trash-panel-plugin? ( >=xfce-base/xfce4-panel-4.10:= )
+ udisks? ( dev-libs/libgudev:= )
+"
+RDEPEND="
+ ${DEPEND}
+ >=dev-util/desktop-file-utils-0.20-r1
+ x11-misc/shared-mime-info
+ trash-panel-plugin? (
+ >=gnome-base/gvfs-1.18.3
+ )
+ udisks? (
+ >=gnome-base/gvfs-1.18.3[udisks,udev]
+ virtual/udev
+ )
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable udisks gudev)
+ $(use_enable libnotify notifications)
+ $(use_enable exif)
+ $(use_enable pcre)
+ $(use_enable trash-panel-plugin tpa-plugin)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog "If you were using an older Xfce version and Thunar fails to start"
+ elog "with a message similar to:"
+ elog " Failed to register: Timeout was reached"
+ elog "you may need to reset your xfce4 session:"
+ elog " rm ~/.cache/sessions/xfce4-session-*"
+ elog "See https://bugs.gentoo.org/698914."
+
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}