summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-31 17:14:24 +0100
committerMichał Górny <mgorny@gentoo.org>2022-10-31 17:14:24 +0100
commite1b17560a8bb0270e036dbd0df0daf5eeebe28b4 (patch)
treebc6938af308d38e6071cc910639a686085f1943b /xfce-base
parentxfce-base/xfce4-panel: Bump to 4.17.4 (diff)
downloadgentoo-e1b17560a8bb0270e036dbd0df0daf5eeebe28b4.tar.gz
gentoo-e1b17560a8bb0270e036dbd0df0daf5eeebe28b4.tar.bz2
gentoo-e1b17560a8bb0270e036dbd0df0daf5eeebe28b4.zip
xfce-base/garcon: Bump to 4.17.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/garcon/Manifest1
-rw-r--r--xfce-base/garcon/garcon-4.17.2.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/xfce-base/garcon/Manifest b/xfce-base/garcon/Manifest
index e469cab188f9..7081eddf0eac 100644
--- a/xfce-base/garcon/Manifest
+++ b/xfce-base/garcon/Manifest
@@ -1,2 +1,3 @@
DIST garcon-0.8.0.tar.bz2 539061 BLAKE2B 8d7b207fdb325d060c3ecfa5e2574961082706c5a4af59cabebad9d3c915228085dc32442521018bfb7da2d3c169445ac270c00c381e666bfda8774329a60cfc SHA512 708c68c31c0d3d89ecdde4790594837af0d065ecb805131fd7db2eb4c433c0523f44d51f2040f7bf9af729537e5f9e89ed06a435fc0c4e6113db00ad78ba8ce0
DIST garcon-4.17.1.tar.bz2 546754 BLAKE2B b84e502cda113719454353af80a6436f2a4ee1ca132a9d795f49fddeeb7d30abdac3468c6d40b0f23cb68e0584aa7f51c844ca5496a0bf4fa7c60b2d9bbdb3af SHA512 52bd03d7a4b5675b113b14f9acb56a2fb1d60c60a65b06b06376661228bea675e3c8be397b45d7d525fccd21c1bee9802378d11f51ed1f6229a4a5a73b607fe9
+DIST garcon-4.17.2.tar.bz2 549980 BLAKE2B 0d2c1578ee63bbcc553091d8fa1d8fec04f2598aabe878fa0bf827890713ad3a2fb8bdfb28e004abc1678fbf8e18b8854392a028e15fb86102a8065f318165b2 SHA512 4a1c9ced7126cf116cd5f15da77b132136f70056cb5aa2678bbefe09c47f93a4a2ef7ec22f47a2df4c85e43bf7e33ed533ee531e21f867cf070301529a16fe47
diff --git a/xfce-base/garcon/garcon-4.17.2.ebuild b/xfce-base/garcon/garcon-4.17.2.ebuild
new file mode 100644
index 000000000000..2ec5063e184c
--- /dev/null
+++ b/xfce-base/garcon/garcon-4.17.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Xfce's freedesktop.org specification compatible menu implementation library"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/garcon/start
+ https://gitlab.xfce.org/xfce/garcon/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+ FDL-1.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="introspection"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0
+ >=x11-libs/gtk+-3.20:3
+ >=xfce-base/libxfce4util-4.15.6:=[introspection?]
+ >=xfce-base/libxfce4ui-4.15.7:=[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.66:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/glib-utils
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ introspection? ( >=dev-libs/gobject-introspection-1.66 )
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}