summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emulation/dxvk/dxvk-1.10.3.ebuild6
-rw-r--r--app-emulation/dxvk/dxvk-2.0.ebuild6
-rw-r--r--app-emulation/dxvk/dxvk-2.1.ebuild7
-rw-r--r--app-emulation/dxvk/dxvk-2.2.ebuild7
-rw-r--r--app-emulation/dxvk/dxvk-9999.ebuild7
-rw-r--r--app-emulation/vkd3d-proton/vkd3d-proton-2.6.ebuild6
-rw-r--r--app-emulation/vkd3d-proton/vkd3d-proton-2.8.ebuild6
-rw-r--r--app-emulation/vkd3d-proton/vkd3d-proton-2.9.ebuild6
-rw-r--r--app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild6
-rw-r--r--app-emulation/wine-proton/wine-proton-7.0.6.ebuild5
-rw-r--r--app-emulation/wine-proton/wine-proton-8.0.1d.ebuild5
-rw-r--r--app-emulation/wine-proton/wine-proton-8.0.2c.ebuild5
-rw-r--r--app-emulation/wine-proton/wine-proton-8.0.9999.ebuild5
-rw-r--r--app-emulation/wine-staging/wine-staging-8.0.ebuild5
-rw-r--r--app-emulation/wine-staging/wine-staging-8.10-r1.ebuild (renamed from app-emulation/wine-staging/wine-staging-8.10.ebuild)5
-rw-r--r--app-emulation/wine-staging/wine-staging-8.11-r1.ebuild (renamed from app-emulation/wine-staging/wine-staging-8.11.ebuild)5
-rw-r--r--app-emulation/wine-staging/wine-staging-8.7.ebuild5
-rw-r--r--app-emulation/wine-staging/wine-staging-8.8.ebuild5
-rw-r--r--app-emulation/wine-staging/wine-staging-8.9.1.ebuild5
-rw-r--r--app-emulation/wine-staging/wine-staging-9999.ebuild5
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-7.0.2.ebuild5
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-8.0.1.ebuild5
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-8.10-r1.ebuild (renamed from app-emulation/wine-vanilla/wine-vanilla-8.10.ebuild)5
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-8.11-r1.ebuild (renamed from app-emulation/wine-vanilla/wine-vanilla-8.11.ebuild)5
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-8.7.ebuild5
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-8.8.ebuild5
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-8.9.ebuild5
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-9999.ebuild5
-rw-r--r--dev-util/mingw64-runtime/mingw64-runtime-10.0.0-r1.ebuild9
-rw-r--r--dev-util/mingw64-runtime/mingw64-runtime-11.0.0.ebuild7
-rw-r--r--dev-util/mingw64-toolchain/mingw64-toolchain-10.0.0_p1-r2.ebuild7
-rw-r--r--dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0.ebuild7
32 files changed, 168 insertions, 14 deletions
diff --git a/app-emulation/dxvk/dxvk-1.10.3.ebuild b/app-emulation/dxvk/dxvk-1.10.3.ebuild
index e9f3f4344b63..c11db845a715 100644
--- a/app-emulation/dxvk/dxvk-1.10.3.ebuild
+++ b/app-emulation/dxvk/dxvk-1.10.3.ebuild
@@ -66,8 +66,10 @@ src_prepare() {
src_configure() {
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}
- # AVX has a history of causing issues with this package, disable for safety
- # https://github.com/Tk-Glitch/PKGBUILDS/issues/515
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
append-flags -mno-avx
if [[ ${CHOST} != *-mingw* ]]; then
diff --git a/app-emulation/dxvk/dxvk-2.0.ebuild b/app-emulation/dxvk/dxvk-2.0.ebuild
index f2b240b7f42a..51375fb11c10 100644
--- a/app-emulation/dxvk/dxvk-2.0.ebuild
+++ b/app-emulation/dxvk/dxvk-2.0.ebuild
@@ -82,8 +82,10 @@ src_prepare() {
src_configure() {
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}
- # AVX has a history of causing issues with this package, disable for safety
- # https://github.com/Tk-Glitch/PKGBUILDS/issues/515
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
append-flags -mno-avx
if [[ ${CHOST} != *-mingw* ]]; then
diff --git a/app-emulation/dxvk/dxvk-2.1.ebuild b/app-emulation/dxvk/dxvk-2.1.ebuild
index af2054a54097..28608a67906c 100644
--- a/app-emulation/dxvk/dxvk-2.1.ebuild
+++ b/app-emulation/dxvk/dxvk-2.1.ebuild
@@ -90,9 +90,10 @@ src_prepare() {
src_configure() {
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}
- # AVX has a history of causing issues with this package, disable for safety
- # https://bugs.winehq.org/show_bug.cgi?id=43516
- # https://bugs.winehq.org/show_bug.cgi?id=45289
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
append-flags -mno-avx
if [[ ${CHOST} != *-mingw* ]]; then
diff --git a/app-emulation/dxvk/dxvk-2.2.ebuild b/app-emulation/dxvk/dxvk-2.2.ebuild
index 377428505711..b2ad8ecef4f0 100644
--- a/app-emulation/dxvk/dxvk-2.2.ebuild
+++ b/app-emulation/dxvk/dxvk-2.2.ebuild
@@ -86,9 +86,10 @@ src_prepare() {
src_configure() {
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}
- # AVX has a history of causing issues with this package, disable for safety
- # https://bugs.winehq.org/show_bug.cgi?id=43516
- # https://bugs.winehq.org/show_bug.cgi?id=45289
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
append-flags -mno-avx
if [[ ${CHOST} != *-mingw* ]]; then
diff --git a/app-emulation/dxvk/dxvk-9999.ebuild b/app-emulation/dxvk/dxvk-9999.ebuild
index b2469528ebc8..12656f42a335 100644
--- a/app-emulation/dxvk/dxvk-9999.ebuild
+++ b/app-emulation/dxvk/dxvk-9999.ebuild
@@ -86,9 +86,10 @@ src_prepare() {
src_configure() {
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}
- # AVX has a history of causing issues with this package, disable for safety
- # https://bugs.winehq.org/show_bug.cgi?id=43516
- # https://bugs.winehq.org/show_bug.cgi?id=45289
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
append-flags -mno-avx
if [[ ${CHOST} != *-mingw* ]]; then
diff --git a/app-emulation/vkd3d-proton/vkd3d-proton-2.6.ebuild b/app-emulation/vkd3d-proton/vkd3d-proton-2.6.ebuild
index 2e3e5c86e2ce..3c960bc15b97 100644
--- a/app-emulation/vkd3d-proton/vkd3d-proton-2.6.ebuild
+++ b/app-emulation/vkd3d-proton/vkd3d-proton-2.6.ebuild
@@ -100,6 +100,12 @@ src_prepare() {
src_configure() {
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-flags -mno-avx
+
if [[ ${CHOST} != *-mingw* ]]; then
if [[ ! -v MINGW_BYPASS ]]; then
unset AR CC CXX RC STRIP WIDL
diff --git a/app-emulation/vkd3d-proton/vkd3d-proton-2.8.ebuild b/app-emulation/vkd3d-proton/vkd3d-proton-2.8.ebuild
index 9acb9d5109a0..cd727dfb9b35 100644
--- a/app-emulation/vkd3d-proton/vkd3d-proton-2.8.ebuild
+++ b/app-emulation/vkd3d-proton/vkd3d-proton-2.8.ebuild
@@ -105,6 +105,12 @@ src_prepare() {
src_configure() {
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-flags -mno-avx
+
if [[ ${CHOST} != *-mingw* ]]; then
if [[ ! -v MINGW_BYPASS ]]; then
unset AR CC CXX RC STRIP WIDL
diff --git a/app-emulation/vkd3d-proton/vkd3d-proton-2.9.ebuild b/app-emulation/vkd3d-proton/vkd3d-proton-2.9.ebuild
index 48d90c5020cc..e51d2c12d6be 100644
--- a/app-emulation/vkd3d-proton/vkd3d-proton-2.9.ebuild
+++ b/app-emulation/vkd3d-proton/vkd3d-proton-2.9.ebuild
@@ -105,6 +105,12 @@ src_prepare() {
src_configure() {
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-flags -mno-avx
+
if [[ ${CHOST} != *-mingw* ]]; then
if [[ ! -v MINGW_BYPASS ]]; then
unset AR CC CXX RC STRIP WIDL
diff --git a/app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild b/app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild
index 3b7c91df0a13..3aa61a026157 100644
--- a/app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild
+++ b/app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild
@@ -105,6 +105,12 @@ src_prepare() {
src_configure() {
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-flags -mno-avx
+
if [[ ${CHOST} != *-mingw* ]]; then
if [[ ! -v MINGW_BYPASS ]]; then
unset AR CC CXX RC STRIP WIDL
diff --git a/app-emulation/wine-proton/wine-proton-7.0.6.ebuild b/app-emulation/wine-proton/wine-proton-7.0.6.ebuild
index 96f444e33758..086837096042 100644
--- a/app-emulation/wine-proton/wine-proton-7.0.6.ebuild
+++ b/app-emulation/wine-proton/wine-proton-7.0.6.ebuild
@@ -259,6 +259,11 @@ src_configure() {
: "${CROSSCFLAGS:=$(
filter-flags '-fstack-protector*' #870136
filter-flags '-mfunction-return=thunk*' #878849
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-cflags -mno-avx
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
filter-flags '-fuse-ld=*'
diff --git a/app-emulation/wine-proton/wine-proton-8.0.1d.ebuild b/app-emulation/wine-proton/wine-proton-8.0.1d.ebuild
index b2b9a61de3ff..1080ea80dd3f 100644
--- a/app-emulation/wine-proton/wine-proton-8.0.1d.ebuild
+++ b/app-emulation/wine-proton/wine-proton-8.0.1d.ebuild
@@ -260,6 +260,11 @@ src_configure() {
append-cflags '-fno-strict-aliasing'
filter-flags '-fstack-protector*' #870136
filter-flags '-mfunction-return=thunk*' #878849
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-cflags -mno-avx
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
filter-flags '-fuse-ld=*'
diff --git a/app-emulation/wine-proton/wine-proton-8.0.2c.ebuild b/app-emulation/wine-proton/wine-proton-8.0.2c.ebuild
index b2b9a61de3ff..1080ea80dd3f 100644
--- a/app-emulation/wine-proton/wine-proton-8.0.2c.ebuild
+++ b/app-emulation/wine-proton/wine-proton-8.0.2c.ebuild
@@ -260,6 +260,11 @@ src_configure() {
append-cflags '-fno-strict-aliasing'
filter-flags '-fstack-protector*' #870136
filter-flags '-mfunction-return=thunk*' #878849
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-cflags -mno-avx
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
filter-flags '-fuse-ld=*'
diff --git a/app-emulation/wine-proton/wine-proton-8.0.9999.ebuild b/app-emulation/wine-proton/wine-proton-8.0.9999.ebuild
index b294ba4b95e7..e5ff1bbe7cce 100644
--- a/app-emulation/wine-proton/wine-proton-8.0.9999.ebuild
+++ b/app-emulation/wine-proton/wine-proton-8.0.9999.ebuild
@@ -261,6 +261,11 @@ src_configure() {
append-cflags '-fno-strict-aliasing'
filter-flags '-fstack-protector*' #870136
filter-flags '-mfunction-return=thunk*' #878849
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-cflags -mno-avx
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
filter-flags '-fuse-ld=*'
diff --git a/app-emulation/wine-staging/wine-staging-8.0.ebuild b/app-emulation/wine-staging/wine-staging-8.0.ebuild
index 06a39f07e0f3..c8412919b5a8 100644
--- a/app-emulation/wine-staging/wine-staging-8.0.ebuild
+++ b/app-emulation/wine-staging/wine-staging-8.0.ebuild
@@ -301,6 +301,11 @@ src_configure() {
append-cflags '-fno-strict-aliasing'
filter-flags '-fstack-protector*' #870136
filter-flags '-mfunction-return=thunk*' #878849
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-cflags -mno-avx
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
filter-flags '-fuse-ld=*'
diff --git a/app-emulation/wine-staging/wine-staging-8.10.ebuild b/app-emulation/wine-staging/wine-staging-8.10-r1.ebuild
index 7096d33eb0ec..e42a0756d4a3 100644
--- a/app-emulation/wine-staging/wine-staging-8.10.ebuild
+++ b/app-emulation/wine-staging/wine-staging-8.10-r1.ebuild
@@ -311,6 +311,11 @@ src_configure() {
: "${CROSSCFLAGS:=$(
filter-flags '-fstack-protector*' #870136
filter-flags '-mfunction-return=thunk*' #878849
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-cflags -mno-avx
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
filter-flags '-fuse-ld=*'
diff --git a/app-emulation/wine-staging/wine-staging-8.11.ebuild b/app-emulation/wine-staging/wine-staging-8.11-r1.ebuild
index a11cbb764ad0..940bb93e3836 100644
--- a/app-emulation/wine-staging/wine-staging-8.11.ebuild
+++ b/app-emulation/wine-staging/wine-staging-8.11-r1.ebuild
@@ -314,6 +314,11 @@ src_configure() {
: "${CROSSCFLAGS:=$(
filter-flags '-fstack-protector*' #870136
filter-flags '-mfunction-return=thunk*' #878849
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-cflags -mno-avx
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
filter-flags '-fuse-ld=*'
diff --git a/app-emulation/wine-staging/wine-staging-8.7.ebuild b/app-emulation/wine-staging/wine-staging-8.7.ebuild
index 50cd09f01e47..3d3ed519862c 100644
--- a/app-emulation/wine-staging/wine-staging-8.7.ebuild
+++ b/app-emulation/wine-staging/wine-staging-8.7.ebuild
@@ -312,6 +312,11 @@ src_configure() {
append-cflags '-fno-strict-aliasing'
filter-flags '-fstack-protector*' #870136
filter-flags '-mfunction-return=thunk*' #878849
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-cflags -mno-avx
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
filter-flags '-fuse-ld=*'
diff --git a/app-emulation/wine-staging/wine-staging-8.8.ebuild b/app-emulation/wine-staging/wine-staging-8.8.ebuild
index 356b6bd8d790..84fd9d3669c3 100644
--- a/app-emulation/wine-staging/wine-staging-8.8.ebuild
+++ b/app-emulation/wine-staging/wine-staging-8.8.ebuild
@@ -312,6 +312,11 @@ src_configure() {
append-cflags '-fno-strict-aliasing'
filter-flags '-fstack-protector*' #870136
filter-flags '-mfunction-return=thunk*' #878849
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-cflags -mno-avx
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
filter-flags '-fuse-ld=*'
diff --git a/app-emulation/wine-staging/wine-staging-8.9.1.ebuild b/app-emulation/wine-staging/wine-staging-8.9.1.ebuild
index 91fff75c3a4c..6a22f7ebef3f 100644
--- a/app-emulation/wine-staging/wine-staging-8.9.1.ebuild
+++ b/app-emulation/wine-staging/wine-staging-8.9.1.ebuild
@@ -313,6 +313,11 @@ src_configure() {
append-cflags '-fno-strict-aliasing'
filter-flags '-fstack-protector*' #870136
filter-flags '-mfunction-return=thunk*' #878849
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-cflags -mno-avx
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
filter-flags '-fuse-ld=*'
diff --git a/app-emulation/wine-staging/wine-staging-9999.ebuild b/app-emulation/wine-staging/wine-staging-9999.ebuild
index a11cbb764ad0..940bb93e3836 100644
--- a/app-emulation/wine-staging/wine-staging-9999.ebuild
+++ b/app-emulation/wine-staging/wine-staging-9999.ebuild
@@ -314,6 +314,11 @@ src_configure() {
: "${CROSSCFLAGS:=$(
filter-flags '-fstack-protector*' #870136
filter-flags '-mfunction-return=thunk*' #878849
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-cflags -mno-avx
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
filter-flags '-fuse-ld=*'
diff --git a/app-emulation/wine-vanilla/wine-vanilla-7.0.2.ebuild b/app-emulation/wine-vanilla/wine-vanilla-7.0.2.ebuild
index 36c592c40934..fe54aab83894 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-7.0.2.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-7.0.2.ebuild
@@ -267,6 +267,11 @@ src_configure() {
: "${CROSSCFLAGS:=$(
filter-flags '-fstack-protector*' #870136
filter-flags '-mfunction-return=thunk*' #878849
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-cflags -mno-avx
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
filter-flags '-fuse-ld=*'
diff --git a/app-emulation/wine-vanilla/wine-vanilla-8.0.1.ebuild b/app-emulation/wine-vanilla/wine-vanilla-8.0.1.ebuild
index 686049493098..6aa6458e6edd 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-8.0.1.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-8.0.1.ebuild
@@ -269,6 +269,11 @@ src_configure() {
append-cflags '-fno-strict-aliasing'
filter-flags '-fstack-protector*' #870136
filter-flags '-mfunction-return=thunk*' #878849
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-cflags -mno-avx
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
filter-flags '-fuse-ld=*'
diff --git a/app-emulation/wine-vanilla/wine-vanilla-8.10.ebuild b/app-emulation/wine-vanilla/wine-vanilla-8.10-r1.ebuild
index f2da3a5c1b7b..11ed198a2f98 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-8.10.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-8.10-r1.ebuild
@@ -273,6 +273,11 @@ src_configure() {
: "${CROSSCFLAGS:=$(
filter-flags '-fstack-protector*' #870136
filter-flags '-mfunction-return=thunk*' #878849
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-cflags -mno-avx
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
filter-flags '-fuse-ld=*'
diff --git a/app-emulation/wine-vanilla/wine-vanilla-8.11.ebuild b/app-emulation/wine-vanilla/wine-vanilla-8.11-r1.ebuild
index f2da3a5c1b7b..11ed198a2f98 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-8.11.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-8.11-r1.ebuild
@@ -273,6 +273,11 @@ src_configure() {
: "${CROSSCFLAGS:=$(
filter-flags '-fstack-protector*' #870136
filter-flags '-mfunction-return=thunk*' #878849
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-cflags -mno-avx
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
filter-flags '-fuse-ld=*'
diff --git a/app-emulation/wine-vanilla/wine-vanilla-8.7.ebuild b/app-emulation/wine-vanilla/wine-vanilla-8.7.ebuild
index b8ac1a27c65a..5389f45538a8 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-8.7.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-8.7.ebuild
@@ -275,6 +275,11 @@ src_configure() {
append-cflags '-fno-strict-aliasing'
filter-flags '-fstack-protector*' #870136
filter-flags '-mfunction-return=thunk*' #878849
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-cflags -mno-avx
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
filter-flags '-fuse-ld=*'
diff --git a/app-emulation/wine-vanilla/wine-vanilla-8.8.ebuild b/app-emulation/wine-vanilla/wine-vanilla-8.8.ebuild
index b8ac1a27c65a..5389f45538a8 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-8.8.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-8.8.ebuild
@@ -275,6 +275,11 @@ src_configure() {
append-cflags '-fno-strict-aliasing'
filter-flags '-fstack-protector*' #870136
filter-flags '-mfunction-return=thunk*' #878849
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-cflags -mno-avx
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
filter-flags '-fuse-ld=*'
diff --git a/app-emulation/wine-vanilla/wine-vanilla-8.9.ebuild b/app-emulation/wine-vanilla/wine-vanilla-8.9.ebuild
index a513b26e07bb..8286b85d538e 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-8.9.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-8.9.ebuild
@@ -275,6 +275,11 @@ src_configure() {
append-cflags '-fno-strict-aliasing'
filter-flags '-fstack-protector*' #870136
filter-flags '-mfunction-return=thunk*' #878849
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-cflags -mno-avx
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
filter-flags '-fuse-ld=*'
diff --git a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
index f2da3a5c1b7b..11ed198a2f98 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
@@ -273,6 +273,11 @@ src_configure() {
: "${CROSSCFLAGS:=$(
filter-flags '-fstack-protector*' #870136
filter-flags '-mfunction-return=thunk*' #878849
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-cflags -mno-avx
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
filter-flags '-fuse-ld=*'
diff --git a/dev-util/mingw64-runtime/mingw64-runtime-10.0.0-r1.ebuild b/dev-util/mingw64-runtime/mingw64-runtime-10.0.0-r1.ebuild
index ffbdbd5e4ddd..dbbdbd2de31c 100644
--- a/dev-util/mingw64-runtime/mingw64-runtime-10.0.0-r1.ebuild
+++ b/dev-util/mingw64-runtime/mingw64-runtime-10.0.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -70,6 +70,13 @@ src_configure() {
filter-flags '-mfunction-return=thunk*' #878849
fi
local CHOST=${CTARGET}
+
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ tc-is-gcc && append-flags -mno-avx
+
strip-unsupported-flags
# Normally mingw64 does not use dynamic linker.
diff --git a/dev-util/mingw64-runtime/mingw64-runtime-11.0.0.ebuild b/dev-util/mingw64-runtime/mingw64-runtime-11.0.0.ebuild
index e9b21a93f78c..5e0b60934d20 100644
--- a/dev-util/mingw64-runtime/mingw64-runtime-11.0.0.ebuild
+++ b/dev-util/mingw64-runtime/mingw64-runtime-11.0.0.ebuild
@@ -65,6 +65,13 @@ src_configure() {
filter-flags '-mfunction-return=thunk*' #878849
fi
local CHOST=${CTARGET}
+
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ tc-is-gcc && append-flags -mno-avx
+
strip-unsupported-flags
# Normally mingw64 does not use dynamic linker, but at configure time it
diff --git a/dev-util/mingw64-toolchain/mingw64-toolchain-10.0.0_p1-r2.ebuild b/dev-util/mingw64-toolchain/mingw64-toolchain-10.0.0_p1-r2.ebuild
index 82af5181e021..cb802c55f8b1 100644
--- a/dev-util/mingw64-toolchain/mingw64-toolchain-10.0.0_p1-r2.ebuild
+++ b/dev-util/mingw64-toolchain/mingw64-toolchain-10.0.0_p1-r2.ebuild
@@ -193,6 +193,13 @@ src_compile() {
filter-flags '-fstack-protector*' #870136
filter-flags '-fuse-ld=*'
filter-flags '-mfunction-return=thunk*' #878849
+
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-flags -mno-avx
+
strip-unsupported-flags
mwt-build "${@:2}"
)
diff --git a/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0.ebuild b/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0.ebuild
index d4fe6b516d10..803cd398d9be 100644
--- a/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0.ebuild
+++ b/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0.ebuild
@@ -201,6 +201,13 @@ src_compile() {
CHOST=${CTARGET}
filter-flags '-fuse-ld=*'
filter-flags '-mfunction-return=thunk*' #878849
+
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-flags -mno-avx
+
strip-unsupported-flags
mwt-build "${@:2}"
)