summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/qrencode/qrencode-4.0.0.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/media-gfx/qrencode/qrencode-4.0.0.ebuild b/media-gfx/qrencode/qrencode-4.0.0.ebuild
index 2aac69499076..fba7ff05361e 100644
--- a/media-gfx/qrencode/qrencode-4.0.0.ebuild
+++ b/media-gfx/qrencode/qrencode-4.0.0.ebuild
@@ -10,7 +10,7 @@ SRC_URI="https://fukuchi.org/works/${PN}/${P}.tar.bz2"
LICENSE="LGPL-2"
SLOT="0/4"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE=""
+IUSE="test"
RDEPEND="media-libs/libpng:0="
DEPEND="${RDEPEND}
@@ -18,8 +18,17 @@ DEPEND="${RDEPEND}
src_configure() {
local myconf=(
- --disable-tests
+ $(use_with test tests)
+ # TODO: figure out how to make SDL check fail as the SDL test
+ # program is not useful
)
econf "${myconf[@]}"
}
+
+src_test() {
+ cd tests || die
+ # the configure test checks if reconfiguring works...
+ sed -i -e '/configure/d' test_all.sh || die
+ sh test_all.sh || die
+}