summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-portage/gentle/Manifest1
-rw-r--r--app-portage/gentle/gentle-0.3.1.ebuild43
-rw-r--r--dev-python/iminuit/Manifest1
-rw-r--r--dev-python/iminuit/iminuit-2.22.0.ebuild52
-rw-r--r--dev-python/insipid-sphinx-theme/Manifest1
-rw-r--r--dev-python/insipid-sphinx-theme/insipid-sphinx-theme-0.4.1.ebuild30
-rw-r--r--dev-python/insipid-sphinx-theme/metadata.xml18
-rw-r--r--eclass/distutils-r1.eclass24
-rw-r--r--eclass/python-utils-r1.eclass12
-rwxr-xr-xeclass/tests/python-utils-r1.sh2
10 files changed, 172 insertions, 12 deletions
diff --git a/app-portage/gentle/Manifest b/app-portage/gentle/Manifest
index 44e009a44f2b..c9ad182b5c39 100644
--- a/app-portage/gentle/Manifest
+++ b/app-portage/gentle/Manifest
@@ -1 +1,2 @@
DIST gentle_mxml-0.3.0.tar.gz 34317 BLAKE2B caa5ce9e529a13c7df58b1b5622f1837bea1c05a77df7c85eefd087df204fcab14bbc0884b5dbfb056b4613520110e3a291a8f78cb4e798d6f32208e98d7da26 SHA512 a77154e43e17e12e514a5d579792d757b2e69c2aaa95a80af6e355eaaa8fcd2bd3e18373a96db7ad64804a1ce67dca32d9c0af2ac9bf11d5f18f0328d6501969
+DIST gentle_mxml-0.3.1.tar.gz 141735 BLAKE2B 6720ff9af32d83beac66e5e8fc71cc33a7554edb000b835d4f770da199806ebfbc3bdd95954b738f21768da6b6f8315cb870e2185b8066d5f69cad85128f60ec SHA512 4722e37c635d7f1b492bf52f3f4003deda1ba65c79be56228009875241048d6976b38e836e62f6d90adb8ec1bc545ff903487759ad581ffc0bb2e371d25dd780
diff --git a/app-portage/gentle/gentle-0.3.1.ebuild b/app-portage/gentle/gentle-0.3.1.ebuild
new file mode 100644
index 000000000000..b24f526fe46e
--- /dev/null
+++ b/app-portage/gentle/gentle-0.3.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=flit
+PYPI_PN="gentle-mxml"
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Gentoo Lazy Entry - a metadata.xml generator"
+HOMEPAGE="
+ https://gentle.sysrq.in
+ https://pypi.org/project/gentle-mxml/
+"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ app-text/xmldiff[${PYTHON_USEDEP}]
+ dev-python/pkginfo[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/rdflib[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep \
+ 'dev-python/tomli[${PYTHON_USEDEP}]' 3.10)
+ )
+"
+
+distutils_enable_tests pytest
+
+distutils_enable_sphinx docs \
+ dev-python/insipid-sphinx-theme \
+ dev-python/sphinx-prompt
+
+pkg_postinst() {
+ optfeature "PKG-INFO support" dev-python/pkginfo
+ optfeature "yaml support" dev-python/pyyaml
+ optfeature "rdf support" dev-python/rdflib
+ optfeature "toml support" dev-python/tomli
+}
diff --git a/dev-python/iminuit/Manifest b/dev-python/iminuit/Manifest
index 1031fe323734..2644f892ba55 100644
--- a/dev-python/iminuit/Manifest
+++ b/dev-python/iminuit/Manifest
@@ -1 +1,2 @@
DIST iminuit-2.21.3.tar.gz 437827 BLAKE2B 5196e896769f6312bb6ba9af8d6f03bea6023a9459ccbe8553e4c10ba5dc2ed90e4e4b57bdd104f7b72e7514a50c0d4c717c76adf206d7eaddcd3c4c54c4d210 SHA512 5e48d4451caf56688143fa4590528fb4ed0660e144dbb3d1c409b84f793593478979728b4af9748b7bbdb7063e2ef7e05476a2ecd52af089f351522aadfc9ba4
+DIST iminuit-2.22.0.tar.gz 2324676 BLAKE2B e45952ee6a7f7b6ef3e1ac570abf167423c59ee82841b360278d43c4ab1e07667e143a439f7354e8257007a198c015388b9acf0a5e9aa487814d6619999eab2e SHA512 e9eda1bc7741c35bd9e9e650a626b45a2f5e4362a7c1dead57dcc461fa6e6cdbab8cfd4203c483017f8fa43e6cf1e75e074d40b92cbc3f271140d950ee4da158
diff --git a/dev-python/iminuit/iminuit-2.22.0.ebuild b/dev-python/iminuit/iminuit-2.22.0.ebuild
new file mode 100644
index 000000000000..b8a08320e0b8
--- /dev/null
+++ b/dev-python/iminuit/iminuit-2.22.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=scikit-build-core
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit cmake distutils-r1 virtualx pypi
+
+DESCRIPTION="Minuit numerical function minimization in Python"
+HOMEPAGE="
+ https://github.com/scikit-hep/iminuit/
+ https://pypi.org/project/iminuit/
+"
+
+LICENSE="MIT LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/ipywidgets[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # warnings caught as exceptions, sigh
+ # https://github.com/scikit-hep/iminuit/pull/907
+ tests/test_cost.py::test_UnbinnedNLL_visualize
+
+ # precision error
+ tests/test_cost.py::test_Template_with_model_2D
+ )
+
+ epytest -p no:pytest-describe || die "Tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/insipid-sphinx-theme/Manifest b/dev-python/insipid-sphinx-theme/Manifest
new file mode 100644
index 000000000000..ecf8f37fd4ee
--- /dev/null
+++ b/dev-python/insipid-sphinx-theme/Manifest
@@ -0,0 +1 @@
+DIST insipid-sphinx-theme-0.4.1.tar.gz 73400 BLAKE2B 1b156787354219ba9b31905748c6d786021ce6e349a120e60416fc1de215d6f8d898bc0e91514043bb2e5c13d4004f22a906e525a4b0d610de4024b07e81af5f SHA512 aa7eb3768f48c481518984028c7911810afca3a6c4c93ec50efcf6f7b41efe9959acdf4b24d54bf8402eee829789b6945a2fa1a7648011d4566e174a7c5ca99e
diff --git a/dev-python/insipid-sphinx-theme/insipid-sphinx-theme-0.4.1.ebuild b/dev-python/insipid-sphinx-theme/insipid-sphinx-theme-0.4.1.ebuild
new file mode 100644
index 000000000000..5c440d6eecdd
--- /dev/null
+++ b/dev-python/insipid-sphinx-theme/insipid-sphinx-theme-0.4.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+inherit distutils-r1 pypi
+
+DESCRIPTION="Insipid Sphinx theme"
+HOMEPAGE="
+ https://pypi.org/project/insipid-sphinx-theme/
+ https://github.com/mgeier/insipid-sphinx-theme
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/jinja[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-5[${PYTHON_USEDEP}]
+ >=dev-python/docutils-0.18[${PYTHON_USEDEP}]
+"
+
+DOCS=( {CONTRIBUTING,NEWS,README}.rst )
+
+# needs sphinx_last_updated_by_git
+#distutils_enable_sphinx "doc"
diff --git a/dev-python/insipid-sphinx-theme/metadata.xml b/dev-python/insipid-sphinx-theme/metadata.xml
new file mode 100644
index 000000000000..b2ddf5ba8fc6
--- /dev/null
+++ b/dev-python/insipid-sphinx-theme/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>cyber+gentoo@sysrq.in</email>
+ <name>Anna Vyalkova</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">insipid-sphinx-theme</remote-id>
+ <remote-id type="github">mgeier/insipid-sphinx-theme</remote-id>
+ <doc>https://insipid-sphinx-theme.readthedocs.io/</doc>
+ <bugs-to>https://github.com/mgeier/insipid-sphinx-theme/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 7a7b762ef059..fd9bf47aa963 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -212,7 +212,7 @@ _distutils_set_globals() {
case ${DISTUTILS_USE_PEP517} in
flit)
bdep+='
- >=dev-python/flit-core-3.8.0[${PYTHON_USEDEP}]
+ >=dev-python/flit-core-3.9.0[${PYTHON_USEDEP}]
'
;;
flit_scm)
@@ -256,12 +256,17 @@ _distutils_set_globals() {
;;
pdm-backend)
bdep+='
- >=dev-python/pdm-backend-2.0.7[${PYTHON_USEDEP}]
+ >=dev-python/pdm-backend-2.1.0[${PYTHON_USEDEP}]
'
;;
poetry)
bdep+='
- >=dev-python/poetry-core-1.5.2[${PYTHON_USEDEP}]
+ >=dev-python/poetry-core-1.6.1[${PYTHON_USEDEP}]
+ '
+ ;;
+ scikit-build-core)
+ bdep+='
+ >=dev-python/scikit-build-core-0.4.6[${PYTHON_USEDEP}]
'
;;
setuptools)
@@ -272,7 +277,7 @@ _distutils_set_globals() {
;;
sip)
bdep+='
- >=dev-python/sip-6.7.8[${PYTHON_USEDEP}]
+ >=dev-python/sip-6.7.9[${PYTHON_USEDEP}]
'
;;
standalone)
@@ -287,7 +292,7 @@ _distutils_set_globals() {
eqawarn "is enabled."
fi
else
- local setuptools_dep='>=dev-python/setuptools-65.7.0[${PYTHON_USEDEP}]'
+ local setuptools_dep='>=dev-python/setuptools-67.7.2[${PYTHON_USEDEP}]'
case ${DISTUTILS_USE_SETUPTOOLS:-bdepend} in
no|manual)
@@ -1002,9 +1007,15 @@ _distutils-r1_print_package_versions() {
dev-python/poetry-core
)
;;
+ scikit-build-core)
+ packages+=(
+ dev-python/scikit-build-core
+ )
+ ;;
setuptools)
packages+=(
dev-python/setuptools
+ dev-python/setuptools-rust
dev-python/setuptools-scm
dev-python/wheel
)
@@ -1200,6 +1211,9 @@ _distutils-r1_backend_to_key() {
poetry.core.masonry.api|poetry.masonry.api)
echo poetry
;;
+ scikit_build_core.build)
+ echo scikit-build-core
+ ;;
setuptools.build_meta|setuptools.build_meta:__legacy__)
echo setuptools
;;
diff --git a/eclass/python-utils-r1.eclass b/eclass/python-utils-r1.eclass
index 7a1be381f596..40c15b65d7a5 100644
--- a/eclass/python-utils-r1.eclass
+++ b/eclass/python-utils-r1.eclass
@@ -238,12 +238,12 @@ _python_impl_matches() {
fi
return 0
;;
- 3.9)
- # the only unmasked pypy3 version is pypy3.9 atm
+ 3.9|3.10)
+ # <pypy3-7.3.12 is 3.9, >=7.3.12 is 3.10
[[ ${impl} == python${pattern/./_} || ${impl} == pypy3 ]] &&
return 0
;;
- 3.8|3.1[0-2])
+ 3.8|3.1[1-2])
[[ ${impl} == python${pattern/./_} ]] && return 0
;;
*)
@@ -448,11 +448,11 @@ _python_export() {
local d
case ${impl} in
python3.10)
- PYTHON_PKG_DEP=">=dev-lang/python-3.10.11:3.10";;
+ PYTHON_PKG_DEP=">=dev-lang/python-3.10.12:3.10";;
python3.11)
- PYTHON_PKG_DEP=">=dev-lang/python-3.11.3:3.11";;
+ PYTHON_PKG_DEP=">=dev-lang/python-3.11.4:3.11";;
python3.12)
- PYTHON_PKG_DEP=">=dev-lang/python-3.12.0_beta1:3.12";;
+ PYTHON_PKG_DEP=">=dev-lang/python-3.12.0_beta3:3.12";;
pypy3)
PYTHON_PKG_DEP='>=dev-python/pypy3-7.3.11_p1:0=';;
*)
diff --git a/eclass/tests/python-utils-r1.sh b/eclass/tests/python-utils-r1.sh
index 635d49decbdd..81c459765f0f 100755
--- a/eclass/tests/python-utils-r1.sh
+++ b/eclass/tests/python-utils-r1.sh
@@ -208,7 +208,7 @@ test_is "_python_impl_matches python3_11 3.12" 1
test_is "_python_impl_matches python3_12 3.10" 1
test_is "_python_impl_matches python3_12 3.11" 1
test_is "_python_impl_matches python3_12 3.12" 0
-test_is "_python_impl_matches pypy3 3.10" 1
+test_is "_python_impl_matches pypy3 3.10" 0
test_is "_python_impl_matches pypy3 3.11" 1
test_is "_python_impl_matches pypy3 3.12" 1
eoutdent