summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/chameleon/Manifest1
-rw-r--r--dev-python/chameleon/chameleon-3.7.2.ebuild21
-rw-r--r--dev-python/cliff/Manifest1
-rw-r--r--dev-python/cliff/cliff-3.1.0.ebuild36
-rw-r--r--dev-python/stevedore/Manifest1
-rw-r--r--dev-python/stevedore/stevedore-1.32.0.ebuild39
-rw-r--r--dev-python/unicodecsv/unicodecsv-0.14.1-r1.ebuild2
-rw-r--r--dev-ruby/parser/Manifest4
-rw-r--r--dev-ruby/parser/parser-2.7.0.4.ebuild32
-rw-r--r--dev-ruby/parser/parser-2.7.0.5.ebuild32
-rw-r--r--dev-ruby/parser/parser-2.7.1.3.ebuild (renamed from dev-ruby/parser/parser-2.7.0.3.ebuild)2
-rw-r--r--eclass/distutils-r1.eclass2
-rw-r--r--x11-themes/numix-gtk-theme/numix-gtk-theme-2.6.7-r1.ebuild44
-rw-r--r--x11-wm/enlightenment/Manifest2
-rw-r--r--x11-wm/enlightenment/enlightenment-0.24.1.ebuild (renamed from x11-wm/enlightenment/enlightenment-0.24.0.ebuild)2
15 files changed, 107 insertions, 114 deletions
diff --git a/dev-python/chameleon/Manifest b/dev-python/chameleon/Manifest
index 09e4d862c992..e891b00500e0 100644
--- a/dev-python/chameleon/Manifest
+++ b/dev-python/chameleon/Manifest
@@ -1,2 +1,3 @@
DIST chameleon-3.7.0.gh.tar.gz 135209 BLAKE2B 14e890eca1a3c211dfb5a658457473b21948b6f252e76e5391e862850a29e9e0fe4aaa31a03da7ec1674a2b563d083ee31fb342be2dc9bf4e7b4dbccbabf8637 SHA512 9f1d2a9222b795ac139f0c06ea8169ec132c00714ec4608e58dd5781dba8380f988141f6659c47e8920ee0cd4d4bcde9070794cd0e2b5f34d0fce21d24e2dc98
DIST chameleon-3.7.1.gh.tar.gz 135230 BLAKE2B f0bd4dd90f7ea976e96101c2937f0ae5db110531caf28890042d0cd7a628489f03f9e2e3eed16dea2981ebb6e064a53adf95638102dfde6c8218e41e0473b32d SHA512 158b418fa6fbd13cd48d913ab34fb4f16450aa0fa3b382c6c829efed3100753814449a1d4004c9bc45d327d2a66130db0518b9c28943af300b4b310e955c426c
+DIST chameleon-3.7.2.gh.tar.gz 135311 BLAKE2B da6803bc6c064151b9d0cbe7761bbb44f73b1fd24fcf77d2e906c410768a1c99fa04225ae4aa719282bbb1f4fd0d51a6c710901016bb5c24f78ba2184f978f27 SHA512 3025fa92bdff3279fc404ad08d73d46bee82afd421f1d81982bd5cd2ea3fdffadf22efdb8b66157dbdf4d0cd793ac06b1a0daac4eb17a2a1ce9f14a65d4a6f8d
diff --git a/dev-python/chameleon/chameleon-3.7.2.ebuild b/dev-python/chameleon/chameleon-3.7.2.ebuild
new file mode 100644
index 000000000000..6f8ba1fc5c20
--- /dev/null
+++ b/dev-python/chameleon/chameleon-3.7.2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Fast HTML/XML template compiler for Python"
+HOMEPAGE="https://github.com/malthe/chameleon
+ https://pypi.org/project/Chameleon/"
+SRC_URI="
+ https://github.com/malthe/chameleon/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests setup.py
diff --git a/dev-python/cliff/Manifest b/dev-python/cliff/Manifest
index 30570a1aa3ac..7d9755b20893 100644
--- a/dev-python/cliff/Manifest
+++ b/dev-python/cliff/Manifest
@@ -1 +1,2 @@
DIST cliff-2.18.0.tar.gz 77905 BLAKE2B e371c4025fd3bf0543d3f4f038ff891a27f8116d3c833a2ded4e9f619879501868c3acf9e2f1c36023b79da404dcb69f8a8c31fbbbc2847b6c7dfabbd7ad666e SHA512 0748f8f392b11ceaa63f516860f6a339a9bc1233134562b13384bcbaff0b9e84e82a1544658ea3bf9c0fde973c563bfa1e92cc418a2fef0bfdced3f88d93058f
+DIST cliff-3.1.0.tar.gz 79037 BLAKE2B ab7fd085a222d93deab2d97649be45510f868c7b6ffc32bca6a6cfd7c6c66033f831fa5682d753d8111ce869d94c788c204610851034fdd020f829889062a066 SHA512 f6b74a91e75a0715949a245816f60563c78aa23b03f896240650a190b9d9486e0079081f3fb12acc8aa610c411c7571a330a94f2884ec00b6f893a0d9bebdcd4
diff --git a/dev-python/cliff/cliff-3.1.0.ebuild b/dev-python/cliff/cliff-3.1.0.ebuild
new file mode 100644
index 000000000000..3c74f32631a1
--- /dev/null
+++ b/dev-python/cliff/cliff-3.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Command Line Interface Formulation Framework"
+HOMEPAGE="https://github.com/openstack/cliff"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/cmd2-0.8.0[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
+"
+BDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0
+ test? (
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
diff --git a/dev-python/stevedore/Manifest b/dev-python/stevedore/Manifest
index ce2af7bfbbfd..26a589adaf1b 100644
--- a/dev-python/stevedore/Manifest
+++ b/dev-python/stevedore/Manifest
@@ -1 +1,2 @@
DIST stevedore-1.31.0.tar.gz 505482 BLAKE2B c69ecf61b32ab996f23aa913a9f226f64164b94e9420da8b7dd5a8ba568a228bd2f536052ab9378167fd2fe2e0d8d7b42515580a966eeffb5beeaf55dbba69ad SHA512 07b641b63766eddd094690acad81c1417a9721d785f81ca11da0ec2afed455d1beedfea5be4dcfd833d9379d650b193e26207ec0411d274bdf399ea2acd321a0
+DIST stevedore-1.32.0.tar.gz 510344 BLAKE2B 96de6598245e88900ba0f0bd69b976425fc5be2c783f32c551ebb2536dc5fde7fab18121947f3f9caa4d7d822372ad502d272285cc66368bfc39c566821a0160 SHA512 98c66b9ac827f69737cc2522029108831380b4bf4c633786d9819b52be930f6116ce5bfab58e724a2efad147830fcb6353409322fc5e01617d35d1c8aafb0259
diff --git a/dev-python/stevedore/stevedore-1.32.0.ebuild b/dev-python/stevedore/stevedore-1.32.0.ebuild
new file mode 100644
index 000000000000..96df662c46eb
--- /dev/null
+++ b/dev-python/stevedore/stevedore-1.32.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Manage dynamic plugins for Python applications"
+HOMEPAGE="https://github.com/openstack/stevedore https://pypi.org/project/stevedore/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+distutils_enable_sphinx 'doc/source' \
+ '>=dev-python/openstackdocstheme-1.18.1' \
+ '>=dev-python/reno-2.5.0' \
+ '>=dev-python/sphinx-2.0.0'
+
+python_prepare_all() {
+ # Delete spurious data in requirements.txt
+ sed -e '/^pbr/d' -i requirements.txt || die
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/unicodecsv/unicodecsv-0.14.1-r1.ebuild b/dev-python/unicodecsv/unicodecsv-0.14.1-r1.ebuild
index 1b0e7f8bad9a..1b726c42c610 100644
--- a/dev-python/unicodecsv/unicodecsv-0.14.1-r1.ebuild
+++ b/dev-python/unicodecsv/unicodecsv-0.14.1-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{6,7,8}} )
+PYTHON_COMPAT=( python{2_7,3_{6..9}} )
inherit distutils-r1
diff --git a/dev-ruby/parser/Manifest b/dev-ruby/parser/Manifest
index dffc73de865b..687c97d0fa2e 100644
--- a/dev-ruby/parser/Manifest
+++ b/dev-ruby/parser/Manifest
@@ -1,7 +1,5 @@
DIST parser-2.6.5.0.gem 710144 BLAKE2B 72ae2ddd179b3d05ed94ff43d80940cf3b9e04445e4ee713284b35db016a50266891761fb84e2f56d9abe4fe41b7d6813b468cc618801561883b9178311001e6 SHA512 ffa73aba17be57ba8fe685213b5c009a4ba5e72dd165b63ec49f83562e4f501bd1c20e40893e7ea3e977f47aa10d1afd055578a031d8ec9cd0b5ad081c43ea39
-DIST parser-2.7.0.3.gem 725504 BLAKE2B b665475d3054a7d61492f7c04e2b1039f89bd08d28b58df452542f85570867a161e5e525ae4b8d9d02e8476194486a5c30549971d9f789e1cbc2751e6cc8bb1a SHA512 43355bab41f662f0afb03a8ab929024ecf4c5ed936f987ea55cff2473c8cca4551454802d5b22c3466d3c1abaf14cb9155e8a0b697f1c1cbdc98fe93bf4e71a7
-DIST parser-2.7.0.4.gem 726016 BLAKE2B 168462c98cf21563cfef07783a8723201aea5ffce4d363f206a9604503ded91c11e49851908a4b2317fb62c01fdef6b9f7ef9c8d6ff243dc721912e705d19c63 SHA512 87f613279cdd911e707ccacb65f9278bbcbea153c77d96da0163f8cffbb6c43ce17351fc9a7146018f3e27bbc9ec99365f250010f61d60cf665e062be3ef5501
-DIST parser-2.7.0.5.gem 726016 BLAKE2B 556d4b580f7efcdec484646db59b623f9f40b0959e8751b2cbbfcf3fa84c0e82dac06d2df88df77b4d1d973c56e17190a1da85523485d4a36feee4042890dbac SHA512 5358c7004ca06ee50f38906145a1d357b49a23f1ce461b72b8cb5558e91aee18b87fe5eafa7df1b356d47a3ddacbb7cdff8fc516470ea6ad6532be1782c05a82
DIST parser-2.7.1.0.gem 726016 BLAKE2B 55386c4d2107230e17d1bce7997c15512024d93e65e21ca7d1e850e433dcaf7daa75d180967b40c109d3361824c3d9e1c6ef992602c6eec3b7a2c9679993bc72 SHA512 f6e4e814836798045c9eadf84aefe0394b0e8b3dc47d9e6c0e7e372cc4ad13653a45aac10c03e94f79a879b99cb43eaf8cdc4a899a41d463ecae76205d2943a7
DIST parser-2.7.1.1.gem 727040 BLAKE2B 5deb439440cff0f95cfa99969a70c926a82bb0d30f842f0a0915e2e1b7dc6eb4c12e059e8b2f8882b2f772777d611de7ea9133f68a6b0a5954c6446f2dafd1c3 SHA512 29345f4cdbc424e07184b97c4dfab39be2b61f5ae57dba53ee8775fa0251b23f01375f281922f65c64cb0f6998f87144e685db2c9e0815ea7747ea573fa38f56
DIST parser-2.7.1.2.gem 782848 BLAKE2B 87a0ca30fe277d88a8ef013c450ab2823469a723906ecd67f4ed859e016d5df25b1c976a47c2333e538b7e8b99ce948e58f51a1a21c7686439382ff1e11e5222 SHA512 74c44c64d305de18de745ab09f63041d73435aa4c5a07042178a8a6a35cfdef30e1b55c02c7e7dc97469b8c46a705159a4f746da1c3b3f3a74df1d2d830ddcd3
+DIST parser-2.7.1.3.gem 785920 BLAKE2B 85ec4c6d0ff2c86937f3ca43e27d222d75c98a6d7c5cc38a58f466aa905f303577fb20cbd02e6c295f45ca9b83fa8decf27c7ed22149b0cfc6cec3b1a71afce8 SHA512 eb9018deda2418e728925c48fa27d373f3a25ae562b92798e6ce42e225afaf9631bcd3c98999ff5d11daf464d80a887f7f2b5a23ae9dafa5e12ffd8b46d7bf88
diff --git a/dev-ruby/parser/parser-2.7.0.4.ebuild b/dev-ruby/parser/parser-2.7.0.4.ebuild
deleted file mode 100644
index a1dfc9b62aad..000000000000
--- a/dev-ruby/parser/parser-2.7.0.4.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_RECIPE_DOC="yard"
-RUBY_FAKEGEM_TASK_TEST="test"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_VERSION="${PV/_pre/.pre.}"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A production-ready Ruby parser written in pure Ruby"
-HOMEPAGE="https://github.com/whitequark/parser"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-ruby_add_bdepend "test? (
- dev-ruby/minitest:5
- dev-ruby/racc
- dev-ruby/cliver )"
-ruby_add_rdepend "=dev-ruby/ast-2.4*"
-
-all_ruby_prepare() {
- sed -i -e "/[Bb]undler/d" Rakefile || die
- sed -i -e '/simplecov/ s:^:#:' test/helper.rb || die
-}
diff --git a/dev-ruby/parser/parser-2.7.0.5.ebuild b/dev-ruby/parser/parser-2.7.0.5.ebuild
deleted file mode 100644
index a1dfc9b62aad..000000000000
--- a/dev-ruby/parser/parser-2.7.0.5.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_RECIPE_DOC="yard"
-RUBY_FAKEGEM_TASK_TEST="test"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_VERSION="${PV/_pre/.pre.}"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A production-ready Ruby parser written in pure Ruby"
-HOMEPAGE="https://github.com/whitequark/parser"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-ruby_add_bdepend "test? (
- dev-ruby/minitest:5
- dev-ruby/racc
- dev-ruby/cliver )"
-ruby_add_rdepend "=dev-ruby/ast-2.4*"
-
-all_ruby_prepare() {
- sed -i -e "/[Bb]undler/d" Rakefile || die
- sed -i -e '/simplecov/ s:^:#:' test/helper.rb || die
-}
diff --git a/dev-ruby/parser/parser-2.7.0.3.ebuild b/dev-ruby/parser/parser-2.7.1.3.ebuild
index a1dfc9b62aad..a74e07888a7c 100644
--- a/dev-ruby/parser/parser-2.7.0.3.ebuild
+++ b/dev-ruby/parser/parser-2.7.1.3.ebuild
@@ -20,6 +20,8 @@ SLOT="0"
KEYWORDS="~amd64"
IUSE=""
+DEPEND+="test? ( =dev-util/ragel-6* )"
+
ruby_add_bdepend "test? (
dev-ruby/minitest:5
dev-ruby/racc
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 254a25fd3a6e..8fa343ae75f7 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -476,6 +476,8 @@ _distutils_verify_use_setuptools() {
expected=rdepend
elif grep -F -q -s '[options.entry_points]' setup.cfg; then
expected=rdepend
+ elif grep -F -q -s '[entry_points]' setup.cfg; then # pbr
+ expected=rdepend
else
expected=bdepend
fi
diff --git a/x11-themes/numix-gtk-theme/numix-gtk-theme-2.6.7-r1.ebuild b/x11-themes/numix-gtk-theme/numix-gtk-theme-2.6.7-r1.ebuild
deleted file mode 100644
index 8d5caa1ce812..000000000000
--- a/x11-themes/numix-gtk-theme/numix-gtk-theme-2.6.7-r1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby24 ruby25 ruby26"
-
-inherit ruby-ng
-
-DESCRIPTION="A modern flat theme with a combination of light and dark elements"
-HOMEPAGE="https://github.com/numixproject/numix-gtk-theme"
-SRC_URI="https://github.com/numixproject/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="dev-libs/libxml2:2
- x11-libs/gtk+:3
- x11-themes/gtk-engines-murrine"
-
-DEPEND="${RDEPEND}
- dev-libs/glib:2
- x11-libs/gdk-pixbuf:2"
-
-ruby_add_depend ">=dev-ruby/sass-3.5"
-
-S="${WORKDIR}/${P}"
-
-src_unpack() {
- default
-}
-
-src_prepare() {
- default
-}
-
-src_compile() {
- default
-}
-
-src_install() {
- default
-}
diff --git a/x11-wm/enlightenment/Manifest b/x11-wm/enlightenment/Manifest
index 65eb55da2e8d..936e25cd2cfb 100644
--- a/x11-wm/enlightenment/Manifest
+++ b/x11-wm/enlightenment/Manifest
@@ -1,2 +1,2 @@
DIST enlightenment-0.23.1.tar.xz 26426096 BLAKE2B d781dc951ad8eddd90f633b29a6b1180be63e6052a56e60644b4f738f4c0d42617aeb4f7326cf3284d0b331dd87d605fa0625ea6435f4e36b8f5b3ccce82ca53 SHA512 b5b8a34f6abe47d9b23dbcaf09d2f61f74b3f8d5a97b30a9666916b4bd307a45cb2ad874288419ab40ef06fa57c3b7dc15377dd9acaeb6eb71cd8c0c24fc42cb
-DIST enlightenment-0.24.0.tar.xz 28712348 BLAKE2B 97294beaf6456ca5512796fbfbff72207e2c57aad130f802b6a63c7a9a30e8bc6cd98ad6947a1f4edb8508a96ef135b66297827edfb63c4ea4330588677a9abc SHA512 7255ec5c2e85143df8d92e37456f5392feb3a264daa81ec6b10ae57886d714c524869392ddc753914f3a9c5fd71e1b2c5dd1d1e1f7a5a649fb6aaaed81214b95
+DIST enlightenment-0.24.1.tar.xz 28713452 BLAKE2B 1d4713a4887a687a5425888e65b358cd01fe12e42865799265f5092dc6784eb29c25b5563805d1c7be9856037b0570027c2f01a8eb848299e7729d905e291470 SHA512 3835d898f1fdb96ab6539543e9af910b4a9078372af5cfd90abb33c0d5ecb41496499629c54613e3fec4c230233b69bf1abde68f3ffba4996c69979a526da418
diff --git a/x11-wm/enlightenment/enlightenment-0.24.0.ebuild b/x11-wm/enlightenment/enlightenment-0.24.1.ebuild
index bf3eeb20a1d2..bf2169b4ee55 100644
--- a/x11-wm/enlightenment/enlightenment-0.24.0.ebuild
+++ b/x11-wm/enlightenment/enlightenment-0.24.1.ebuild
@@ -93,7 +93,7 @@ pkg_postinst() {
xdg_icon_cache_update
xdg_mimeinfo_database_update
- einfo "Additional programs to complete full EFL suite: "
+ elog "Additional programs to complete full EFL suite: "
optfeature "office file thumbnails" app-office/libreoffice app-office/libreoffice-bin
optfeature "an EFL-based IDE" dev-util/edi
optfeature "image viewer" media-gfx/ephoto