summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/chronic/chronic-0.10.2-r1.ebuild4
-rw-r--r--dev-ruby/hiera-eyaml/Manifest2
-rw-r--r--dev-ruby/hiera-eyaml/hiera-eyaml-3.1.1.ebuild48
-rw-r--r--dev-ruby/hiera-eyaml/hiera-eyaml-3.2.2.ebuild49
-rw-r--r--dev-ruby/highline/Manifest1
-rw-r--r--dev-ruby/highline/highline-2.1.0.ebuild34
-rw-r--r--dev-ruby/power_assert/Manifest1
-rw-r--r--dev-ruby/power_assert/power_assert-1.1.7.ebuild41
-rw-r--r--www-apps/gitea/Manifest1
-rw-r--r--www-apps/gitea/gitea-1.18.5.ebuild125
10 files changed, 163 insertions, 143 deletions
diff --git a/dev-ruby/chronic/chronic-0.10.2-r1.ebuild b/dev-ruby/chronic/chronic-0.10.2-r1.ebuild
index 42b160ad19dd..e0b73a7ec84e 100644
--- a/dev-ruby/chronic/chronic-0.10.2-r1.ebuild
+++ b/dev-ruby/chronic/chronic-0.10.2-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="HISTORY.md README.md"
diff --git a/dev-ruby/hiera-eyaml/Manifest b/dev-ruby/hiera-eyaml/Manifest
index e96204128486..8bb06486fe67 100644
--- a/dev-ruby/hiera-eyaml/Manifest
+++ b/dev-ruby/hiera-eyaml/Manifest
@@ -1,3 +1 @@
-DIST hiera-eyaml-3.1.1.tar.gz 54848 BLAKE2B 8daa4925bf1fb945ddb5ce7a485c3bf2bfca8747eb0cf00530eb91307d18d3f5c73699a30631b80e7825baac3a8b0c1695bd0313906bc8c7aba9c3c00d69b9cc SHA512 3bc93ca31af96383401f28644490f5540a70cf719e47d340794daf6c8bcc7fe9800d1d1e6ba99aba344831966f8d15f1a1fd9d1522696457f0bdec79dd45a108
-DIST hiera-eyaml-3.2.2.tar.gz 59174 BLAKE2B 2e31d1d0807096757f338a3f112a2f853f9dc61d14f92720a06e8835ef5b2228cea1ef2db1d5d7a2758422158acca14e882e1fa88a3189fcc254573e15e32185 SHA512 ac7800d35cba9b11e1fcfd831419caa1fb32fc1747499f780a40005cf57a87be4562f52251b8f5482156ad98892d41fe5060e48f74a75a0d1657dd5c04b8ee92
DIST hiera-eyaml-3.3.0.tar.gz 60385 BLAKE2B 222c0e531a0b713a0d996895168229468f131d9ce1dd786ef8337b5d9ec8a322e336bd12191253fb09e11d60682491081acd5b946a7257b6183e6533fe924811 SHA512 4bb81b87244177a4ab3ca80d0a5e67a8e6534dbdf4d489ca9f918ea97981e50d203e441cff6a35996878b6fa91815e00bdb8261e19359bb3f00efc14b1f25e0d
diff --git a/dev-ruby/hiera-eyaml/hiera-eyaml-3.1.1.ebuild b/dev-ruby/hiera-eyaml/hiera-eyaml-3.1.1.ebuild
deleted file mode 100644
index cb1acb35e03f..000000000000
--- a/dev-ruby/hiera-eyaml/hiera-eyaml-3.1.1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md PLUGINS.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Encrypted YAML backend for hiera"
-HOMEPAGE="https://github.com/TomPoulton/hiera-eyaml"
-SRC_URI="https://github.com/TomPoulton/hiera-eyaml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="3"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-ruby_add_rdepend ">=dev-ruby/highline-1.6.19:*"
-ruby_add_rdepend "dev-ruby/optimist"
-ruby_add_rdepend "!!dev-ruby/hiera-eyaml:0" # both install the /usr/bin/eyaml binary
-
-ruby_add_bdepend "test? ( dev-util/cucumber ~dev-util/aruba-0.6.2 <app-admin/puppet-6 dev-ruby/hiera-eyaml-plaintext )"
-
-all_ruby_prepare() {
- # Fix highline dependency to be compatible with more versions.
- sed -i -e '/highline/ s/~>/>=/' \
- -e '/gem.files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
-
- sed -i -e "s:/tmp:${T}:" \
- features/sandbox/puppet/environments/local/modules/test/manifests/run.pp \
- features/sandbox/puppet-hiera-merge/environments/local/modules/test/manifests/run.pp \
- features/puppet.feature
-}
-
-each_ruby_prepare() {
- # Run tests with the correct ruby interpreter
- sed -i -e 's:I run `eyaml:I run `'${RUBY}' '"${S}"'/bin/eyaml:' features/*.feature || die
-
-}
-
-each_ruby_test() {
- ${RUBY} -S cucumber --format progress features || die
-}
diff --git a/dev-ruby/hiera-eyaml/hiera-eyaml-3.2.2.ebuild b/dev-ruby/hiera-eyaml/hiera-eyaml-3.2.2.ebuild
deleted file mode 100644
index c20c61b8599b..000000000000
--- a/dev-ruby/hiera-eyaml/hiera-eyaml-3.2.2.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby26 ruby27"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md PLUGINS.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Encrypted YAML backend for hiera"
-HOMEPAGE="https://github.com/TomPoulton/hiera-eyaml"
-SRC_URI="https://github.com/TomPoulton/hiera-eyaml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="3"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-ruby_add_rdepend ">=dev-ruby/highline-1.6.19:*"
-ruby_add_rdepend "dev-ruby/optimist"
-ruby_add_rdepend "!!dev-ruby/hiera-eyaml:0" # both install the /usr/bin/eyaml binary
-
-ruby_add_bdepend "test? ( dev-util/cucumber ~dev-util/aruba-0.6.2 <app-admin/puppet-6 dev-ruby/hiera-eyaml-plaintext )"
-
-all_ruby_prepare() {
- # Fix highline dependency to be compatible with more versions.
- sed -i -e '/highline/ s/~>/>=/' \
- -e '/gem.files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
-
- sed -i -e "s:/tmp:${T}:" \
- features/sandbox/puppet/environments/local/modules/test/manifests/run.pp \
- features/sandbox/puppet-hiera-merge/environments/local/modules/test/manifests/run.pp \
- features/sandbox/puppet-envvar/environments/local/modules/test/manifests/run.pp \
- features/puppet.feature
-}
-
-each_ruby_prepare() {
- # Run tests with the correct ruby interpreter
- sed -i -e 's:I run `eyaml:I run `'${RUBY}' '"${S}"'/bin/eyaml:' features/*.feature || die
-
-}
-
-each_ruby_test() {
- ${RUBY} -S cucumber --format progress features || die
-}
diff --git a/dev-ruby/highline/Manifest b/dev-ruby/highline/Manifest
index ccf43edf3690..8837783258c4 100644
--- a/dev-ruby/highline/Manifest
+++ b/dev-ruby/highline/Manifest
@@ -1 +1,2 @@
DIST highline-2.0.3.tar.gz 234205 BLAKE2B 4748c3ad8a15e551162ab9f2eb6e176297d833d13e6f5db7898f99c71f25e8a2a01057b0438c5d30b56a66333bbba0da1a435cfa07db97f2ffc5e301157618ef SHA512 f432c8836040bcfb147a84efa2dd3feee7f3f6e03eafbf4232e9457aeef8cb9ca83fcf854d3b261f59a166666abc3f2c8fc0f1279a7efeb07dea8a13be22ebde
+DIST highline-2.1.0.tar.gz 234116 BLAKE2B e1e899093de7e162e83f4d2e694e5841cedc336063a4410cab392702241136d5eec258b53065ffcded567f0af163d04a25bbdfd0767211b059980e9e5effe7c9 SHA512 b763428d67b1eb77762b54b8e2dd39bda720589e7030db8694e793bb432fa94caa2848b23358e7eaea0ccb22d8a93e0a64aeef3865f7e9fec348bbebee19d713
diff --git a/dev-ruby/highline/highline-2.1.0.ebuild b/dev-ruby/highline/highline-2.1.0.ebuild
new file mode 100644
index 000000000000..b503aee0e9dc
--- /dev/null
+++ b/dev-ruby/highline/highline-2.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md TODO"
+
+RUBY_FAKEGEM_GEMSPEC="highline.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Highline is a high-level command-line IO library for ruby"
+HOMEPAGE="https://github.com/JEG2/highline"
+SRC_URI="https://github.com/JEG2/highline/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+IUSE=""
+LICENSE="|| ( GPL-2 Ruby-BSD )"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+
+all_ruby_prepare() {
+ # fix up gemspec file not to call git
+ sed -i -e 's/git ls-files -z/find * -print0/' highline.gemspec || die
+
+ # Avoid unneeded dependencies
+ sed -i -e '/\(bundler\|code_statistics\)/ s:^:#:' \
+ -e '/PackageTask/,/end/ s:^:#:' Rakefile || die
+ sed -i -e '/simplecov/ s:^:#:' test/test_helper.rb || die
+
+ # Remove almost empty doc directory to allow rdoc recipe to work
+ rm -rf doc || die
+}
diff --git a/dev-ruby/power_assert/Manifest b/dev-ruby/power_assert/Manifest
index bf3ad5e65e72..6027d93319e3 100644
--- a/dev-ruby/power_assert/Manifest
+++ b/dev-ruby/power_assert/Manifest
@@ -1,4 +1,3 @@
-DIST power_assert-1.1.7.tar.gz 17361 BLAKE2B 54fe379af9231a1794534f0199bb587418ea6d0960f7ae5cfc3a9c484c692e08254b5bd7220120559cc1b9e6f1b85c73d0e8e58c115731faea72d70180a94336 SHA512 bc6649bf17f41f7c84611eb334b73b43a0b7c3892a46acb82ae7b43dcf43b7a556ad617a6806ce1d354796bc694cea9eef7cc47b1928102f1822a03e01160a35
DIST power_assert-1.2.0.tar.gz 17358 BLAKE2B 8b75b34f5d80f8f52370816b916e3bc3a60493b8f52a910346c51c70770e0645566b8b7c3dd551d8bb1f1cbdac5dfcebe043457bd025d819e3782e75e41e0f16 SHA512 2f001f6223fc3fb586c7b0457f775379040e11eb83b5bdda51c02b2b24e531aecd6e12e6ec80bf9407a768ab1a10b0a6b4c8f1a92ca69ea702faf56202bb635c
DIST power_assert-2.0.0.tar.gz 16994 BLAKE2B 5106e77566100274000c55af1bd2ff9aaf00185ed1821ac966587461919210d7460e30aefdb5a880e7ef59e4f536121371d0862df2af91cb274ed79ded8c9771 SHA512 e6faf3cf50d2c70ae421bae20b885ac858fe11b10b1a8562d9ca88afbd397fa4812631f2aa02638c273eed518091dfaa020b6c002c0559383ddca625404bcc1c
DIST power_assert-2.0.1.tar.gz 17062 BLAKE2B 9c592c12e0722a3376fede86b1a609c4c5feec49dacdb74f5af96d7ee3024112525bdd57fd5d1763b3a599386ce6548d694f5a4b1207c356701c79046166ee42 SHA512 717d163050e45d889bbf50ee5caf4d91b143a0df45d8ed1be9588595fd485f05662d59ae6166d44b5cf987d6b2a1e77f40441f2aefd1051ff9cf679d3bcdddc6
diff --git a/dev-ruby/power_assert/power_assert-1.1.7.ebuild b/dev-ruby/power_assert/power_assert-1.1.7.ebuild
deleted file mode 100644
index 1056c61f570d..000000000000
--- a/dev-ruby/power_assert/power_assert-1.1.7.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_EXTRADOC="README.rdoc"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-RUBY_FAKEGEM_GEMSPEC="power_assert.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Shows each value of variables and method calls in the expression"
-HOMEPAGE="https://github.com/k-tsj/power_assert"
-SRC_URI="https://github.com/k-tsj/power_assert/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="|| ( Ruby BSD-2 )"
-
-KEYWORDS="~alpha amd64 arm arm64 hppa ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-SLOT="0"
-IUSE=""
-
-ruby_add_bdepend "test? ( dev-ruby/test-unit )"
-
-all_ruby_prepare() {
- sed -i -e '/bundler/I s:^:#:' Rakefile test/test_helper.rb || die
- sed -i -e '1igem "test-unit"' \
- -e '/byebug/ s:^:#:' test/test_helper.rb || die
-
- # Avoid git dependency
- sed -i -e 's/git ls-files -z/find . -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
-
- # Avoid circular dependency on byebug when bootstrapping ruby
- sed -i -e '/byebug/ s:^:#:' -e '/test_core_ext_helper/ s:^:#:' test/test_helper.rb || die
- rm test/test_core_ext_helper.rb test/trace_test.rb || die
-
- # Avoid circular dependency on pry when bootstrapping ruby
- sed -i -e '/pry/ s:^:#:' -e '/test_colorized_pp/,/^ end/ s:^:#:' test/block_test.rb || die
-}
diff --git a/www-apps/gitea/Manifest b/www-apps/gitea/Manifest
index 8f27ddfe0429..af08bd90cad0 100644
--- a/www-apps/gitea/Manifest
+++ b/www-apps/gitea/Manifest
@@ -1 +1,2 @@
DIST gitea-1.18.3.tar.gz 55493166 BLAKE2B 6a0bb385244c212f577b99b54cd621bf4b9b4f7bdd77bf199e2667fcb5b77638136b2c26b0a46d755d5aea359f0eea251762f759b461377d459092c0017ed972 SHA512 4dabcafad5f4f9804f369cf248b351db68e80f193a4b2a5901f8c13b7cb6051b6b5ef1f283037376e545c3b76aabe703e947d1780ed4a4e630ec68adffa8afff
+DIST gitea-1.18.5.tar.gz 55521804 BLAKE2B fe413fce8bdba68a9ea1a75f66a69c899ca7fca367e9f3e2bbad7f506d3dd2019f634e708ff7079f31c98ccdab5605187dff20118e91675f33e2f28cee547aab SHA512 20b502a11969691e5f331844453aedc5bd1708ff13e0615b7186b00f8fa6fe8de2b2c6ec1af052bfd6f87a07c92e1118e58aacf35f59bde32d587ba400adda8a
diff --git a/www-apps/gitea/gitea-1.18.5.ebuild b/www-apps/gitea/gitea-1.18.5.ebuild
new file mode 100644
index 000000000000..14e3dc8458e3
--- /dev/null
+++ b/www-apps/gitea/gitea-1.18.5.ebuild
@@ -0,0 +1,125 @@
+# Copyright 2016-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fcaps go-module tmpfiles systemd flag-o-matic
+
+DESCRIPTION="A painless self-hosted Git service"
+HOMEPAGE="https://gitea.io https://github.com/go-gitea/gitea"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/go-gitea/gitea.git"
+else
+ SRC_URI="https://github.com/go-gitea/gitea/releases/download/v${PV}/gitea-src-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+S="${WORKDIR}/${PN}-src-${PV}"
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC MIT MPL-2.0"
+SLOT="0"
+IUSE="+acct pam sqlite pie"
+
+DEPEND="
+ acct? (
+ acct-group/git
+ acct-user/git[gitea] )
+ pam? ( sys-libs/pam )"
+RDEPEND="${DEPEND}
+ dev-vcs/git"
+
+DOCS=(
+ custom/conf/app.example.ini CONTRIBUTING.md README.md
+)
+FILECAPS=(
+ -m 711 cap_net_bind_service+ep usr/bin/gitea
+)
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+
+ local sedcmds=(
+ -e "s#^ROOT =#ROOT = ${EPREFIX}/var/lib/gitea/gitea-repositories#"
+ -e "s#^ROOT_PATH =#ROOT_PATH = ${EPREFIX}/var/log/gitea#"
+ -e "s#^APP_DATA_PATH = data#APP_DATA_PATH = ${EPREFIX}/var/lib/gitea/data#"
+ -e "s#^HTTP_ADDR = 0.0.0.0#HTTP_ADDR = 127.0.0.1#"
+ -e "s#^MODE = console#MODE = file#"
+ -e "s#^LEVEL = Trace#LEVEL = Info#"
+ -e "s#^LOG_SQL = true#LOG_SQL = false#"
+ -e "s#^DISABLE_ROUTER_LOG = false#DISABLE_ROUTER_LOG = true#"
+ )
+
+ sed -i "${sedcmds[@]}" custom/conf/app.example.ini || die
+ if use sqlite ; then
+ sed -i -e "s#^DB_TYPE = .*#DB_TYPE = sqlite3#" custom/conf/app.example.ini || die
+ fi
+}
+
+src_configure() {
+ # bug 832756 - PIE build issues
+ filter-flags -fPIE
+ filter-ldflags -fPIE -pie
+}
+
+src_compile() {
+ local gitea_tags=(
+ bindata
+ $(usev pam)
+ $(usex sqlite 'sqlite sqlite_unlock_notify' '')
+ )
+ local gitea_settings=(
+ "-X code.gitea.io/gitea/modules/setting.CustomConf=${EPREFIX}/etc/gitea/app.ini"
+ "-X code.gitea.io/gitea/modules/setting.CustomPath=${EPREFIX}/var/lib/gitea/custom"
+ "-X code.gitea.io/gitea/modules/setting.AppWorkPath=${EPREFIX}/var/lib/gitea"
+ )
+ local makeenv=(
+ DRONE_TAG="${PV}"
+ LDFLAGS="-extldflags \"${LDFLAGS}\" ${gitea_settings[*]}"
+ TAGS="${gitea_tags[*]}"
+ )
+
+ GOFLAGS=""
+ if use pie ; then
+ GOFLAGS+="-buildmode=pie"
+ fi
+
+ env "${makeenv[@]}" emake EXTRA_GOFLAGS="${GOFLAGS}" backend
+}
+
+src_install() {
+ dobin gitea
+
+ einstalldocs
+
+ newconfd "${FILESDIR}/gitea.confd-r1" gitea
+ newinitd "${FILESDIR}/gitea.initd-r3" gitea
+ newtmpfiles - gitea.conf <<-EOF
+ d /run/gitea 0755 git git
+ EOF
+ systemd_newunit "${FILESDIR}"/gitea.service-r3 gitea.service
+
+ insinto /etc/gitea
+ newins custom/conf/app.example.ini app.ini
+ if use acct; then
+ fowners root:git /etc/gitea/{,app.ini}
+ fperms g+w,o-rwx /etc/gitea/{,app.ini}
+
+ diropts -m0750 -o git -g git
+ keepdir /var/lib/gitea /var/lib/gitea/custom /var/lib/gitea/data
+ keepdir /var/log/gitea
+ fi
+}
+
+pkg_postinst() {
+ fcaps_pkg_postinst
+ tmpfiles_process gitea.conf
+
+ ewarn "The default JWT signing algorithm changed in 1.15.0 from HS256 (symmetric) to"
+ ewarn "RS256 (asymmetric). Gitea OAuth2 tokens (and potentially client secrets) will"
+ ewarn "need to be regenerated unless you change your JWT_SIGNING_ALGORITHM back to HS256."
+ ewarn "For other breaking changes, see <https://github.com/go-gitea/gitea/releases/tag/v1.15.0>."
+}