summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--eclass/optfeature.eclass6
-rw-r--r--eclass/perl-functions.eclass46
-rw-r--r--eclass/perl-module.eclass123
-rw-r--r--net-misc/openvswitch/openvswitch-2.17.2-r1.ebuild (renamed from net-misc/openvswitch/openvswitch-2.17.2.ebuild)2
4 files changed, 69 insertions, 108 deletions
diff --git a/eclass/optfeature.eclass b/eclass/optfeature.eclass
index acf8584e6dbc..b44fc1b85251 100644
--- a/eclass/optfeature.eclass
+++ b/eclass/optfeature.eclass
@@ -1,14 +1,14 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: optfeature.eclass
# @MAINTAINER:
# base-system@gentoo.org
-# @SUPPORTED_EAPIS: 6 7 8
+# @SUPPORTED_EAPIS: 7 8
# @BLURB: Advertise optional functionality that might be useful to users
case ${EAPI} in
- 6|7|8) ;;
+ 7|8) ;;
*) die "${ECLASS}: EAPI=${EAPI:-0} is not supported" ;;
esac
diff --git a/eclass/perl-functions.eclass b/eclass/perl-functions.eclass
index 106394afa15a..142fdeb8cfbd 100644
--- a/eclass/perl-functions.eclass
+++ b/eclass/perl-functions.eclass
@@ -8,7 +8,7 @@
# Seemant Kulleen <seemant@gentoo.org>
# Andreas K. Huettel <dilfridge@gentoo.org>
# Kent Fredric <kentnl@gentoo.org>
-# @SUPPORTED_EAPIS: 6 7 8
+# @SUPPORTED_EAPIS: 7 8
# @BLURB: helper functions eclass for perl modules
# @DESCRIPTION:
# The perl-functions eclass is designed to allow easier installation of perl
@@ -17,7 +17,7 @@
# global scope.
case ${EAPI} in
- 6|7|8)
+ 7|8)
;;
*)
die "${ECLASS}: EAPI ${EAPI:-0} not supported"
@@ -44,7 +44,8 @@ perlinfo_done=false
# echo $PERL_VERSION
# @CODE
perl_set_version() {
- debug-print-function $FUNCNAME "$@"
+ debug-print-function ${FUNCNAME} "$@"
+
debug-print "$FUNCNAME: perlinfo_done=${perlinfo_done}"
${perlinfo_done} && return 0
perlinfo_done=true
@@ -65,7 +66,7 @@ perl_set_version() {
#
# This function used to be called fixlocalpod as well.
perl_delete_localpod() {
- debug-print-function $FUNCNAME "$@"
+ debug-print-function ${FUNCNAME} "$@"
find "${D}" -type f -name perllocal.pod -delete
find "${D}" -depth -mindepth 1 -type d -empty -delete
@@ -75,7 +76,7 @@ perl_delete_localpod() {
# @DESCRIPTION:
# Look through ${S} for AppleDouble encoded files and get rid of them.
perl_fix_osx_extra() {
- debug-print-function $FUNCNAME "$@"
+ debug-print-function ${FUNCNAME} "$@"
local f
find "${S}" -type f -name "._*" -print0 | while read -rd '' f ; do
@@ -92,7 +93,7 @@ perl_fix_osx_extra() {
# Bump off manpages installed by the current module such as *.3pm files as well
# as empty directories.
perl_delete_module_manpages() {
- debug-print-function $FUNCNAME "$@"
+ debug-print-function ${FUNCNAME} "$@"
if [[ -d "${ED}"/usr/share/man ]] ; then
find "${ED}"/usr/share/man -type f -name "*.3pm" -delete
@@ -105,7 +106,8 @@ perl_delete_module_manpages() {
# Look through ${D} for .packlist files, empty .bs files and empty directories,
# and get rid of items found.
perl_delete_packlist() {
- debug-print-function $FUNCNAME "$@"
+ debug-print-function ${FUNCNAME} "$@"
+
perl_set_version
if [[ -d ${D}/${VENDOR_ARCH} ]] ; then
find "${D}/${VENDOR_ARCH}" -type f -a -name .packlist -delete
@@ -118,7 +120,8 @@ perl_delete_packlist() {
# Look through ${D} for empty .bs files and empty directories,
# and get rid of items found.
perl_delete_emptybsdir() {
- debug-print-function $FUNCNAME "$@"
+ debug-print-function ${FUNCNAME} "$@"
+
perl_set_version
if [[ -d ${D}/${VENDOR_ARCH} ]] ; then
find "${D}/${VENDOR_ARCH}" -type f \
@@ -132,7 +135,8 @@ perl_delete_emptybsdir() {
# Make all of ${D} user-writable, since EU::MM does silly things with
# the w bit. See bug 554346.
perl_fix_permissions() {
- debug-print-function $FUNCNAME "$@"
+ debug-print-function ${FUNCNAME} "$@"
+
perl_set_version
einfo Fixing installed file permissions
fperms -R u+w /
@@ -145,7 +149,7 @@ perl_fix_permissions() {
# Remove duplicate entries; then validate all entries in the packlist against ${D}
# and prune entries that do not correspond to installed files.
perl_fix_packlist() {
- debug-print-function $FUNCNAME "$@"
+ debug-print-function ${FUNCNAME} "$@"
local packlist_temp="${T}/.gentoo_packlist_temp"
find "${D}" -type f -name '.packlist' -print0 | while read -rd '' f ; do
@@ -176,7 +180,7 @@ perl_fix_packlist() {
# Look through ${D} for text files containing the temporary installation
# folder (i.e. ${D}). If the pattern is found, replace it with `/' and warn.
perl_remove_temppath() {
- debug-print-function $FUNCNAME "$@"
+ debug-print-function ${FUNCNAME} "$@"
find "${D}" -type f -not -name '*.so' -print0 | while read -rd '' f ; do
if file "${f}" | grep -q -i " text" ; then
@@ -209,7 +213,8 @@ perl_remove_temppath() {
# }
# @CODE
perl_rm_files() {
- debug-print-function $FUNCNAME "$@"
+ debug-print-function ${FUNCNAME} "$@"
+
local skipfile="${T}/.gentoo_makefile_skip"
local manifile="${S}/MANIFEST"
local manitemp="${T}/.gentoo_manifest_temp"
@@ -236,7 +241,8 @@ perl_rm_files() {
# lead to file collisions. Mainly for use in pkg_postinst and pkg_postrm, and makes
# only sense for perl-core packages.
perl_link_duallife_scripts() {
- debug-print-function $FUNCNAME "$@"
+ debug-print-function ${FUNCNAME} "$@"
+
[[ ${CATEGORY} != perl-core ]] && return 0
local i ff
@@ -328,7 +334,7 @@ perl_check_env() {
# }
# @CODE
perl_doexamples() {
- debug-print-function $FUNCNAME "$@"
+ debug-print-function ${FUNCNAME} "$@"
einfo "Installing examples into /usr/share/doc/${PF}/examples"
@@ -362,7 +368,7 @@ perl_doexamples() {
# @CODE
perl_has_module() {
- debug-print-function $FUNCNAME "$@"
+ debug-print-function ${FUNCNAME} "$@"
[[ $# -gt 0 ]] || die "${FUNCNAME}: No module name provided"
[[ $# -lt 2 ]] || die "${FUNCNAME}: Too many parameters ($#)"
@@ -400,7 +406,7 @@ perl_has_module() {
# && echo "Test::Tester 0.017 or greater installed"
# @CODE
perl_has_module_version() {
- debug-print-function $FUNCNAME "$@"
+ debug-print-function ${FUNCNAME} "$@"
[[ $# -gt 0 ]] || die "${FUNCNAME}: No module name provided"
[[ $# -gt 1 ]] || die "${FUNCNAME}: No module version provided"
@@ -441,7 +447,7 @@ perl_has_module_version() {
# @CODE
perl_get_module_version() {
- debug-print-function $FUNCNAME "$@"
+ debug-print-function ${FUNCNAME} "$@"
[[ $# -gt 0 ]] || die "${FUNCNAME}: No module name provided"
[[ $# -lt 2 ]] || die "${FUNCNAME}: Too many parameters ($#)"
@@ -487,7 +493,7 @@ perl_get_module_version() {
# @CODE
perl_get_raw_vendorlib() {
- debug-print-function $FUNCNAME "$@"
+ debug-print-function ${FUNCNAME} "$@"
[[ $# -lt 1 ]] || die "${FUNCNAME}: Too many parameters ($#)"
@@ -508,7 +514,7 @@ perl_get_raw_vendorlib() {
# @CODE
perl_get_vendorlib() {
- debug-print-function $FUNCNAME "$@"
+ debug-print-function ${FUNCNAME} "$@"
[[ $# -lt 1 ]] || die "${FUNCNAME}: Too many parameters ($#)"
@@ -607,7 +613,7 @@ perl_domodule() {
# @CODE
perl_get_wikiurl() {
- debug-print-function $FUNCNAME "$@"
+ debug-print-function ${FUNCNAME} "$@"
if [[ -z "${1}" ]]; then
echo "https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/${CATEGORY}/${PN}"
diff --git a/eclass/perl-module.eclass b/eclass/perl-module.eclass
index d1f9dc6ffccd..25490c25058a 100644
--- a/eclass/perl-module.eclass
+++ b/eclass/perl-module.eclass
@@ -7,7 +7,7 @@
# @AUTHOR:
# Seemant Kulleen <seemant@gentoo.org>
# Andreas K. Hüttel <dilfridge@gentoo.org>
-# @SUPPORTED_EAPIS: 6 7 8
+# @SUPPORTED_EAPIS: 7 8
# @PROVIDES: perl-functions
# @BLURB: eclass for installing Perl module distributions
# @DESCRIPTION:
@@ -20,7 +20,7 @@
# instead.
case ${EAPI} in
- 6|7)
+ 7)
inherit multiprocessing perl-functions
PERL_EXPF="src_prepare src_configure src_compile src_test src_install"
;;
@@ -39,39 +39,12 @@ esac
# This variable controls whether a runtime and build time dependency on
# dev-lang/perl is automatically added by the eclass. It defaults to yes.
# Set to no to disable, set to noslotop to add a perl dependency without
-# slot operator (EAPI=6). All packages installing into the vendor_perl
+# slot operator. All packages installing into the vendor_perl
# path must use yes here. (EAPI=8 and later) Also adds a test useflag,
# a use-conditional build time dependency on virtual/perl-Test-Simple, and
# the required RESTRICT setting.
case ${EAPI} in
- 6)
- [[ ${CATEGORY} == perl-core ]] && \
- PERL_EXPF+=" pkg_postinst pkg_postrm"
-
- case "${GENTOO_DEPEND_ON_PERL:-yes}" in
- yes)
- DEPEND="dev-lang/perl"
- RDEPEND="dev-lang/perl:="
- ;;
- noslotop)
- DEPEND="dev-lang/perl"
- RDEPEND="dev-lang/perl"
- ;;
- esac
-
- if [[ "${GENTOO_DEPEND_ON_PERL_SUBSLOT:-yes}" != "yes" ]]; then
- eerror "GENTOO_DEPEND_ON_PERL_SUBSLOT=no is banned in EAPI=6 and later. If you don't want a slot operator"
- die "set GENTOO_DEPEND_ON_PERL=noslotop instead."
- fi
-
- if [[ "${PERL_EXPORT_PHASE_FUNCTIONS}" ]]; then
- eerror "PERL_EXPORT_PHASE_FUNCTIONS is banned in EAPI=6 and later. Use perl-module.eclass if you need"
- die "phase functions, perl-functions.eclass if not."
- fi
-
- EXPORT_FUNCTIONS ${PERL_EXPF}
- ;;
7)
[[ ${CATEGORY} == perl-core ]] && \
PERL_EXPF+=" pkg_postinst pkg_postrm"
@@ -90,11 +63,11 @@ case ${EAPI} in
esac
if [[ "${GENTOO_DEPEND_ON_PERL_SUBSLOT:-yes}" != "yes" ]]; then
- die "GENTOO_DEPEND_ON_PERL_SUBSLOT=no is banned in EAPI=6 and later."
+ die "GENTOO_DEPEND_ON_PERL_SUBSLOT=no is banned."
fi
if [[ "${PERL_EXPORT_PHASE_FUNCTIONS}" ]]; then
- die "PERL_EXPORT_PHASE_FUNCTIONS is banned in EAPI=6 and later."
+ die "PERL_EXPORT_PHASE_FUNCTIONS is banned."
fi
EXPORT_FUNCTIONS ${PERL_EXPF}
@@ -120,11 +93,11 @@ case ${EAPI} in
esac
if [[ "${GENTOO_DEPEND_ON_PERL_SUBSLOT:-yes}" != "yes" ]]; then
- die "GENTOO_DEPEND_ON_PERL_SUBSLOT=no is banned in EAPI=6 and later."
+ die "GENTOO_DEPEND_ON_PERL_SUBSLOT=no is banned."
fi
if [[ "${PERL_EXPORT_PHASE_FUNCTIONS}" ]]; then
- die "PERL_EXPORT_PHASE_FUNCTIONS is banned in EAPI=6 and later."
+ die "PERL_EXPORT_PHASE_FUNCTIONS is banned."
fi
EXPORT_FUNCTIONS ${PERL_EXPF}
@@ -218,7 +191,7 @@ pm_echovar=""
# Get the ebuild sources ready.
# This function is to be called during the ebuild src_prepare() phase.
perl-module_src_prepare() {
- debug-print-function $FUNCNAME "$@"
+ debug-print-function ${FUNCNAME} "$@"
default
@@ -234,7 +207,7 @@ perl-module_src_prepare() {
# Configure the ebuild sources.
# This function is to be called during the ebuild src_configure() phase.
perl-module_src_configure() {
- debug-print-function $FUNCNAME "$@"
+ debug-print-function ${FUNCNAME} "$@"
perl_check_env
@@ -251,38 +224,20 @@ perl-module_src_configure() {
fi
if [[ ( ${PREFER_BUILDPL} == yes || ! -f Makefile.PL ) && -f Build.PL ]] ; then
- case ${EAPI} in
- 6)
- if grep -q '\(use\|require\)\s*Module::Build::Tiny' Build.PL ; then
- einfo "Using Module::Build::Tiny"
- if [[ ${DEPEND} != *dev-perl/Module-Build-Tiny* && ${PN} != Module-Build-Tiny ]]; then
- eerror "QA Notice: The ebuild uses Module::Build::Tiny but doesn't depend on it."
- die " Add dev-perl/Module-Build-Tiny to DEPEND!"
- fi
- else
- einfo "Using Module::Build"
- if [[ ${DEPEND} != *virtual/perl-Module-Build* && ${DEPEND} != *dev-perl/Module-Build* && ${PN} != Module-Build ]] ; then
- eerror "QA Notice: The ebuild uses Module::Build but doesn't depend on it."
- die " Add dev-perl/Module-Build to DEPEND!"
- fi
- fi
- ;;
- *)
- if grep -q '\(use\|require\)\s*Module::Build::Tiny' Build.PL ; then
- einfo "Using Module::Build::Tiny"
- if [[ ${BDEPEND} != *dev-perl/Module-Build-Tiny* && ${PN} != Module-Build-Tiny ]]; then
- eerror "QA Notice: The ebuild uses Module::Build::Tiny but doesn't depend on it."
- eerror " Add dev-perl/Module-Build-Tiny to BDEPEND!"
- fi
- else
- einfo "Using Module::Build"
- if [[ ${BDEPEND} != *virtual/perl-Module-Build* && ${BDEPEND} != *dev-perl/Module-Build* && ${PN} != Module-Build ]] ; then
- eerror "QA Notice: The ebuild uses Module::Build but doesn't depend on it."
- eerror " Add dev-perl/Module-Build to BDEPEND!"
- fi
- fi
- ;;
- esac
+ if grep -q '\(use\|require\)\s*Module::Build::Tiny' Build.PL ; then
+ einfo "Using Module::Build::Tiny"
+ if [[ ${BDEPEND} != *dev-perl/Module-Build-Tiny* && ${PN} != Module-Build-Tiny ]]; then
+ eerror "QA Notice: The ebuild uses Module::Build::Tiny but doesn't depend on it."
+ eerror " Add dev-perl/Module-Build-Tiny to BDEPEND!"
+ fi
+ else
+ einfo "Using Module::Build"
+ if [[ ${BDEPEND} != *virtual/perl-Module-Build* && ${BDEPEND} != *dev-perl/Module-Build* && ${PN} != Module-Build ]] ; then
+ eerror "QA Notice: The ebuild uses Module::Build but doesn't depend on it."
+ eerror " Add dev-perl/Module-Build to BDEPEND!"
+ fi
+ fi
+
set -- \
--installdirs=vendor \
--libdoc= \
@@ -315,11 +270,12 @@ perl-module_src_configure() {
# Compile the ebuild sources.
# This function is to be called during the ebuild src_compile() phase.
perl-module_src_compile() {
- debug-print-function $FUNCNAME "$@"
+ debug-print-function ${FUNCNAME} "$@"
+
perl_set_version
case ${EAPI} in
- 6|7)
+ 7)
if [[ $(declare -p mymake 2>&-) != "declare -a mymake="* ]]; then
local mymake_local=(${mymake})
else
@@ -338,10 +294,7 @@ perl-module_src_compile() {
set -- \
OTHERLDFLAGS="${LDFLAGS}" \
"${mymake_local[@]}"
- einfo "emake" "$@"
- emake "$@" \
- || die "Compilation failed"
-# OPTIMIZE="${CFLAGS}" \
+ emake "$@"
fi
}
@@ -372,7 +325,8 @@ perl-module_src_compile() {
# This code attempts to work out your threadingness and runs tests
# according to the settings of DIST_TEST using Test::Harness.
perl-module_src_test() {
- debug-print-function $FUNCNAME "$@"
+ debug-print-function ${FUNCNAME} "$@"
+
local my_test_control
local my_test_verbose
@@ -401,7 +355,7 @@ perl-module_src_test() {
fi
case ${EAPI} in
- 6|7)
+ 7)
;;
*)
if has 'tests' ${DIST_WIKI} ; then
@@ -416,7 +370,7 @@ perl-module_src_test() {
if [[ -f Build ]] ; then
./Build test verbose=${my_test_verbose} || die "test failed"
elif [[ -f Makefile ]] ; then
- emake test TEST_VERBOSE=${my_test_verbose} || die "test failed"
+ emake test TEST_VERBOSE=${my_test_verbose}
fi
}
@@ -425,7 +379,7 @@ perl-module_src_test() {
# Install a Perl ebuild.
# This function is to be called during the ebuild src_install() phase.
perl-module_src_install() {
- debug-print-function $FUNCNAME "$@"
+ debug-print-function ${FUNCNAME} "$@"
perl_set_version
@@ -447,12 +401,11 @@ perl-module_src_install() {
else
local myinst_local=("${myinst[@]}")
fi
- emake "${myinst_local[@]}" ${mytargets} \
- || die "emake ${myinst_local[@]} ${mytargets} failed"
+ emake "${myinst_local[@]}" ${mytargets}
fi
case ${EAPI} in
- 6|7)
+ 7)
;;
*)
perl_fix_permissions
@@ -476,7 +429,7 @@ perl-module_src_install() {
perl_link_duallife_scripts
case ${EAPI} in
- 6|7)
+ 7)
;;
*)
if has 'features' ${DIST_WIKI} ; then
@@ -499,7 +452,8 @@ perl-module_src_install() {
# links that prevent file collisions for dual-life packages installing scripts.
# In any other category it immediately exits.
perl-module_pkg_postinst() {
- debug-print-function $FUNCNAME "$@"
+ debug-print-function ${FUNCNAME} "$@"
+
if [[ ${CATEGORY} != perl-core ]] ; then
eerror "perl-module.eclass: You are calling perl-module_pkg_postinst outside the perl-core category."
die " This does not do anything; the call can be removed."
@@ -514,7 +468,8 @@ perl-module_pkg_postinst() {
# links that prevent file collisions for dual-life packages installing scripts.
# In any other category it immediately exits.
perl-module_pkg_postrm() {
- debug-print-function $FUNCNAME "$@"
+ debug-print-function ${FUNCNAME} "$@"
+
if [[ ${CATEGORY} != perl-core ]] ; then
eerror "perl-module.eclass: You are calling perl-module_pkg_postrm outside the perl-core category."
die " This does not do anything; the call can be removed."
diff --git a/net-misc/openvswitch/openvswitch-2.17.2.ebuild b/net-misc/openvswitch/openvswitch-2.17.2-r1.ebuild
index 4d3678b83503..4f04cb37a9a8 100644
--- a/net-misc/openvswitch/openvswitch-2.17.2.ebuild
+++ b/net-misc/openvswitch/openvswitch-2.17.2-r1.ebuild
@@ -21,7 +21,7 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
# Check python/ovs/version.py in tarball for dev-python/ovs dep
RDEPEND="${PYTHON_DEPS}
~dev-python/ovs-2.17.1_p1[${PYTHON_USEDEP}]
- dev-python/twisted[conch,${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]
debug? ( dev-lang/perl )
ssl? ( dev-libs/openssl:= )"