summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/pastel/Manifest1
-rw-r--r--dev-ruby/pastel/pastel-0.7.4.ebuild33
-rw-r--r--dev-ruby/pastel/pastel-0.8.0.ebuild2
-rw-r--r--dev-ruby/ttfunk/ttfunk-1.7.0.ebuild4
-rw-r--r--dev-ruby/tty-color/tty-color-0.6.0.ebuild2
-rw-r--r--dev-ruby/tty-command/tty-command-0.10.1-r1.ebuild2
-rw-r--r--dev-ruby/tty-command/tty-command-0.10.1.ebuild32
-rw-r--r--dev-ruby/tty-cursor/tty-cursor-0.7.1.ebuild2
-rw-r--r--dev-ruby/tty-editor/tty-editor-0.7.0.ebuild2
-rw-r--r--dev-ruby/tty-prompt/tty-prompt-0.23.1.ebuild2
-rw-r--r--dev-ruby/tty-reader/tty-reader-0.9.0.ebuild2
-rw-r--r--dev-ruby/tty-screen/Manifest1
-rw-r--r--dev-ruby/tty-screen/tty-screen-0.7.1.ebuild29
-rw-r--r--dev-ruby/tty-screen/tty-screen-0.8.1.ebuild2
-rw-r--r--eclass/ruby-ng.eclass1
15 files changed, 11 insertions, 106 deletions
diff --git a/dev-ruby/pastel/Manifest b/dev-ruby/pastel/Manifest
index bb354ada0143..df3b0908ba9c 100644
--- a/dev-ruby/pastel/Manifest
+++ b/dev-ruby/pastel/Manifest
@@ -1,2 +1 @@
-DIST pastel-0.7.4.tar.gz 48176 BLAKE2B 3564aba28f9315d2f988dabdd0686e6c7a53c1b200e6e03519c1ebcde917503760d4f0d790e456c7a732b47535f692d7f5b88cf786e5b4236e9b2e8b5eee66d7 SHA512 a1ad8487babd1e788282e141538855370e09bb2745731670b814cb4572c54e0568955108f7657809b98f92b94d9d94cdd555e2db8146b20f80db98bbab3512ea
DIST pastel-0.8.0.tar.gz 49560 BLAKE2B 646cdf5f7cd1e62e83d87cdcdbbdc2cb2619fd570b4715191825344346053b7bf8f8f18b177a8bad6416c13858ab007d94ccf5c16b71c123e4a3d2fd03cd0720 SHA512 8066b372f08e1d6312b87744309692e3e6fd5e2737374bce53087af45141ea4f14e67ead6dccb11df70f73cbb0611ab9e20f7fb553d87a349996bda0f7a3862d
diff --git a/dev-ruby/pastel/pastel-0.7.4.ebuild b/dev-ruby/pastel/pastel-0.7.4.ebuild
deleted file mode 100644
index fdd5b02e3bc1..000000000000
--- a/dev-ruby/pastel/pastel-0.7.4.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_GEMSPEC="pastel.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Terminal strings styling with intuitive and clean API"
-HOMEPAGE="https://github.com/piotrmurach/pastel"
-SRC_URI="https://github.com/piotrmurach/pastel/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-ruby_add_rdepend "
- >=dev-ruby/equatable-0.6:0
- >=dev-ruby/tty-color-0.5:0
-"
-
-all_ruby_prepare() {
- echo '-rspec_helper' > .rspec || die
- sed -i -e 's:_relative ": "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
-}
diff --git a/dev-ruby/pastel/pastel-0.8.0.ebuild b/dev-ruby/pastel/pastel-0.8.0.ebuild
index 76a2edfab1dc..ef170d9a83f2 100644
--- a/dev-ruby/pastel/pastel-0.8.0.ebuild
+++ b/dev-ruby/pastel/pastel-0.8.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
diff --git a/dev-ruby/ttfunk/ttfunk-1.7.0.ebuild b/dev-ruby/ttfunk/ttfunk-1.7.0.ebuild
index 6b3e58eed0f2..cdd977a619a5 100644
--- a/dev-ruby/ttfunk/ttfunk-1.7.0.ebuild
+++ b/dev-ruby/ttfunk/ttfunk-1.7.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
diff --git a/dev-ruby/tty-color/tty-color-0.6.0.ebuild b/dev-ruby/tty-color/tty-color-0.6.0.ebuild
index 79503c8b0eb4..5beccea83d87 100644
--- a/dev-ruby/tty-color/tty-color-0.6.0.ebuild
+++ b/dev-ruby/tty-color/tty-color-0.6.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
diff --git a/dev-ruby/tty-command/tty-command-0.10.1-r1.ebuild b/dev-ruby/tty-command/tty-command-0.10.1-r1.ebuild
index 0b30996d4768..af35c67359f5 100644
--- a/dev-ruby/tty-command/tty-command-0.10.1-r1.ebuild
+++ b/dev-ruby/tty-command/tty-command-0.10.1-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby26 ruby27 ruby30"
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
diff --git a/dev-ruby/tty-command/tty-command-0.10.1.ebuild b/dev-ruby/tty-command/tty-command-0.10.1.ebuild
deleted file mode 100644
index 3b7a3370f289..000000000000
--- a/dev-ruby/tty-command/tty-command-0.10.1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Terminal color capabilities detection"
-HOMEPAGE="https://github.com/piotrmurach/tty-command"
-SRC_URI="https://github.com/piotrmurach/tty-command/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/pastel-0.8:0"
-
-all_ruby_prepare() {
- echo '-rspec_helper' > .rspec || die
-
- sed -i -e 's:_relative ": "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
-}
diff --git a/dev-ruby/tty-cursor/tty-cursor-0.7.1.ebuild b/dev-ruby/tty-cursor/tty-cursor-0.7.1.ebuild
index 1830b2b54402..df93cfe31699 100644
--- a/dev-ruby/tty-cursor/tty-cursor-0.7.1.ebuild
+++ b/dev-ruby/tty-cursor/tty-cursor-0.7.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
diff --git a/dev-ruby/tty-editor/tty-editor-0.7.0.ebuild b/dev-ruby/tty-editor/tty-editor-0.7.0.ebuild
index 97bce9d0768c..28d97ce920bc 100644
--- a/dev-ruby/tty-editor/tty-editor-0.7.0.ebuild
+++ b/dev-ruby/tty-editor/tty-editor-0.7.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-USE_RUBY="ruby26 ruby27 ruby30"
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
RUBY_FAKEGEM_BINWRAP=""
RUBY_FAKEGEM_EXTRADOC="README.md"
RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
diff --git a/dev-ruby/tty-prompt/tty-prompt-0.23.1.ebuild b/dev-ruby/tty-prompt/tty-prompt-0.23.1.ebuild
index c9ddb1410361..2c65ddd67c3f 100644
--- a/dev-ruby/tty-prompt/tty-prompt-0.23.1.ebuild
+++ b/dev-ruby/tty-prompt/tty-prompt-0.23.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
diff --git a/dev-ruby/tty-reader/tty-reader-0.9.0.ebuild b/dev-ruby/tty-reader/tty-reader-0.9.0.ebuild
index bca162eaa83b..a52955abdd41 100644
--- a/dev-ruby/tty-reader/tty-reader-0.9.0.ebuild
+++ b/dev-ruby/tty-reader/tty-reader-0.9.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
diff --git a/dev-ruby/tty-screen/Manifest b/dev-ruby/tty-screen/Manifest
index 1ec807c76489..a7e9122631be 100644
--- a/dev-ruby/tty-screen/Manifest
+++ b/dev-ruby/tty-screen/Manifest
@@ -1,2 +1 @@
-DIST tty-screen-0.7.1.tar.gz 11377 BLAKE2B 485b5610bc81524cfe525f8a837e99d13788da499dd8fa0f7c3be3f580ada63861f04652031e84817ef6ee49ce099c5fa97104b6634fc306d9ee0bbed0828ac3 SHA512 1ef5ce12cdd6337c47f09e5b6ae116985a80efe9f493d52c404496319f1377d4308cd829343d84f5c653b70327c033955232ca62fc8a134503a87a33a264130a
DIST tty-screen-0.8.1.tar.gz 13019 BLAKE2B 9c9ccb49ae323ebc67c5bca918303586fb749813539aed32a892f3135aa392f6c77b078bab2c7bd116d9f152ee2745d72aae38a91cf4292d1f360085d88060ba SHA512 b0a01c49bb0c56f23c8b384a2d4f4b5c7168863a35c3ab7160d0f34c7d63a2b10b3b9f0f54c6d56e2424a8b16e6ba74268ac81af631976876fb37eb9c347c393
diff --git a/dev-ruby/tty-screen/tty-screen-0.7.1.ebuild b/dev-ruby/tty-screen/tty-screen-0.7.1.ebuild
deleted file mode 100644
index d2da38e96cae..000000000000
--- a/dev-ruby/tty-screen/tty-screen-0.7.1.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-RUBY_FAKEGEM_GEMSPEC="tty-screen.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Terminal screen size detection which works on Linux, OS X and Windows/Cygwin"
-HOMEPAGE="https://github.com/piotrmurach/tty-screen"
-SRC_URI="https://github.com/piotrmurach/tty-screen/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-all_ruby_prepare() {
- echo '-rspec_helper' > .rspec || die
- sed -i -e 's:require_relative ":require "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
-}
diff --git a/dev-ruby/tty-screen/tty-screen-0.8.1.ebuild b/dev-ruby/tty-screen/tty-screen-0.8.1.ebuild
index 7b248316baa6..a0b3ffa5e9a0 100644
--- a/dev-ruby/tty-screen/tty-screen-0.8.1.ebuild
+++ b/dev-ruby/tty-screen/tty-screen-0.8.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
diff --git a/eclass/ruby-ng.eclass b/eclass/ruby-ng.eclass
index 72e714129715..70cb5be74b87 100644
--- a/eclass/ruby-ng.eclass
+++ b/eclass/ruby-ng.eclass
@@ -412,6 +412,7 @@ _ruby_invoke_environment() {
ebegin "Running ${_PHASE:-${EBUILD_PHASE}} phase for $environment"
"$@"
+ eend $?
popd &>/dev/null || die
S=${old_S}