summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-backup/duplicity/duplicity-0.8.13.ebuild1
-rw-r--r--net-libs/nodejs/nodejs-14.4.0.ebuild2
-rw-r--r--net-libs/nodejs/nodejs-99999999.ebuild2
-rw-r--r--profiles/prefix/package.use.mask6
-rw-r--r--sys-fs/snapraid/Manifest3
-rw-r--r--sys-fs/snapraid/snapraid-11.2.ebuild23
-rw-r--r--sys-fs/snapraid/snapraid-11.3.ebuild23
7 files changed, 9 insertions, 51 deletions
diff --git a/app-backup/duplicity/duplicity-0.8.13.ebuild b/app-backup/duplicity/duplicity-0.8.13.ebuild
index d63a2b170693..afc6288b43a1 100644
--- a/app-backup/duplicity/duplicity-0.8.13.ebuild
+++ b/app-backup/duplicity/duplicity-0.8.13.ebuild
@@ -22,6 +22,7 @@ CDEPEND="
"
DEPEND="${CDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
test? (
app-arch/par2cmdline
dev-python/mock[${PYTHON_USEDEP}]
diff --git a/net-libs/nodejs/nodejs-14.4.0.ebuild b/net-libs/nodejs/nodejs-14.4.0.ebuild
index 406b59067b2b..559e5a9d30f0 100644
--- a/net-libs/nodejs/nodejs-14.4.0.ebuild
+++ b/net-libs/nodejs/nodejs-14.4.0.ebuild
@@ -54,7 +54,7 @@ pkg_pretend() {
}
src_prepare() {
- tc-export CC CXX PKG_CONFIG
+ tc-export AR CC CXX PKG_CONFIG
export V=1
export BUILDTYPE=Release
diff --git a/net-libs/nodejs/nodejs-99999999.ebuild b/net-libs/nodejs/nodejs-99999999.ebuild
index c5eaa6e6aa77..e7b61f1ab582 100644
--- a/net-libs/nodejs/nodejs-99999999.ebuild
+++ b/net-libs/nodejs/nodejs-99999999.ebuild
@@ -51,7 +51,7 @@ pkg_pretend() {
}
src_prepare() {
- tc-export CC CXX PKG_CONFIG
+ tc-export AR CC CXX PKG_CONFIG
export V=1
export BUILDTYPE=Release
diff --git a/profiles/prefix/package.use.mask b/profiles/prefix/package.use.mask
index c101c1896932..71cdac1f6bc0 100644
--- a/profiles/prefix/package.use.mask
+++ b/profiles/prefix/package.use.mask
@@ -1,6 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Fabian Groffen <grobian@gentoo.org> (2020-06-07)
+# installing kernels has no business in Prefix
+sys-apps/debianutils installkernel
+
# Michael Haubenwallner <haubi@gentoo.org> (2019-05-02)
# gold is linux only, and is required by cxx
sys-devel/binutils cxx gold default-gold
diff --git a/sys-fs/snapraid/Manifest b/sys-fs/snapraid/Manifest
index 1776bad2d71a..e97438f71fa0 100644
--- a/sys-fs/snapraid/Manifest
+++ b/sys-fs/snapraid/Manifest
@@ -1,3 +1,2 @@
-DIST snapraid-11.2.tar.gz 735526 BLAKE2B d039c56c2fa4f0d2b333cb9eada2d59346e672c5196c0622c5536c5c3fe49b6df0ba742bcd467695fcbd46bb0ede06b1e54dc0c8088c275aeb4b1acd2f8e0f84 SHA512 975c0bb3e69e4feb2845c7d2971676beb59e3815070ee5fae09447925e74af5666dd51783fdadca096bd8bca43cfa19a88132d0999eb86a338915842a46a1834
-DIST snapraid-11.3.tar.gz 736549 BLAKE2B 67ad1e23630076b088167525e50f0ae2673201a9c02b25116d7d0ad9d2d8e34b17e240bd2fd90d39c6906842a6f321a2b76569d90c6ae24b40d1c6c335b8d6b4 SHA512 f0ed2bc1ab480b58220dac299ef95635747d5a8046bfcddf21b216d92d5cbfbf4299cb4130856a7fa5b808ba42662534b35a370193fe0a51791c994ed773a2ae
DIST snapraid-11.4.tar.gz 742589 BLAKE2B 21c0976b6fcf792653fb0d2f223cd9b728e8850505aa78914c37fa2e3b5399df33b38fcbe870a567b1beb87ba1e2a37d63afc32ae08fb487d7b24fcffe5da8a4 SHA512 d9d5d48f6f996f2c1fbec2f84219b007ac28828d54e6b8614d05ab87f717b3498333ec950e861060c1278993f4971af2435cf8f268c0f1fb403c279d00a96b92
+DIST snapraid-11.5.tar.gz 742480 BLAKE2B b0e66faccdacc0404b52f38061bc45b198cac5ce2fd2c465b8730a6e98f3e50569be70f5374f33a24cd2578b5c5e6f5db1070bbcd0e5ab269424ea52595aac9d SHA512 c0c8b6ebf6c1f057de618504d8f030158cbaf5135097f6c4fa320697eef9be447341e5c26fcab861c40c9995bcc4429dbb4d1fcdfd00090e6dfc7a1f6b501f7c
diff --git a/sys-fs/snapraid/snapraid-11.2.ebuild b/sys-fs/snapraid/snapraid-11.2.ebuild
deleted file mode 100644
index 35f69f087034..000000000000
--- a/sys-fs/snapraid/snapraid-11.2.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools
-
-DESCRIPTION="a backup program for disk array for home media centers"
-HOMEPAGE="http://snapraid.it/"
-SRC_URI="https://github.com/amadvance/${PN}/releases/download/v${PV}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DOCS=( "AUTHORS" "HISTORY" "README" "TODO" "snapraid.conf.example" )
-
-src_prepare() {
- default
- eautoreconf
-}
diff --git a/sys-fs/snapraid/snapraid-11.3.ebuild b/sys-fs/snapraid/snapraid-11.3.ebuild
deleted file mode 100644
index d9c8f45f3452..000000000000
--- a/sys-fs/snapraid/snapraid-11.3.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools
-
-DESCRIPTION="a backup program for disk array for home media centers"
-HOMEPAGE="http://snapraid.it/"
-SRC_URI="https://github.com/amadvance/${PN}/releases/download/v${PV}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DOCS=( "AUTHORS" "HISTORY" "README" "TODO" "snapraid.conf.example" )
-
-src_prepare() {
- default
- eautoreconf
-}