summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/nano/nano-5.3-r1.ebuild2
-rw-r--r--app-editors/nano/nano-5.5.ebuild2
-rw-r--r--app-editors/nano/nano-5.6.1.ebuild2
-rw-r--r--app-editors/nano/nano-5.6.ebuild2
-rw-r--r--app-editors/nano/nano-9999.ebuild2
-rw-r--r--app-text/groonga/groonga-8.0.2.ebuild2
-rw-r--r--dev-python/pytest-subtests/pytest-subtests-0.4.0.ebuild6
-rw-r--r--dev-util/quilt/quilt-9999.ebuild2
-rw-r--r--eclass/cmake-utils.eclass3
-rw-r--r--eclass/oasis.eclass2
-rw-r--r--eclass/readme.gentoo.eclass5
-rw-r--r--x11-misc/sisctrl/sisctrl-0.0.20051202-r1.ebuild2
-rw-r--r--x11-terms/xterm/Manifest1
-rw-r--r--x11-terms/xterm/xterm-367.ebuild99
14 files changed, 118 insertions, 14 deletions
diff --git a/app-editors/nano/nano-5.3-r1.ebuild b/app-editors/nano/nano-5.3-r1.ebuild
index 6f1437da2a77..d98c2483f54c 100644
--- a/app-editors/nano/nano-5.3-r1.ebuild
+++ b/app-editors/nano/nano-5.3-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
inherit flag-o-matic
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.sv.gnu.org/nano.git"
+ EGIT_REPO_URI="https://git.savannah.gnu.org/git/nano.git"
inherit git-r3 autotools
else
MY_P="${PN}-${PV/_}"
diff --git a/app-editors/nano/nano-5.5.ebuild b/app-editors/nano/nano-5.5.ebuild
index 64c74e70f9b1..aaa4c8829842 100644
--- a/app-editors/nano/nano-5.5.ebuild
+++ b/app-editors/nano/nano-5.5.ebuild
@@ -5,7 +5,7 @@ EAPI=7
inherit flag-o-matic
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.sv.gnu.org/nano.git"
+ EGIT_REPO_URI="https://git.savannah.gnu.org/git/nano.git"
inherit git-r3 autotools
else
MY_P="${PN}-${PV/_}"
diff --git a/app-editors/nano/nano-5.6.1.ebuild b/app-editors/nano/nano-5.6.1.ebuild
index 64c74e70f9b1..aaa4c8829842 100644
--- a/app-editors/nano/nano-5.6.1.ebuild
+++ b/app-editors/nano/nano-5.6.1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
inherit flag-o-matic
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.sv.gnu.org/nano.git"
+ EGIT_REPO_URI="https://git.savannah.gnu.org/git/nano.git"
inherit git-r3 autotools
else
MY_P="${PN}-${PV/_}"
diff --git a/app-editors/nano/nano-5.6.ebuild b/app-editors/nano/nano-5.6.ebuild
index 64c74e70f9b1..aaa4c8829842 100644
--- a/app-editors/nano/nano-5.6.ebuild
+++ b/app-editors/nano/nano-5.6.ebuild
@@ -5,7 +5,7 @@ EAPI=7
inherit flag-o-matic
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.sv.gnu.org/nano.git"
+ EGIT_REPO_URI="https://git.savannah.gnu.org/git/nano.git"
inherit git-r3 autotools
else
MY_P="${PN}-${PV/_}"
diff --git a/app-editors/nano/nano-9999.ebuild b/app-editors/nano/nano-9999.ebuild
index 64c74e70f9b1..aaa4c8829842 100644
--- a/app-editors/nano/nano-9999.ebuild
+++ b/app-editors/nano/nano-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=7
inherit flag-o-matic
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.sv.gnu.org/nano.git"
+ EGIT_REPO_URI="https://git.savannah.gnu.org/git/nano.git"
inherit git-r3 autotools
else
MY_P="${PN}-${PV/_}"
diff --git a/app-text/groonga/groonga-8.0.2.ebuild b/app-text/groonga/groonga-8.0.2.ebuild
index 19c48773526c..ba54ef3cbd01 100644
--- a/app-text/groonga/groonga-8.0.2.ebuild
+++ b/app-text/groonga/groonga-8.0.2.ebuild
@@ -78,7 +78,7 @@ src_configure() {
$(use_with lzo)
$(use_with mecab)
$(use_enable msgpack message-pack)
- $(use_with msgpack message-pack "${EPREFIX}/usr")
+ $(use_with msgpack message-pack "${ESYSROOT}/usr")
$(use_enable nfkc)
$(use_with sphinx sphinx-build)
$(use_enable static-libs static)
diff --git a/dev-python/pytest-subtests/pytest-subtests-0.4.0.ebuild b/dev-python/pytest-subtests/pytest-subtests-0.4.0.ebuild
index 9d5b3d569ee1..8d4f5768289a 100644
--- a/dev-python/pytest-subtests/pytest-subtests-0.4.0.ebuild
+++ b/dev-python/pytest-subtests/pytest-subtests-0.4.0.ebuild
@@ -19,7 +19,11 @@ SLOT="0"
KEYWORDS="~amd64 ~ia64 ~x86"
RDEPEND="
- >=dev-python/pytest-5.3.0[${PYTHON_USEDEP}]"
+ >=dev-python/pytest-5.3.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions
+ ' python3_7 pypy3)
+"
# pytest-xdist is used to test compatibility
BDEPEND="
dev-python/setuptools_scm[${PYTHON_USEDEP}]
diff --git a/dev-util/quilt/quilt-9999.ebuild b/dev-util/quilt/quilt-9999.ebuild
index 8fee81630b8f..df879d29d9c6 100644
--- a/dev-util/quilt/quilt-9999.ebuild
+++ b/dev-util/quilt/quilt-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-EGIT_REPO_URI="git://git.sv.gnu.org/quilt.git"
+EGIT_REPO_URI="https://git.savannah.gnu.org/git/quilt.git"
[[ ${PV} == 9999 ]] && inherit git-r3
diff --git a/eclass/cmake-utils.eclass b/eclass/cmake-utils.eclass
index 8127a66c2b52..59a3f9a026b9 100644
--- a/eclass/cmake-utils.eclass
+++ b/eclass/cmake-utils.eclass
@@ -1,7 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: cmake-utils.eclass
+# @DEPRECATED: cmake.eclass
# @MAINTAINER:
# kde@gentoo.org
# @AUTHOR:
diff --git a/eclass/oasis.eclass b/eclass/oasis.eclass
index a0b9a0a71153..83e68ae75335 100644
--- a/eclass/oasis.eclass
+++ b/eclass/oasis.eclass
@@ -9,7 +9,7 @@
# Original Author: Alexis Ballier <aballier@gentoo.org>
# @SUPPORTED_EAPIS: 3 4 5
# @BLURB: Provides common ebuild phases for oasis-based packages.
-# @DEPRECATED: Use opam.eclass, dune.eclass, or findlib.eclass (if necessary)
+# @DEPRECATED: opam.eclass, dune.eclass, or findlib.eclass (if necessary)
# @DESCRIPTION:
# Provides common ebuild phases for oasis-based packages.
# Most of these packages will just have to inherit the eclass, set their
diff --git a/eclass/readme.gentoo.eclass b/eclass/readme.gentoo.eclass
index fdb2d60f183f..2d8d7512ded2 100644
--- a/eclass/readme.gentoo.eclass
+++ b/eclass/readme.gentoo.eclass
@@ -1,7 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: readme.gentoo.eclass
+# @DEPRECATED: readme.gentoo-r1
# @MAINTAINER:
# Pacho Ramos <pacho@gentoo.org>
# @AUTHOR:
@@ -13,8 +14,6 @@
# shown via elog messages. With this eclass, those elog messages will only be
# shown at first package installation and a file for later reviewing will be
# installed under /usr/share/doc/${PF}
-#
-# This eclass is DEPRECATED. Please use readme.gentoo-r1 instead.
if [[ -z ${_README_GENTOO_ECLASS} ]]; then
_README_GENTOO_ECLASS=1
diff --git a/x11-misc/sisctrl/sisctrl-0.0.20051202-r1.ebuild b/x11-misc/sisctrl/sisctrl-0.0.20051202-r1.ebuild
index 072b2dfda9b1..931f27d46585 100644
--- a/x11-misc/sisctrl/sisctrl-0.0.20051202-r1.ebuild
+++ b/x11-misc/sisctrl/sisctrl-0.0.20051202-r1.ebuild
@@ -35,5 +35,5 @@ PATCHES=(
src_configure() {
append-libs -lm
econf \
- --with-xv-path="${EPREFIX}/usr/$(get_libdir)"
+ --with-xv-path="${ESYSROOT}/usr/$(get_libdir)"
}
diff --git a/x11-terms/xterm/Manifest b/x11-terms/xterm/Manifest
index 5a1302d346ba..164eb585017c 100644
--- a/x11-terms/xterm/Manifest
+++ b/x11-terms/xterm/Manifest
@@ -2,3 +2,4 @@ DIST xterm-351.tgz 1401009 BLAKE2B df32425affce33deb199710be118e90da7b1975882aaf
DIST xterm-363.tgz 1442520 BLAKE2B f63efde533f9d495c3d6b744544e592608d2731f04af58a9d799f8ca7d705c81c507d9012fc4a1bd04b3e4c0a76fc00557d1a61cd9954f5fb2bf7b5ec624764f SHA512 e9148f144e5e38597c84ccd82033f4fb83a9dd222c4cecf7498e31065e7d0148c89631290e5f804fcd9d2d55f59f4fd271aaf220eb636fbe38ae245ea6537871
DIST xterm-365.tgz 1444367 BLAKE2B efb4ce024b7a196955c160e10aadc54d97da1df6e53b9ca79184382a1db939583e52f66ed4df1f586a33b9febda6ac51dc66a9f2cd69bb04296c934aae7e7571 SHA512 3f6571d09cd3fa94e9133494a2893e804ea0f0c76289d4a7e46e3ea267278042f0e78231ff4b06ee6d7ba5936dc3e2e6c81a8f52c36d79a8ddf3cfaa59376970
DIST xterm-366.tgz 1445992 BLAKE2B 4724851b84ae0682b39e5f1b070ba9f04c627511aa20a5b1c76e740666e14436a0095d8a1be4f6ad54eb1e5d841ef766b0bf4d840ebddcaea0889285f1377900 SHA512 ffab7e0970b92a25488bd57da2dfe2856279208c489a632e0e92788deec2a4f99510f76e1c88e55f389dfe984c323add0fab31b04d2a1d774ce6d3b2c9c642ef
+DIST xterm-367.tgz 1448562 BLAKE2B 29b38ba3b48c843ecbf22d209a05afb4e9a6d52cf8f14efa18ed5dd02b26cc11c107bfb17260cb62f68fc318cb08e5147b5f12e8779ca63151c7b712ada60b7e SHA512 86fd6ed4e4aa0201349edd67d8bf00d3b93a19640307372011f9bdcd26fdb453267d1ab092a0639902e419b00c175d793b196884b6e65e546650e1b83a4461c4
diff --git a/x11-terms/xterm/xterm-367.ebuild b/x11-terms/xterm/xterm-367.ebuild
new file mode 100644
index 000000000000..0102172747d3
--- /dev/null
+++ b/x11-terms/xterm/xterm-367.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop flag-o-matic
+
+DESCRIPTION="Terminal Emulator for X Windows"
+HOMEPAGE="https://invisible-island.net/xterm/"
+SRC_URI="ftp://ftp.invisible-island.net/${PN}/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+openpty sixel toolbar truetype unicode Xaw3d xinerama"
+
+BDEPEND="virtual/pkgconfig
+ x11-base/xorg-proto"
+DEPEND="kernel_linux? ( sys-libs/libutempter )
+ kernel_FreeBSD? ( sys-libs/libutempter )
+ media-libs/fontconfig:1.0
+ >=sys-libs/ncurses-5.7-r7:0=
+ x11-apps/xmessage
+ x11-libs/libICE
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXft
+ x11-libs/libxkbfile
+ x11-libs/libXmu
+ x11-libs/libXrender
+ x11-libs/libXt
+ unicode? ( x11-apps/luit )
+ Xaw3d? ( x11-libs/libXaw3d )
+ xinerama? ( x11-libs/libXinerama )"
+RDEPEND="${DEPEND}
+ media-fonts/font-misc-misc
+ x11-apps/rgb"
+
+DOCS=( README{,.i18n} ctlseqs.txt )
+
+pkg_setup() {
+ DEFAULTS_DIR="${EPREFIX}"/usr/share/X11/app-defaults
+}
+
+src_configure() {
+ # 454736
+ # Workaround for ncurses[tinfo] until upstream fixes their buildsystem using
+ # something sane like pkg-config or ncurses5-config and stops guessing libs
+ # Everything gets linked against ncurses anyways, so don't shout
+ append-libs $(pkg-config --libs ncurses)
+
+ local myeconfargs=(
+ --disable-full-tgetent
+ --disable-imake
+ --disable-setgid
+ --disable-setuid
+ --enable-256-color
+ --enable-broken-osc
+ --enable-broken-st
+ --enable-dabbrev
+ --enable-exec-xterm
+ --enable-i18n
+ --enable-load-vt-fonts
+ --enable-logging
+ --enable-screen-dumps
+ --enable-warnings
+ --enable-wide-chars
+ --libdir="${EPREFIX}"/etc
+ --with-app-defaults="${DEFAULTS_DIR}"
+ --with-utempter
+ --with-x
+ $(use_enable openpty)
+ $(use_enable sixel sixel-graphics)
+ $(use_enable toolbar)
+ $(use_enable truetype freetype)
+ $(use_enable unicode luit)
+ $(use_enable unicode mini-luit)
+ $(use_with Xaw3d)
+ $(use_with xinerama)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ docinto html
+ dodoc xterm.log.html
+ domenu *.desktop
+
+ # Fix permissions -- it grabs them from live system, and they can
+ # be suid or sgid like they were in pre-unix98 pty or pre-utempter days,
+ # respectively (#69510).
+ # (info from Thomas Dickey) - Donnie Berkholz <spyderous@gentoo.org>
+ fperms 0755 /usr/bin/xterm
+
+ # restore the navy blue
+ sed -i -e 's:blue2$:blue:' "${ED}${DEFAULTS_DIR}"/XTerm-color || die
+}