summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/telegram-desktop/files/tdesktop-2.7.4-fix-disable-dbus-integration.patch21
-rw-r--r--net-im/telegram-desktop/telegram-desktop-2.7.4-r1.ebuild3
2 files changed, 23 insertions, 1 deletions
diff --git a/net-im/telegram-desktop/files/tdesktop-2.7.4-fix-disable-dbus-integration.patch b/net-im/telegram-desktop/files/tdesktop-2.7.4-fix-disable-dbus-integration.patch
new file mode 100644
index 000000000000..941a4ecc09cb
--- /dev/null
+++ b/net-im/telegram-desktop/files/tdesktop-2.7.4-fix-disable-dbus-integration.patch
@@ -0,0 +1,21 @@
+--- tdesktop-2.7.4-full.orig/Telegram/SourceFiles/platform/linux/notifications_manager_linux_dummy.cpp
++++ tdesktop-2.7.4-full/Telegram/SourceFiles/platform/linux/notifications_manager_linux_dummy.cpp
+@@ -13,15 +13,15 @@
+ namespace Platform {
+ namespace Notifications {
+
+-bool SkipAudio() {
++bool SkipAudioForCustom() {
+ return false;
+ }
+
+-bool SkipToast() {
++bool SkipToastForCustom() {
+ return false;
+ }
+
+-bool SkipFlashBounce() {
++bool SkipFlashBounceForCustom() {
+ return false;
+ }
+
diff --git a/net-im/telegram-desktop/telegram-desktop-2.7.4-r1.ebuild b/net-im/telegram-desktop/telegram-desktop-2.7.4-r1.ebuild
index 095e7419b7c7..bf094b208475 100644
--- a/net-im/telegram-desktop/telegram-desktop-2.7.4-r1.ebuild
+++ b/net-im/telegram-desktop/telegram-desktop-2.7.4-r1.ebuild
@@ -73,10 +73,11 @@ PATCHES=(
"${FILESDIR}/tdesktop-2.7.3-webview-include-gdkx.patch"
# https://github.com/desktop-app/lib_webview/pull/3
"${FILESDIR}/tdesktop-2.7.4-webview-fix-gcc11.patch"
-
# https://github.com/telegramdesktop/tdesktop/issues/16217
"${FILESDIR}/tdesktop-2.7.4-voice-crash.patch"
"${FILESDIR}/tdesktop-2.7.4-voice-ffmpeg44.patch"
+ # https://github.com/telegramdesktop/tdesktop/commit/404538c98968d44d207671de3adde91b8df50721
+ "${FILESDIR}/tdesktop-2.7.4-fix-disable-dbus-integration.patch"
)
pkg_pretend() {