summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/ntpsec/Manifest1
-rw-r--r--net-misc/ntpsec/files/ntpsec-1.2.0-seccomp.patch19
-rw-r--r--net-misc/ntpsec/ntpsec-1.1.9.ebuild160
-rw-r--r--net-misc/ntpsec/ntpsec-1.2.0-r2.ebuild (renamed from net-misc/ntpsec/ntpsec-1.2.0-r1.ebuild)5
-rw-r--r--net-misc/ntpsec/ntpsec-9999.ebuild2
-rw-r--r--profiles/package.mask6
-rw-r--r--sys-fs/static-dev/static-dev-0.1-r2.ebuild (renamed from sys-fs/static-dev/static-dev-0.1-r1.ebuild)2
7 files changed, 30 insertions, 165 deletions
diff --git a/net-misc/ntpsec/Manifest b/net-misc/ntpsec/Manifest
index 7de62087eed7..4f7af2898d26 100644
--- a/net-misc/ntpsec/Manifest
+++ b/net-misc/ntpsec/Manifest
@@ -1,2 +1 @@
-DIST ntpsec-1.1.9.tar.gz 2606066 BLAKE2B bbc482333c7f86936fa20751df1b427bc24be159969050caf5751e26724714bbf6491b120986563497f015c96ac9cdbdf0e999c6446a68798aff23076f631ecc SHA512 e04267aa675a5b528f3478d00329a569ecb9bbe2b6ad18697020854d2ee451bc188c4603cd5f420a08a7e3bf047d2db1301416f57f9156df23aceb1f57303b0b
DIST ntpsec-1.2.0.tar.gz 2625968 BLAKE2B 23ceae5a1f241fcf5a17801fec2f15f9b9d9d64a108bebe29bdc75196303091eaf0efee7df67ce10acefb7c8dba90ce1144a0c0c5432797d7659714d162f26bb SHA512 9e18b3ca2f786a1ea323ba2384b51cff3d862115cea1ae576fc98172c476ac5e7d0d0fc873e47be0b19b050204ea9ed49669d94e66eb94525068dd1b08a8ae71
diff --git a/net-misc/ntpsec/files/ntpsec-1.2.0-seccomp.patch b/net-misc/ntpsec/files/ntpsec-1.2.0-seccomp.patch
new file mode 100644
index 000000000000..e4dc47f19cc6
--- /dev/null
+++ b/net-misc/ntpsec/files/ntpsec-1.2.0-seccomp.patch
@@ -0,0 +1,19 @@
+https://bugs.gentoo.org/705128
+--- a/ntpd/ntp_sandbox.c
++++ b/ntpd/ntp_sandbox.c
+@@ -463,6 +463,15 @@ int scmp_sc[] = {
+ SCMP_SYS(send),
+ SCMP_SYS(stat64),
+ #endif
++#if defined(__arm__)
++ SCMP_SYS(statx),
++#endif
++#if defined(__riscv32__)
++ SCMP_SYS(faccessat),
++#endif
++#if defined(__aarch64__)
++ SCMP_SYS(syscall);
++#endif
+ };
+ {
+ for (unsigned int i = 0; i < COUNTOF(scmp_sc); i++) {
diff --git a/net-misc/ntpsec/ntpsec-1.1.9.ebuild b/net-misc/ntpsec/ntpsec-1.1.9.ebuild
deleted file mode 100644
index f92de0e4f1d9..000000000000
--- a/net-misc/ntpsec/ntpsec-1.1.9.ebuild
+++ /dev/null
@@ -1,160 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-PYTHON_REQ_USE='threads(+)'
-
-inherit flag-o-matic python-r1 waf-utils systemd
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://gitlab.com/NTPsec/ntpsec.git"
-else
- SRC_URI="ftp://ftp.ntpsec.org/pub/releases/${PN}-${PV}.tar.gz"
- RESTRICT="mirror"
- KEYWORDS="amd64 arm arm64 ~x86"
-fi
-
-DESCRIPTION="The NTP reference implementation, refactored"
-HOMEPAGE="https://www.ntpsec.org/"
-
-NTPSEC_REFCLOCK=(
- oncore trimble truetime gpsd jjy generic spectracom
- shm pps hpgps zyfer arbiter nmea neoclock modem
- local)
-
-IUSE_NTPSEC_REFCLOCK=${NTPSEC_REFCLOCK[@]/#/rclock_}
-
-LICENSE="HPND MIT BSD-2 BSD CC-BY-SA-4.0"
-SLOT="0"
-IUSE="${IUSE_NTPSEC_REFCLOCK} debug doc early gdb heat libbsd nist ntpviz samba seccomp smear tests" #ionice
-REQUIRED_USE="${PYTHON_REQUIRED_USE} nist? ( rclock_local )"
-
-# net-misc/pps-tools oncore,pps
-CDEPEND="${PYTHON_DEPS}
- sys-libs/libcap
- dev-python/psutil[${PYTHON_USEDEP}]
- libbsd? ( dev-libs/libbsd:0= )
- dev-libs/openssl:0=
- seccomp? ( sys-libs/libseccomp )
-"
-RDEPEND="${CDEPEND}
- ntpviz? ( sci-visualization/gnuplot media-fonts/liberation-fonts )
- !net-misc/ntp
- !net-misc/openntpd
- acct-group/ntp
- acct-user/ntp
-"
-DEPEND="${CDEPEND}
- >=app-text/asciidoc-8.6.8
- dev-libs/libxslt
- app-text/docbook-xsl-stylesheets
- sys-devel/bison
- rclock_oncore? ( net-misc/pps-tools )
- rclock_pps? ( net-misc/pps-tools )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.1.8-fix-missing-scmp_sys-on-aarch64.patch"
- "${FILESDIR}/${P}-remove-asciidoctor-from-config.patch"
-)
-
-WAF_BINARY="${S}/waf"
-
-src_prepare() {
- default
- # Remove autostripping of binaries
- sed -i -e '/Strip binaries/d' wscript || die
- if ! use libbsd ; then
- eapply "${FILESDIR}/${PN}-no-bsd.patch"
- fi
- python_copy_sources
-}
-
-src_configure() {
- is-flagq -flto* && filter-flags -flto* -fuse-linker-plugin
-
- local string_127=""
- local rclocks="";
- local CLOCKSTRING=""
-
- for refclock in ${NTPSEC_REFCLOCK[@]} ; do
- if use rclock_${refclock} ; then
- string_127+="$refclock,"
- fi
- done
- CLOCKSTRING="`echo ${string_127}|sed 's|,$||'`"
-
- local myconf=(
- --nopyc
- --nopyo
- --refclock="${CLOCKSTRING}"
- --build-epoch="$(date +%s)"
- $(use doc || echo "--disable-doc")
- $(use early && echo "--enable-early-droproot")
- $(use gdb && echo "--enable-debug-gdb")
- $(use samba && echo "--enable-mssntp")
- $(use seccomp && echo "--enable-seccomp")
- $(use smear && echo "--enable-leap-smear")
- $(use tests && echo "--alltests")
- $(use debug && echo "--enable-debug")
- )
-
- python_configure() {
- waf-utils_src_configure "${myconf[@]}"
- }
- python_foreach_impl run_in_build_dir python_configure
-}
-
-src_compile() {
- unset MAKEOPTS
- python_compile() {
- waf-utils_src_compile
- }
- python_foreach_impl run_in_build_dir python_compile
-}
-
-src_install() {
- python_install() {
- waf-utils_src_install
- }
- python_foreach_impl run_in_build_dir python_install
- python_foreach_impl python_optimize
-
- # Install heat generating scripts
- use heat && dosbin "${S}"/contrib/ntpheat{,usb}
-
- # Install the openrc files
- newinitd "${FILESDIR}"/ntpd.rc-r2 ntp
- newconfd "${FILESDIR}"/ntpd.confd ntp
-
- # Install the systemd unit file
- systemd_newunit "${FILESDIR}"/ntpd-r1.service ntpd.service
-
- # Prepare a directory for the ntp.drift file
- mkdir -pv "${ED}"/var/lib/ntp
- chown ntp:ntp "${ED}"/var/lib/ntp
- chmod 770 "${ED}"/var/lib/ntp
- keepdir /var/lib/ntp
-
- # Install a log rotate script
- mkdir -pv "${ED}"/etc/logrotate.d
- cp -v "${S}"/etc/logrotate-config.ntpd "${ED}"/etc/logrotate.d/ntpd
-
- # Install the configuration file and sample configuration
- cp -v "${FILESDIR}"/ntp.conf "${ED}"/etc/ntp.conf
- cp -Rv "${S}"/etc/ntp.d/ "${ED}"/etc/
-
- # move doc files to /usr/share/doc/"${P}"
- use doc && mv -v "${ED}"/usr/share/doc/"${PN}" "${ED}"/usr/share/doc/"${P}"/html
-}
-
-pkg_postinst() {
- einfo "If you want to serve time on your local network, then"
- einfo "you should disable all the ref_clocks unless you have"
- einfo "one and can get stable time from it. Feel free to try"
- einfo "it but PPS probably won't work unless you have a UART"
- einfo "GPS that actually provides PPS messages."
-}
diff --git a/net-misc/ntpsec/ntpsec-1.2.0-r1.ebuild b/net-misc/ntpsec/ntpsec-1.2.0-r2.ebuild
index b303b583ef90..4a5784ca79ed 100644
--- a/net-misc/ntpsec/ntpsec-1.2.0-r1.ebuild
+++ b/net-misc/ntpsec/ntpsec-1.2.0-r2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_COMPAT=( python3_{7..9} )
PYTHON_REQ_USE='threads(+)'
DISTUTILS_USE_SETUPTOOLS=no
@@ -61,6 +61,7 @@ PATCHES=(
"${FILESDIR}/${PN}-1.1.8-fix-missing-scmp_sys-on-aarch64.patch"
"${FILESDIR}/${PN}-1.1.9-remove-asciidoctor-from-config.patch"
"${FILESDIR}/${PN}-1.2.0-move-newfstatat.patch"
+ "${FILESDIR}/${PN}-1.2.0-seccomp.patch"
)
WAF_BINARY="${S}/waf"
diff --git a/net-misc/ntpsec/ntpsec-9999.ebuild b/net-misc/ntpsec/ntpsec-9999.ebuild
index 7833fafd9711..4d520e72c5a9 100644
--- a/net-misc/ntpsec/ntpsec-9999.ebuild
+++ b/net-misc/ntpsec/ntpsec-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python3_{7,8,9} )
PYTHON_REQ_USE='threads(+)'
diff --git a/profiles/package.mask b/profiles/package.mask
index 0c719528dd1a..6daf1156c2e1 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -32,6 +32,12 @@
#--- END OF EXAMPLES ---
+# Sam James <sam@gentoo.org> (2021-06-10)
+# Fails to build with modern libetpan. Unmaintained.
+# See bug #699570, bug #448574.
+# Removal on 2021-07-10.
+mail-client/etpan-ng
+
# Michał Górny <mgorny@gentoo.org> (2021-06-05)
# A backport for 'older Python versions' with no revdeps.
# Removal on 2021-07-05. Bug #794268.
diff --git a/sys-fs/static-dev/static-dev-0.1-r1.ebuild b/sys-fs/static-dev/static-dev-0.1-r2.ebuild
index 42c60e497de4..ca46b76ab1e5 100644
--- a/sys-fs/static-dev/static-dev-0.1-r1.ebuild
+++ b/sys-fs/static-dev/static-dev-0.1-r2.ebuild
@@ -30,7 +30,7 @@ pkg_pretend() {
fi
# We also want to not clobber newer devtmpfs setups.
- if [[ ${ROOT} == "/" ]] && \
+ if [[ -z ${ROOT} ]] && \
! awk '$2 == "/dev" && $3 == "devtmpfs" { exit 1 }' /proc/mounts ; then
abort
fi