summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/gupnp-igd/Manifest1
-rw-r--r--net-libs/gupnp-igd/gupnp-igd-0.2.5.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/net-libs/gupnp-igd/Manifest b/net-libs/gupnp-igd/Manifest
index 7e7941bd5dda..6c46ed393ca9 100644
--- a/net-libs/gupnp-igd/Manifest
+++ b/net-libs/gupnp-igd/Manifest
@@ -1,3 +1,4 @@
DIST gupnp-igd-0.2.2.tar.xz 262216 BLAKE2B a2c1980569b75643b4fc0ce3c28af0e949176572a8368179ad1152b3b9e5a0a879e067c48b37d423855c94f2cf993e8aea8b901b0684c33d31d78e64e3d26d24 SHA512 5e876b5e759f483b270d85f2125ede5db304b3664f22a6b4e68943ba5dbc6fe597e59ef44f23e284d15ee00809c28fc6194b44faa345cc6aec62927958a53583
DIST gupnp-igd-0.2.3.tar.xz 269920 BLAKE2B e3fd67b04f91348c1fbf236f6a9dc03e10575bacbed6ebc99a1be2817983844c2390b2f057c6464ed74e4f140c4cc2fb6bc941296b2db945a90647b77304b14c SHA512 74b4a6e34fe89b7fa92125664bb09354601fe0b476b909fc6c233027ec58914619c88e5bd951a675d7ccfc33d01b0fdddb21eb915d38c7ff824364dc62c319ac
DIST gupnp-igd-0.2.4.tar.xz 272004 BLAKE2B d195187faab17fcb5510afec0d024071936c5d61ac9ce4b4fd266cbc1ac238876935b588d91d7e55d3280ded4a0b39560a3b3bdbfec9cbccc3ab883ab1f75e1c SHA512 4da8d401935c4237661310aec0acb38e9c9fe54aeb6b2ef1c9533a8576dbd2d9f9db3b50c4e86b7efc81c80059a10ea52f73517dab23f3cdc0f91a5c0944dab8
+DIST gupnp-igd-0.2.5.tar.xz 287964 BLAKE2B 2267b991a0137006f122b3454bfb1bd9df0fd7fae2c47b50a394a2859f6e04375b55447830f6606c8a25260b9cafb75329cbdcd201c220a66fe881dce368abfe SHA512 3d2af29d10c2939a81c8745a50d9cc20be53f97a2112cec6e45bf05373d807d86404b61c776fea34b15ac341f9b7bfff2f3c48901dd241e64e18b5bc7e614cc8
diff --git a/net-libs/gupnp-igd/gupnp-igd-0.2.5.ebuild b/net-libs/gupnp-igd/gupnp-igd-0.2.5.ebuild
new file mode 100644
index 000000000000..71474607dad1
--- /dev/null
+++ b/net-libs/gupnp-igd/gupnp-igd-0.2.5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit ltprune gnome.org multilib-minimal xdg-utils
+
+DESCRIPTION="Library to handle UPnP IGD port mapping for GUPnP"
+HOMEPAGE="http://gupnp.org"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ >=net-libs/gssdp-0.14.7[${MULTILIB_USEDEP}]
+ >=net-libs/gupnp-0.20.10[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-0.10 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.10
+ sys-devel/gettext
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+"
+
+# The only existing test is broken
+RESTRICT="test"
+
+multilib_src_configure() {
+ xdg_environment_reset
+
+ # python is old-style bindings; use introspection and pygobject instead
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-static \
+ --disable-gtk-doc \
+ --disable-python \
+ $(multilib_native_use_enable introspection)
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/doc/html doc/html || die
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files
+}