summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--eclass/qmail.eclass20
1 files changed, 19 insertions, 1 deletions
diff --git a/eclass/qmail.eclass b/eclass/qmail.eclass
index 12f7fa8375b0..67069087376d 100644
--- a/eclass/qmail.eclass
+++ b/eclass/qmail.eclass
@@ -156,8 +156,11 @@ qmail_base_install() {
[[ -x ${i} ]] && doexe ${i}
done
+ use pop3 && doexe qmail-pop3d
+
exeopts -o 0 -g qmail -m 711
doexe qmail-{clean,getpw,local,pw2u,remote,rspawn,send} splogger
+ use pop3 && doexe qmail-popup
exeopts -o 0 -g qmail -m 700
doexe qmail-{lspawn,newmrh,newu,start}
@@ -237,7 +240,7 @@ qmail_tcprules_install() {
insinto "${TCPRULES_DIR}"
doins "${GENQMAIL_S}"/tcprules/Makefile.qmail
doins "${GENQMAIL_S}"/tcprules/tcp.qmail-*
- rm -f "${D}${TCPRULES_DIR}"/tcp.qmail-pop3sd
+ use ssl && use pop3 || rm -f "${D}${TCPRULES_DIR}"/tcp.qmail-pop3sd
}
qmail_supervise_install_one() {
@@ -257,6 +260,11 @@ qmail_supervise_install() {
for i in qmail-{send,smtpd,qmtpd,qmqpd}; do
qmail_supervise_install_one ${i}
done
+
+ if use pop3; then
+ qmail_supervise_install_one qmail-pop3d
+ use ssl && qmail_supervise_install_one qmail-pop3sd
+ fi
}
qmail_spp_install() {
@@ -359,6 +367,16 @@ qmail_supervise_config_notice() {
elog "ln -s ${SUPERVISE_DIR}/qmail-send /service/qmail-send"
elog "ln -s ${SUPERVISE_DIR}/qmail-smtpd /service/qmail-smtpd"
elog
+ if use pop3; then
+ elog "To start the pop3 server as well, create the following link:"
+ elog "ln -s ${SUPERVISE_DIR}/qmail-pop3d /service/qmail-pop3d"
+ elog
+ if use ssl; then
+ elog "To start the pop3s server as well, create the following link:"
+ elog "ln -s ${SUPERVISE_DIR}/qmail-pop3sd /service/qmail-pop3sd"
+ elog
+ fi
+ fi
elog "Additionally, the QMTP and QMQP protocols are supported, "
elog "and can be started as:"
elog "ln -s ${SUPERVISE_DIR}/qmail-qmtpd /service/qmail-qmtpd"