summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/exo')
-rw-r--r--app-admin/exo/Manifest1
-rw-r--r--app-admin/exo/exo-1.22.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-admin/exo/Manifest b/app-admin/exo/Manifest
index e4cb272dd5f2..b29613183883 100644
--- a/app-admin/exo/Manifest
+++ b/app-admin/exo/Manifest
@@ -1 +1,2 @@
DIST exo-1.21.0.tar.gz 4625218 BLAKE2B f73c18f1de5a8e8063e66ec11352d9221268289d298bb6ecaa9cb625c00685b68d0f7760614df8cf783bb123bbdb52d3fd9d8c482933445bb089d6e9d493882c SHA512 0a2279ef368e13286082813ebbae38cd5c2e185e43e5d2b2fb851382be8b8a5c08512124638d987401d0e821042bafba50f955a672eec6ce0951f0149d2ec34a
+DIST exo-1.22.0.tar.gz 4684873 BLAKE2B a143517a99fde17c237c25dcdd4b54570d6ce9760157d24c8f09c26851b5fb65c6ac56506179a008f32cc657cf40fb781eb304375e3f3422a5166e6b1c194164 SHA512 f68d1524c8a1dc44aca4ab1999ebbc93a980a58344c1b39c68eb54b4651d9471b310541c2d34a43e67ad956ed93e2d3ce89c3ebeb450b620c641907684572799
diff --git a/app-admin/exo/exo-1.22.0.ebuild b/app-admin/exo/exo-1.22.0.ebuild
new file mode 100644
index 000000000000..0c2c8d861fe4
--- /dev/null
+++ b/app-admin/exo/exo-1.22.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Command-line tool for everything at Exoscale: compute, storage, dns."
+HOMEPAGE="https://github.com/exoscale/cli"
+SRC_URI="https://github.com/exoscale/cli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+DEPEND="dev-lang/go:="
+RESTRICT="strip"
+QA_FLAGS_IGNORED=".*"
+
+S="${WORKDIR}/cli-${PV}"
+
+src_compile() {
+ go build -mod vendor -o ${PN} || die "build failed"
+}
+
+src_test() {
+ # run at least 'exo version' for test
+ ./exo version > /dev/null 2>&1
+ if [[ $? -ne 0 ]]
+ then
+ die "Test failed"
+ fi
+}
+
+src_install() {
+ dobin ${PN}
+}