summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/flasm')
-rw-r--r--app-misc/flasm/Manifest1
-rw-r--r--app-misc/flasm/files/flasm-1.63-makefile.patch27
-rw-r--r--app-misc/flasm/flasm-1.63.ebuild42
-rw-r--r--app-misc/flasm/metadata.xml14
4 files changed, 84 insertions, 0 deletions
diff --git a/app-misc/flasm/Manifest b/app-misc/flasm/Manifest
new file mode 100644
index 000000000000..72e3b8568337
--- /dev/null
+++ b/app-misc/flasm/Manifest
@@ -0,0 +1 @@
+DIST flasm-1.63.zip 111912 SHA256 df1273a506e2479cf95775197f5b7fa94e29fe1e0aae5aa190ed5bbebc4be5c6 SHA512 af53c8902bac9bc03a4274f51280abe7e595f19d8ee367c0237868634df58a42144bb6c335a99f860c494da90d483072c66064897ef1ad467b7621c648ca322a WHIRLPOOL e69860fdfa5be54235c0a02f2b77e30e4a2735b6785aa45260a2bdb55ff8a2edd366c1c9dadc93c7ac76886bd0070c4b6220a38365b6ba3135a1ade19a7ef103
diff --git a/app-misc/flasm/files/flasm-1.63-makefile.patch b/app-misc/flasm/files/flasm-1.63-makefile.patch
new file mode 100644
index 000000000000..32ea2bc00181
--- /dev/null
+++ b/app-misc/flasm/files/flasm-1.63-makefile.patch
@@ -0,0 +1,27 @@
+--- Makefile.o 2010-08-31 01:17:46.505000089 +0200
++++ Makefile 2010-08-31 01:19:11.841000098 +0200
+@@ -1,6 +1,4 @@
+ UNAME = $(shell uname)
+-CC = gcc
+-CFLAGS = -g -Wall -O2
+ LIBS = -lz
+ OFILES = util.o keywords.o flasm.o unflasm.o lex.yy.o assembler.tab.o
+ GARBAGE = assembler.tab.* lex.yy.c memwatch.o gmon.out memwatch.log core
+@@ -9,8 +7,6 @@
+ ifneq (,$(findstring debug,$(MAKECMDGOALS)))
+ CFLAGS += -DMEMWATCH -pg -p -pedantic -W -Wcast-align -Wcast-qual -Wshadow -Wnested-externs -Wstrict-prototypes -Waggregate-return -Wmissing-prototypes -Wpointer-arith
+ OFILES += memwatch.o
+-else
+- CFLAGS += -s
+ endif
+
+ # executable should not depend on cygwin.dll
+@@ -26,7 +22,7 @@
+ -rm -f ${OFILES} ${GARBAGE}
+
+ flasm: ${OFILES}
+- ${CC} $(CFLAGS) -o flasm ${OFILES} ${LIBS}
++ ${CC} $(CFLAGS) $(LDFLAGS) -o flasm ${OFILES} ${LIBS}
+
+ assembler.tab.c assembler.tab.h: assembler.y
+ bison --defines --debug assembler.y
diff --git a/app-misc/flasm/flasm-1.63.ebuild b/app-misc/flasm/flasm-1.63.ebuild
new file mode 100644
index 000000000000..19e76dbd133e
--- /dev/null
+++ b/app-misc/flasm/flasm-1.63.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils versionator toolchain-funcs
+
+MY_PV=$(delete_all_version_separators $(get_version_component_range 1-2))
+DESCRIPTION="Command line assembler/disassembler of Flash ActionScript bytecode"
+HOMEPAGE="http://www.nowrap.de/flasm.html"
+SRC_URI="http://www.nowrap.de/download/flasm${MY_PV}src.zip -> ${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-util/gperf
+ sys-devel/flex
+ virtual/yacc
+"
+
+S=${WORKDIR}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake
+}
+
+src_install() {
+ dobin flasm
+ dodoc CHANGES.TXT
+ dohtml flasm.html classic.css
+}
diff --git a/app-misc/flasm/metadata.xml b/app-misc/flasm/metadata.xml
new file mode 100644
index 000000000000..8362375232ee
--- /dev/null
+++ b/app-misc/flasm/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>Flasm disassembles your entire SWF including all the
+ timelines and events. Looking at disassembly, you learn how the Flash
+ compiler works, which improves your ActionScript skills. You can also do
+ some optimizations on the disassembled code by hand or adjust the code as
+ you wish. Flasm then applies your changes to the original SWF, replacing
+ original actions.
+ </longdescription>
+</pkgmetadata>