summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/bash')
-rw-r--r--app-shells/bash/bash-5.0_p11-r1.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/app-shells/bash/bash-5.0_p11-r1.ebuild b/app-shells/bash/bash-5.0_p11-r1.ebuild
index 166972b40ad5..6420a7a4602b 100644
--- a/app-shells/bash/bash-5.0_p11-r1.ebuild
+++ b/app-shells/bash/bash-5.0_p11-r1.ebuild
@@ -252,7 +252,7 @@ pkg_preinst() {
# rewrite the symlink to ensure that its mtime changes. having /bin/sh
# missing even temporarily causes a fatal error with paludis.
local target=$(readlink "${EROOT}"/bin/sh)
- local tmp=$(emktemp "${EROOT}"/bin)
+ local tmp="${T}"/sh
ln -sf "${target}" "${tmp}"
mv -f "${tmp}" "${EROOT}"/bin/sh
fi