summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/libmspub')
-rw-r--r--app-text/libmspub/libmspub-0.1.4.ebuild6
-rw-r--r--app-text/libmspub/libmspub-9999.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/app-text/libmspub/libmspub-0.1.4.ebuild b/app-text/libmspub/libmspub-0.1.4.ebuild
index 20eba626a22a..ce65701b3002 100644
--- a/app-text/libmspub/libmspub-0.1.4.ebuild
+++ b/app-text/libmspub/libmspub-0.1.4.ebuild
@@ -3,11 +3,11 @@
EAPI=7
-inherit flag-o-matic
+inherit autotools flag-o-matic
if [[ ${PV} = *9999 ]]; then
EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libmspub.git"
- inherit autotools git-r3
+ inherit git-r3
else
SRC_URI="https://dev-www.libreoffice.org/src/libmspub/${P}.tar.xz"
KEYWORDS="amd64 ~arm arm64 ~hppa ppc ppc64 ~sparc x86"
@@ -38,7 +38,7 @@ PATCHES=( "${FILESDIR}/${P}-gcc10.patch" )
src_prepare() {
default
[[ -d m4 ]] || mkdir "m4"
- [[ ${PV} == *9999 ]] && eautoreconf
+ eautoreconf
}
src_configure() {
diff --git a/app-text/libmspub/libmspub-9999.ebuild b/app-text/libmspub/libmspub-9999.ebuild
index 2035408ee17b..1ae2f9cb01c2 100644
--- a/app-text/libmspub/libmspub-9999.ebuild
+++ b/app-text/libmspub/libmspub-9999.ebuild
@@ -3,11 +3,11 @@
EAPI=7
-inherit flag-o-matic
+inherit autotools flag-o-matic
if [[ ${PV} = *9999 ]]; then
EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libmspub.git"
- inherit autotools git-r3
+ inherit git-r3
else
SRC_URI="https://dev-www.libreoffice.org/src/libmspub/${P}.tar.xz"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
@@ -36,7 +36,7 @@ DEPEND="${RDEPEND}
src_prepare() {
default
[[ -d m4 ]] || mkdir "m4"
- [[ ${PV} == *9999 ]] && eautoreconf
+ eautoreconf
}
src_configure() {