summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/tree/tree-2.1.0.ebuild')
-rw-r--r--app-text/tree/tree-2.1.0.ebuild31
1 files changed, 0 insertions, 31 deletions
diff --git a/app-text/tree/tree-2.1.0.ebuild b/app-text/tree/tree-2.1.0.ebuild
deleted file mode 100644
index 2d5b903eee52..000000000000
--- a/app-text/tree/tree-2.1.0.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs flag-o-matic bash-completion-r1
-
-DESCRIPTION="Lists directories recursively, and produces an indented listing of files"
-HOMEPAGE="https://mama.indstate.edu/users/ice/tree/ https://gitlab.com/OldManProgrammer/unix-tree"
-SRC_URI="https://gitlab.com/OldManProgrammer/unix-${PN}/-/archive/${PV}/unix-${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
-
-S=${WORKDIR}/unix-${P}
-
-src_compile() {
- append-lfs-flags
- emake \
- CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS} ${CPPFLAGS}" \
- LDFLAGS="${LDFLAGS}"
-}
-
-src_install() {
- dobin tree
- doman doc/tree*.1
- einstalldocs
- newbashcomp "${FILESDIR}"/${PN}.bashcomp ${PN}
-}