summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/tokumx/files')
-rw-r--r--dev-db/tokumx/files/tokumx-2.0.2-undefined-reference.patch60
1 files changed, 14 insertions, 46 deletions
diff --git a/dev-db/tokumx/files/tokumx-2.0.2-undefined-reference.patch b/dev-db/tokumx/files/tokumx-2.0.2-undefined-reference.patch
index 012498f7ecd0..d56f7745d1e9 100644
--- a/dev-db/tokumx/files/tokumx-2.0.2-undefined-reference.patch
+++ b/dev-db/tokumx/files/tokumx-2.0.2-undefined-reference.patch
@@ -1,47 +1,15 @@
-diff -uNr a/src/third_party/backup/copier.cc b/src/third_party/backup/copier.cc
---- a/src/third_party/backup/copier.cc 2018-07-06 12:43:52.698825122 +0200
-+++ b/src/third_party/backup/copier.cc 2018-07-06 12:41:40.066804121 +0200
-@@ -107,10 +107,12 @@
- int r = 0;
- char *fname = 0;
- size_t n_known = 0;
-+ char *dupname;
- {
- with_mutex_locked tm(&m_todo_mutex, BACKTRACE(NULL));
- // Start with "."
-- m_todo.push_back(strdup("."));
-+ dupname = strdup(".");
-+ m_todo.push_back(dupname);
- n_known = m_todo.size();
- }
- while (n_known != 0) {
-@@ -697,6 +699,7 @@
- int error = 0;
- with_mutex_locked tm(&m_todo_mutex, BACKTRACE(NULL));
- struct dirent const *e = NULL;
-+ char *dupname;
- while((e = readdir(dir)) != NULL) {
- if (!the_manager.copy_is_enabled()) break;
- if(is_dot(e)) {
-@@ -716,8 +719,9 @@
- goto out;
- }
-
-+ dupname = strdup(new_name);
- // Add it to our todo list.
-- m_todo.push_back(strdup(new_name));
-+ m_todo.push_back(dupname);
- TRACE("~~~Added this file to todo list:", new_name);
- }
- }
-@@ -730,7 +734,9 @@
- //
- void copier::add_file_to_todo(const char *file) throw() {
- with_mutex_locked tm(&m_todo_mutex, BACKTRACE(NULL));
-- m_todo.push_back(strdup(file));
-+ char *dupname;
-+ dupname = strdup(file);
-+ m_todo.push_back(dupname);
- }
+diff -uNr a/src/third_party/backup/CMakeLists.txt b/src/third_party/backup/CMakeLists.txt
+--- a/src/third_party/backup/CMakeLists.txt 2018-07-06 20:36:58.242767167 +0200
++++ b/src/third_party/backup/CMakeLists.txt 2018-07-06 20:37:31.575390786 +0200
+@@ -1,11 +1,6 @@
+ cmake_minimum_required(VERSION 2.8.8)
+ project(HotBackup)
- ////////////////////////////////////////////////////////////////////////////////
+-# No implicit templates, since that's how mysql compiles.
+-if (NOT CMAKE_CXX_COMPILER_ID MATCHES Clang)
+- set(CMAKE_CXX_FLAGS "-fno-implicit-templates ${CMAKE_CXX_FLAGS}")
+-endif ()
+-
+ set_property(DIRECTORY APPEND PROPERTY COMPILE_DEFINITIONS
+ _FILE_OFFSET_BITS=64
+ _LARGEFILE64_SOURCE)