summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-erlang/eimp/eimp-1.0.22.ebuild')
-rw-r--r--dev-erlang/eimp/eimp-1.0.22.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-erlang/eimp/eimp-1.0.22.ebuild b/dev-erlang/eimp/eimp-1.0.22.ebuild
new file mode 100644
index 000000000000..38be3d9e5c6b
--- /dev/null
+++ b/dev-erlang/eimp/eimp-1.0.22.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit rebar
+
+DESCRIPTION="Erlang Image Manipulation Process"
+HOMEPAGE="https://github.com/processone/eimp"
+SRC_URI="https://github.com/processone/eimp/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+
+RDEPEND="
+ >=dev-lang/erlang-17.1
+ >=dev-erlang/p1_utils-1.0.25
+ media-libs/gd[png,jpeg,webp]
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( CHANGELOG.md README.md )
+
+src_test() {
+ mkdir -p .eunit/priv/bin || die
+ cp priv/bin/eimp .eunit/priv/bin/ || die
+ rebar_src_test
+}