summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/python-3.4.5.ebuild')
-rw-r--r--dev-lang/python/python-3.4.5.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-lang/python/python-3.4.5.ebuild b/dev-lang/python/python-3.4.5.ebuild
index 860da679f226..f5c7f7d72247 100644
--- a/dev-lang/python/python-3.4.5.ebuild
+++ b/dev-lang/python/python-3.4.5.ebuild
@@ -112,10 +112,6 @@ src_configure() {
einfo "Disabled modules: ${PYTHON_DISABLE_MODULES}"
fi
- # Ensure sed works as expected
- # https://bugs.gentoo.org/594768
- export LC_COLLATE=C
-
if [[ "$(gcc-major-version)" -ge 4 ]]; then
append-flags -fwrapv
fi
@@ -173,6 +169,10 @@ src_configure() {
}
src_compile() {
+ # Ensure sed works as expected
+ # https://bugs.gentoo.org/594768
+ local -x LC_ALL=C
+
# Avoid invoking pgen for cross-compiles.
touch Include/graminit.h Python/graminit.c || die