summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/softhsm/metadata.xml5
-rw-r--r--dev-libs/softhsm/softhsm-2.4.0.ebuild6
-rw-r--r--dev-libs/softhsm/softhsm-2.5.0.ebuild6
3 files changed, 8 insertions, 9 deletions
diff --git a/dev-libs/softhsm/metadata.xml b/dev-libs/softhsm/metadata.xml
index 1db90fe1ffe9..5b486dde6ca3 100644
--- a/dev-libs/softhsm/metadata.xml
+++ b/dev-libs/softhsm/metadata.xml
@@ -6,8 +6,7 @@
<name>Crypto</name>
</maintainer>
<use>
- <flag name="migration-tool">
- Build db migration tool
- </flag>
+ <flag name="gost">Enable gost algorithm</flag>
+ <flag name="migration-tool">Build db migration tool</flag>
</use>
</pkgmetadata>
diff --git a/dev-libs/softhsm/softhsm-2.4.0.ebuild b/dev-libs/softhsm/softhsm-2.4.0.ebuild
index ec4f819aecca..1db7548275ed 100644
--- a/dev-libs/softhsm/softhsm-2.4.0.ebuild
+++ b/dev-libs/softhsm/softhsm-2.4.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -8,7 +8,7 @@ HOMEPAGE="https://www.opendnssec.org/"
SRC_URI="https://www.opendnssec.org/files/source/${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="bindist libressl migration-tool test"
+IUSE="bindist gost libressl migration-tool test"
SLOT="2"
LICENSE="BSD"
@@ -33,7 +33,7 @@ src_configure() {
--disable-p11-kit \
--localstatedir="${EROOT}/var" \
$(use_enable !bindist ecc) \
- $(use_enable !libressl gost) \
+ $(use_enable gost) \
$(use_with migration-tool migrate)
}
diff --git a/dev-libs/softhsm/softhsm-2.5.0.ebuild b/dev-libs/softhsm/softhsm-2.5.0.ebuild
index efb92f3af4d2..a23cda5d73ec 100644
--- a/dev-libs/softhsm/softhsm-2.5.0.ebuild
+++ b/dev-libs/softhsm/softhsm-2.5.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -8,7 +8,7 @@ HOMEPAGE="https://www.opendnssec.org/"
SRC_URI="https://www.opendnssec.org/files/source/${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="bindist libressl migration-tool test"
+IUSE="bindist gost libressl migration-tool test"
SLOT="2"
LICENSE="BSD"
@@ -37,7 +37,7 @@ src_configure() {
--disable-p11-kit \
--localstatedir="${EROOT}/var" \
$(use_enable !bindist ecc) \
- $(use_enable !libressl gost) \
+ $(use_enable gost) \
$(use_with migration-tool migrate)
}