summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/cl-ppcre/cl-ppcre-2.0.11.ebuild11
-rw-r--r--dev-lisp/cl-ppcre/metadata.xml31
2 files changed, 25 insertions, 17 deletions
diff --git a/dev-lisp/cl-ppcre/cl-ppcre-2.0.11.ebuild b/dev-lisp/cl-ppcre/cl-ppcre-2.0.11.ebuild
index 7aa2d5026a04..ba65b3febed6 100644
--- a/dev-lisp/cl-ppcre/cl-ppcre-2.0.11.ebuild
+++ b/dev-lisp/cl-ppcre/cl-ppcre-2.0.11.ebuild
@@ -1,16 +1,14 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
inherit common-lisp-3
-MY_P="v${PV}"
-
DESCRIPTION="CL-PPCRE is a portable regular expression library for Common Lisp."
HOMEPAGE="http://weitz.de/cl-ppcre/
http://www.cliki.net/cl-ppcre"
-SRC_URI="https://github.com/edicl/${PN}/archive/${MY_P}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/edicl/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0"
@@ -28,6 +26,5 @@ src_unpack() {
src_install() {
common-lisp-install-sources *.lisp test/
common-lisp-install-asdf ${PN}
- dodoc CHANGELOG
- dohtml doc/index.html
+ dodoc CHANGELOG doc/index.html
}
diff --git a/dev-lisp/cl-ppcre/metadata.xml b/dev-lisp/cl-ppcre/metadata.xml
index c2fc0d6e9b31..80cabfa13150 100644
--- a/dev-lisp/cl-ppcre/metadata.xml
+++ b/dev-lisp/cl-ppcre/metadata.xml
@@ -5,16 +5,27 @@
<email>common-lisp@gentoo.org</email>
<name>Gentoo Common Lisp Project</name>
</maintainer>
- <longdescription>
-CL-PPCRE is a portable regular expression library for Common Lisp
-which has the following features:
-
- * compatible with Perl
- * fast (outperforms Perl)
- * portable (ANSI Common Lisp)
- * thread-safe
- * includes convenience features
- * well-documented.
+ <longdescription lang="en">
+ CL-PPCRE is a portable regular expression library for Common Lisp
+ which has the following features:
+
+ * compatible with Perl
+ * fast (outperforms Perl)
+ * portable (ANSI Common Lisp)
+ * thread-safe
+ * includes convenience features
+ * well-documented
+ </longdescription>
+ <longdescription lang="es">
+ CL-PPCRE es una biblioteca de expressiones regulares portable
+ para Common Lisp que tiene las siguientes características:
+
+ * Compatible con Perl
+ * Rápida (más rápida que la versión para Perl)
+ * Portable (ANSI Common Lisp)
+ * Segura en la ejecución de hilos (thread-safe)
+ * Incluye características para hacerla cómoda
+ * Bien documentada
</longdescription>
<upstream>
<remote-id type="github">edicl/cl-ppcre</remote-id>