summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/camlp5')
-rw-r--r--dev-ml/camlp5/camlp5-7.11-r1.ebuild3
-rw-r--r--dev-ml/camlp5/camlp5-7.14.ebuild3
-rw-r--r--dev-ml/camlp5/camlp5-8.00.ebuild1
3 files changed, 5 insertions, 2 deletions
diff --git a/dev-ml/camlp5/camlp5-7.11-r1.ebuild b/dev-ml/camlp5/camlp5-7.11-r1.ebuild
index 5f91a735d0e7..6be6bcfd624a 100644
--- a/dev-ml/camlp5/camlp5-7.11-r1.ebuild
+++ b/dev-ml/camlp5/camlp5-7.11-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -35,6 +35,7 @@ src_configure() {
}
src_compile() {
+ ulimit -s 11530000
emake out
if use ocamlopt; then
emake opt
diff --git a/dev-ml/camlp5/camlp5-7.14.ebuild b/dev-ml/camlp5/camlp5-7.14.ebuild
index cd630ba25bd9..6bc2cca9ade9 100644
--- a/dev-ml/camlp5/camlp5-7.14.ebuild
+++ b/dev-ml/camlp5/camlp5-7.14.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -37,6 +37,7 @@ src_configure() {
}
src_compile() {
+ ulimit -s 11530000
emake out
if use ocamlopt; then
emake opt
diff --git a/dev-ml/camlp5/camlp5-8.00.ebuild b/dev-ml/camlp5/camlp5-8.00.ebuild
index df181c7416a9..fe4e5ebe5766 100644
--- a/dev-ml/camlp5/camlp5-8.00.ebuild
+++ b/dev-ml/camlp5/camlp5-8.00.ebuild
@@ -35,6 +35,7 @@ src_configure() {
}
src_compile() {
+ ulimit -s 11530000
emake out
if use ocamlopt; then
emake opt