summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/labltk/labltk-8.06.9.ebuild')
-rw-r--r--dev-ml/labltk/labltk-8.06.9.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/dev-ml/labltk/labltk-8.06.9.ebuild b/dev-ml/labltk/labltk-8.06.9.ebuild
index dabb658293ef..7bce5317f51d 100644
--- a/dev-ml/labltk/labltk-8.06.9.ebuild
+++ b/dev-ml/labltk/labltk-8.06.9.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit findlib
+inherit findlib toolchain-funcs
DESCRIPTION="OCaml interface to the Tcl/Tk GUI framework"
HOMEPAGE="https://garrigue.github.io/labltk/"
@@ -15,7 +15,7 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-li
IUSE="+ocamlopt X"
RDEPEND="dev-lang/tk:=
- <dev-lang/ocaml-4.13
+ <dev-lang/ocaml-4.12
>=dev-lang/ocaml-4.11:=[ocamlopt?,X(+)?]"
DEPEND="${RDEPEND}
dev-ml/findlib
@@ -25,6 +25,14 @@ PATCHES=(
"${FILESDIR}/findlib.patch"
)
+src_prepare() {
+ sed -i \
+ -e "s|ranlib|$(tc-getRANLIB)|" \
+ frx/Makefile \
+ || die
+ default
+}
+
src_configure() {
./configure --use-findlib --verbose $(usex X "--tk-x11" "--tk-no-x11") || die "configure failed!"
}