summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/PEAR-Net_DNS2/PEAR-Net_DNS2-1.4.2.ebuild')
-rw-r--r--dev-php/PEAR-Net_DNS2/PEAR-Net_DNS2-1.4.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-php/PEAR-Net_DNS2/PEAR-Net_DNS2-1.4.2.ebuild b/dev-php/PEAR-Net_DNS2/PEAR-Net_DNS2-1.4.2.ebuild
new file mode 100644
index 000000000000..a6ff20e6416e
--- /dev/null
+++ b/dev-php/PEAR-Net_DNS2/PEAR-Net_DNS2-1.4.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://pear.php.net/get/${MY_P}.tgz"
+DESCRIPTION="Object-oriented PHP5 resolver library used to communicate with a DNS server"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-php/PEAR-PEAR >=dev-lang/php-5.3:*[sockets]"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ local DOCS=( README.md )
+ insinto /usr/share/php
+ doins -r Net
+ einstalldocs
+}
+
+pkg_postinst() {
+ # Register the package from the package.xml file
+ if [ -f "${WORKDIR}/package.xml" ] ; then
+ "${EROOT}usr/bin/peardev" install -nrO --force "${WORKDIR}/package.xml" 2> /dev/null || die
+ fi
+}
+
+pkg_postrm() {
+ # Uninstall known dependency
+ "${EROOT}usr/bin/peardev" uninstall -nrO "pear.php.net/${MY_PN}"
+}