summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/doit/doit-0.32.0-r1.ebuild')
-rw-r--r--dev-python/doit/doit-0.32.0-r1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-python/doit/doit-0.32.0-r1.ebuild b/dev-python/doit/doit-0.32.0-r1.ebuild
index 210fb0296c51..e73b597bd0ed 100644
--- a/dev-python/doit/doit-0.32.0-r1.ebuild
+++ b/dev-python/doit/doit-0.32.0-r1.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
PYTHON_COMPAT=( python3_{6,7} )
DISTUTILS_USE_SETUPTOOLS=rdepend
@@ -20,7 +21,6 @@ RDEPEND="
dev-python/pyinotify[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]"
DEPEND="
- doc? ( dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}] )
test? (
${RDEPEND}
dev-python/mock[${PYTHON_USEDEP}]
@@ -30,7 +30,7 @@ DEPEND="
PDEPEND=">=dev-python/doit-py-0.4.0[${PYTHON_USEDEP}]"
distutils_enable_tests pytest
-distutils_enable_sphinx doc
+distutils_enable_sphinx doc dev-python/sphinx_rtd_theme
PATCHES=(
"${FILESDIR}/${P}_pytest5.4.patch"