summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/elementpath')
-rw-r--r--dev-python/elementpath/Manifest1
-rw-r--r--dev-python/elementpath/elementpath-2.2.2.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/elementpath/Manifest b/dev-python/elementpath/Manifest
index dc55013df24c..b550d553b0c4 100644
--- a/dev-python/elementpath/Manifest
+++ b/dev-python/elementpath/Manifest
@@ -1 +1,2 @@
DIST elementpath-2.2.1.gh.tar.gz 228166 BLAKE2B 0fb0f338a28d155056bd551dc00e634a00a820945e8147ac8a1eb4811aca9e25c563e9011f1a0de9d2aad5761322fb8d9167b64cc5653bbc4012d0631c81fb05 SHA512 eadeb7fbdaa5470c39a59c8f02047aa8f8e76bfa03087bf2a3206f3fad57ae78da82ccee1de5e6c13207c9e22ca5a45de4c1b4b42c62f8141c8f2bacece02ebf
+DIST elementpath-2.2.2.gh.tar.gz 232791 BLAKE2B c28dcae59d29fe70422b6075a4a9627037726574c41e43947c00ba47054924c179e646a5dc01f2247b72f8c58d4fcfcaf411dfa1970cd6ae1cd2fb9f1f3753be SHA512 3aebfa15ec036674d716e6fc91745a14b897f757ade1df945270d39153ecfa9486d0465e9126a6c71470b191690158a853c3871d493e83ac08e065ce2aed3af3
diff --git a/dev-python/elementpath/elementpath-2.2.2.ebuild b/dev-python/elementpath/elementpath-2.2.2.ebuild
new file mode 100644
index 000000000000..f476ad08f7a4
--- /dev/null
+++ b/dev-python/elementpath/elementpath-2.2.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="XPath 1.0/2.0 parsers and selectors for ElementTree and lxml"
+HOMEPAGE="https://github.com/sissaschool/elementpath/
+ https://pypi.org/project/elementpath/"
+SRC_URI="
+ https://github.com/sissaschool/elementpath/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xmlschema[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest