summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/gmpy2')
-rw-r--r--dev-python/gmpy2/Manifest1
-rw-r--r--dev-python/gmpy2/gmpy2-2.2.1.ebuild45
-rw-r--r--dev-python/gmpy2/metadata.xml18
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/gmpy2/Manifest b/dev-python/gmpy2/Manifest
new file mode 100644
index 000000000000..0438447f5105
--- /dev/null
+++ b/dev-python/gmpy2/Manifest
@@ -0,0 +1 @@
+DIST gmpy2-2.2.1.tar.gz 234228 BLAKE2B 80188c6abd30ee5b5ebc4d233d3d97dd78be7f9d21d0649429e87b23d3e6d8b5b9269c792d481f24bd3b43d28e012bdd64ee6bb5d0137e3ac759742c845186c1 SHA512 2a3dc011295a373e10455e1f133aa3063cff24cdac0151cee9f29ce5855c3e44c3e3aab61bf13c11c9df1147b9183c6c387db1cb4dcb270b9dce1a9cb521f5dc
diff --git a/dev-python/gmpy2/gmpy2-2.2.1.ebuild b/dev-python/gmpy2/gmpy2-2.2.1.ebuild
new file mode 100644
index 000000000000..86006d0213be
--- /dev/null
+++ b/dev-python/gmpy2/gmpy2-2.2.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYPI_PN="gmpy2"
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python bindings for GMP, MPC, MPFR and MPIR libraries"
+HOMEPAGE="
+ https://github.com/aleaxit/gmpy/
+ https://pypi.org/project/gmpy2/
+"
+
+LICENSE="LGPL-3+"
+SLOT="2"
+KEYWORDS="amd64 arm arm64 hppa ~loong ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+DEPEND="
+ >=dev-libs/mpc-1.0.2:=
+ >=dev-libs/mpfr-3.1.2:=
+ dev-libs/gmp:0=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/mpmath[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ rm -rf gmpy2 || die
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
diff --git a/dev-python/gmpy2/metadata.xml b/dev-python/gmpy2/metadata.xml
new file mode 100644
index 000000000000..f81f2196a2bb
--- /dev/null
+++ b/dev-python/gmpy2/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ gmpy2 is a C-coded Python extension module that supports
+ multiple-precision arithmetic. gmpy2 supports the GMP multi-precision
+ library, the MPFR (correctly rounded real floating-point arithmetic) and MPC
+ (correctly rounded complex floating-point arithmetic) libraries.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">gmpy2</remote-id>
+ <remote-id type="github">aleaxit/gmpy</remote-id>
+ </upstream>
+</pkgmetadata>