summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/gsd/gsd-2.5.2.ebuild')
-rw-r--r--dev-python/gsd/gsd-2.5.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/gsd/gsd-2.5.2.ebuild b/dev-python/gsd/gsd-2.5.2.ebuild
new file mode 100644
index 000000000000..296fe8d78986
--- /dev/null
+++ b/dev-python/gsd/gsd-2.5.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_P=${P/-/-v}
+DESCRIPTION="GSD - file format specification and a library to read and write it"
+HOMEPAGE="https://github.com/glotzerlab/gsd"
+SRC_URI="https://github.com/glotzerlab/gsd/releases/download/v${PV}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+RDEPEND=${DEPEND}
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ cd "${T}" || die
+ epytest --pyargs gsd
+}