summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ifaddr/ifaddr-0.2.0.ebuild')
-rw-r--r--dev-python/ifaddr/ifaddr-0.2.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/ifaddr/ifaddr-0.2.0.ebuild b/dev-python/ifaddr/ifaddr-0.2.0.ebuild
new file mode 100644
index 000000000000..05222a04124e
--- /dev/null
+++ b/dev-python/ifaddr/ifaddr-0.2.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Enumerate IP addresses on the local network adapters"
+HOMEPAGE="
+ https://github.com/pydron/ifaddr/
+ https://pypi.org/project/ifaddr/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests pytest