summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/kiwi')
-rw-r--r--dev-python/kiwi/Manifest2
-rw-r--r--dev-python/kiwi/kiwi-1.9.39.2.ebuild46
-rw-r--r--dev-python/kiwi/kiwi-1.9.40.ebuild48
-rw-r--r--dev-python/kiwi/metadata.xml9
4 files changed, 105 insertions, 0 deletions
diff --git a/dev-python/kiwi/Manifest b/dev-python/kiwi/Manifest
new file mode 100644
index 000000000000..20efe8a7c6dc
--- /dev/null
+++ b/dev-python/kiwi/Manifest
@@ -0,0 +1,2 @@
+DIST kiwi-gtk-1.9.39.2.tar.gz 678242 SHA256 6992d278883ca4ca7bdf3e908e8f091c8fe9b61fdbdd0f0a33c4ba015dbf8458 SHA512 fa54623bb95a7ebe03e87c10d3bb271bd98fa4f40f7244f399cf2f86bf9b2e257666fc58caa4cc83d91a3c7fcf06817886ef5cab1baff58c8cbfdf6cfd12a554 WHIRLPOOL 907c50d89b8a534ba6712137f00214426e937f74d8ba6b49a247113ec7a9a60534a1cfa26d8337e382190bb3901d17d3d555333a7ed1b36cb167194167697e7d
+DIST kiwi-gtk-1.9.40.tar.gz 675794 SHA256 368e65e915f1ea8f69a174b13a116dee95318ca23a4c631f7f0879b4584748e1 SHA512 1fa210bcf00eeb8513f1b3fde968a212ac79c286a50a09427b0e3dffc5e78d739e70101ba4a0086d2002ac6907bc40b0103604f486b72e1bec36c9912ae6f2b6 WHIRLPOOL f7ce0189760c6ed3387ae2f0e1a4df82ffd7a692718d3ddf092ec616cf2403c7aa5781b1c6b26908d44ac13f230fc874da685bebfceb026a6a291022c1420b29
diff --git a/dev-python/kiwi/kiwi-1.9.39.2.ebuild b/dev-python/kiwi/kiwi-1.9.39.2.ebuild
new file mode 100644
index 000000000000..c663480a5477
--- /dev/null
+++ b/dev-python/kiwi/kiwi-1.9.39.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 versionator virtualx
+
+DESCRIPTION="Kiwi is a pure Python framework and set of enhanced PyGTK widgets"
+HOMEPAGE="http://www.async.com.br/projects/kiwi/
+ https://launchpad.net/kiwi
+ http://pypi.python.org/pypi/kiwi-gtk"
+MY_PN="${PN}-gtk"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="examples test"
+
+RDEPEND=">=dev-python/setuptools-0.8[${PYTHON_USEDEP}]
+ >=dev-python/pygtk-2.24[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ sed -e "s:share/doc/kiwi:share/doc/${PF}:g" -i setup.py || die "sed failed"
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ testing() {
+ "${PYTHON}" -m unittest discover || die "tests failed"
+ }
+ VIRTUALX_COMMAND=virtualmake testing
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+ rmdir "${D}"usr/share/doc/${PF}/{api,howto} || die
+}
diff --git a/dev-python/kiwi/kiwi-1.9.40.ebuild b/dev-python/kiwi/kiwi-1.9.40.ebuild
new file mode 100644
index 000000000000..70c22713579d
--- /dev/null
+++ b/dev-python/kiwi/kiwi-1.9.40.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 versionator virtualx
+
+DESCRIPTION="Kiwi is a pure Python framework and set of enhanced PyGTK widgets"
+HOMEPAGE="http://www.async.com.br/projects/kiwi/
+ https://launchpad.net/kiwi
+ http://pypi.python.org/pypi/kiwi-gtk"
+MY_PN="${PN}-gtk"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="examples test"
+
+RDEPEND=">=dev-python/setuptools-0.8[${PYTHON_USEDEP}]
+ >=dev-python/pygtk-2.24[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ sed -e "s:share/doc/kiwi:share/doc/${PF}:g" -i setup.py || die "sed failed"
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # There is one fail of a test repeated 3 times in tests/test_ui.py however
+ # they are shy with their bug tracker. The fail is not a failing of the package's core modules
+ testing() {
+ "${PYTHON}" -m unittest discover || die "tests failed"
+ }
+ VIRTUALX_COMMAND=virtualmake testing
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+ rmdir "${D}"usr/share/doc/${PF}/{api,howto} || die
+}
diff --git a/dev-python/kiwi/metadata.xml b/dev-python/kiwi/metadata.xml
new file mode 100644
index 000000000000..2c9d990566e6
--- /dev/null
+++ b/dev-python/kiwi/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">kiwi-gtk</remote-id>
+ <remote-id type="launchpad">kiwi</remote-id>
+ </upstream>
+</pkgmetadata>