summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/oauth2client/oauth2client-2.0.0.ebuild')
-rw-r--r--dev-python/oauth2client/oauth2client-2.0.0.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-python/oauth2client/oauth2client-2.0.0.ebuild b/dev-python/oauth2client/oauth2client-2.0.0.ebuild
index db2bdb7b1808..23f97404115d 100644
--- a/dev-python/oauth2client/oauth2client-2.0.0.ebuild
+++ b/dev-python/oauth2client/oauth2client-2.0.0.ebuild
@@ -32,6 +32,13 @@ DEPEND="${RDEPEND}
# Needs network
RESTRICT=test
+python_prepare_all() {
+ sed \
+ -e "s:find_packages():find_packages(exclude=['tests']):" \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
python_test() {
nosetests || die
}