summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/openapi-schema-validator')
-rw-r--r--dev-python/openapi-schema-validator/Manifest2
-rw-r--r--dev-python/openapi-schema-validator/files/openapi-schema-validator-0.6.2-test.patch24
-rw-r--r--dev-python/openapi-schema-validator/openapi-schema-validator-0.6.3.ebuild (renamed from dev-python/openapi-schema-validator/openapi-schema-validator-0.6.2-r1.ebuild)8
3 files changed, 2 insertions, 32 deletions
diff --git a/dev-python/openapi-schema-validator/Manifest b/dev-python/openapi-schema-validator/Manifest
index 371a9906cd90..14910018502e 100644
--- a/dev-python/openapi-schema-validator/Manifest
+++ b/dev-python/openapi-schema-validator/Manifest
@@ -1 +1 @@
-DIST openapi_schema_validator-0.6.2.tar.gz 11860 BLAKE2B c9f540998e3e69f987900caa8b12e5bab258c9046babd0705e168d57817666302e000b7b69a71ea74f37cc5bd363a90a45ac29a31e32b91dcc6f48adccb21489 SHA512 709f7a7c00bf050fa2c48a05bcd4e83ad309029f62df10ba61424cb46413cb9218bf2930f24a4db09f7648e51135f346855a4d58ce836b315a82a9986b655932
+DIST openapi_schema_validator-0.6.3.tar.gz 11550 BLAKE2B 5080b089301a651514b1c5689f28d94893bfcae66ee9624f17bf59a017d9246b23855ae66fc82e0d74a42810978dfeb4b84029c9dbb7d6724885e765b3d9162c SHA512 f335fc4dd1530cbcdd63ece998a42b27497e31e7191fc8e65437ae1810a7bc12e313d8eac982368d33a643502d13e1f69f6b00f710b4e90c50961bdfe7150ff9
diff --git a/dev-python/openapi-schema-validator/files/openapi-schema-validator-0.6.2-test.patch b/dev-python/openapi-schema-validator/files/openapi-schema-validator-0.6.2-test.patch
deleted file mode 100644
index 2937a867a1d2..000000000000
--- a/dev-python/openapi-schema-validator/files/openapi-schema-validator-0.6.2-test.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From dfb83c2961bcb6541c8c5e483f10389c77a4f5a0 Mon Sep 17 00:00:00 2001
-From: p1c2u <maciag.artur@gmail.com>
-Date: Sat, 16 Mar 2024 17:05:13 +0000
-Subject: [PATCH 2/2] Jsonschema 4.20 prefixItems test fix
-
-Upstream-PR: https://github.com/python-openapi/openapi-schema-validator/pull/165
-
-diff --git a/tests/integration/test_validators.py b/tests/integration/test_validators.py
-index 07bc4df..07dfaa9 100644
---- a/tests/integration/test_validators.py
-+++ b/tests/integration/test_validators.py
-@@ -863,5 +863,10 @@ def test_array_prefixitems_invalid(self, validator_class, value):
- with pytest.raises(ValidationError) as excinfo:
- validator.validate(value)
-
-- error = "Expected at most 4 items, but found 5"
-- assert error in str(excinfo.value)
-+ errors = [
-+ # jsonschema < 4.20.0
-+ "Expected at most 4 items, but found 5",
-+ # jsonschema >= 4.20.0
-+ "Expected at most 4 items but found 1 extra",
-+ ]
-+ assert any(error in str(excinfo.value) for error in errors)
diff --git a/dev-python/openapi-schema-validator/openapi-schema-validator-0.6.2-r1.ebuild b/dev-python/openapi-schema-validator/openapi-schema-validator-0.6.3.ebuild
index 09270377ce90..b01f53d6e0a3 100644
--- a/dev-python/openapi-schema-validator/openapi-schema-validator-0.6.2-r1.ebuild
+++ b/dev-python/openapi-schema-validator/openapi-schema-validator-0.6.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022-2024 Gentoo Authors
+# Copyright 2022-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -28,13 +28,7 @@ RDEPEND="
distutils_enable_tests pytest
src_prepare() {
- local PATCHES=(
- "${FILESDIR}/${P}-test.patch"
- )
-
distutils-r1_src_prepare
sed -i -e '/--cov/d' pyproject.toml || die
- # unpin dependencies
- sed -i -e 's:\^:>=:' pyproject.toml || die
}