summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pep8/pep8-1.7.1-r1.ebuild')
-rw-r--r--dev-python/pep8/pep8-1.7.1-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pep8/pep8-1.7.1-r1.ebuild b/dev-python/pep8/pep8-1.7.1-r1.ebuild
new file mode 100644
index 000000000000..66396c091a91
--- /dev/null
+++ b/dev-python/pep8/pep8-1.7.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python style guide checker"
+HOMEPAGE="https://github.com/PyCQA/pep8 https://pypi.org/project/pep8/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # AssertionError: 7 is not false : 7 failure(s)
+ sed -i -e 's:test_checkers_testsuite:_&:' \
+ testsuite/test_all.py || die
+
+ distutils-r1_python_prepare_all
+}