summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygtk')
-rw-r--r--dev-python/pygtk/files/pygtk-2.24.0-pango-1.44.patch41
-rw-r--r--dev-python/pygtk/pygtk-2.24.0-r5.ebuild2
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pygtk/files/pygtk-2.24.0-pango-1.44.patch b/dev-python/pygtk/files/pygtk-2.24.0-pango-1.44.patch
new file mode 100644
index 000000000000..b4ed200d0046
--- /dev/null
+++ b/dev-python/pygtk/files/pygtk-2.24.0-pango-1.44.patch
@@ -0,0 +1,41 @@
+From 4aaa48eb80c6802aec6d03e5695d2a0ff20e0fc2 Mon Sep 17 00:00:00 2001
+From: Jordan Petridis <jpetridis@gnome.org>
+Date: Thu, 24 Oct 2019 22:58:36 +0200
+Subject: [PATCH] Drop the PangoFont find_shaper virtual method
+
+This API has been removed from Pango 1.44.6, because it was completely
+unused by anything.
+
+However, PyGTK tries to bind everything, even unused API.
+
+Removing this from PyGTK means we can build it against the latest Pango
+again.
+
+https://gitlab.gnome.org/GNOME/pango/issues/417
+---
+ pango.defs | 9 ---------
+ 1 file changed, 9 deletions(-)
+
+diff --git a/pango.defs b/pango.defs
+index 6935c964..da968f58 100644
+--- a/pango.defs
++++ b/pango.defs
+@@ -1391,15 +1391,6 @@
+ )
+ )
+
+-(define-virtual find_shaper
+- (of-object "PangoFont")
+- (return-type "PangoEngineShape*")
+- (parameters
+- '("PangoLanguage*" "lang")
+- '("guint32" "ch")
+- )
+-)
+-
+ (define-virtual get_glyph_extents
+ (of-object "PangoFont")
+ (return-type "none")
+--
+2.24.1
+
diff --git a/dev-python/pygtk/pygtk-2.24.0-r5.ebuild b/dev-python/pygtk/pygtk-2.24.0-r5.ebuild
index 094ca5ba9e02..f86cab545d53 100644
--- a/dev-python/pygtk/pygtk-2.24.0-r5.ebuild
+++ b/dev-python/pygtk/pygtk-2.24.0-r5.ebuild
@@ -50,6 +50,8 @@ PATCHES=(
"${FILESDIR}/${P}-test_dialog.patch"
# Fix build on Darwin
"${FILESDIR}/${PN}-2.24.0-quartz-objc.patch"
+ # x11-libs/pango-1.44
+ "${FILESDIR}/${PN}-2.24.0-pango-1.44.patch"
)
src_prepare() {