summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pysvn')
-rw-r--r--dev-python/pysvn/pysvn-1.9.11.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/dev-python/pysvn/pysvn-1.9.11.ebuild b/dev-python/pysvn/pysvn-1.9.11.ebuild
index 697dfa14f70f..30f062bcb761 100644
--- a/dev-python/pysvn/pysvn-1.9.11.ebuild
+++ b/dev-python/pysvn/pysvn-1.9.11.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
-inherit eutils distutils-r1 toolchain-funcs
+PYTHON_COMPAT=( python3_{7,8} )
+DISTUTILS_IN_SOURCE_BUILD=true
+inherit distutils-r1 toolchain-funcs
DESCRIPTION="Object-oriented python bindings for subversion"
HOMEPAGE="https://pysvn.sourceforge.io/"
@@ -22,8 +23,6 @@ RDEPEND="${DEPEND}"
PATCHES=( "${FILESDIR}"/${P}-respect-flags.patch )
-DISTUTILS_IN_SOURCE_BUILD=true
-
python_prepare_all() {
# Don't use internal copy of dev-python/pycxx.
rm -r Import || die